2 Replies Latest reply on Dec 18, 2017 6:28 PM by Intel Corporation

    Retrieve data from failed RAID 1

    msf4087

      I had two disks in a RAID 1 configuration.  I used the CTRL-I to mark one as non-RAID to "borrow" for a new OS install, assuming I could rebuild the array when I got a replacement second drive.  However, the RAID array is now marked as "failed" and I have no options either in CTRL-I or RST software for rebuilding to a new drive.  I even tried returning the borrowed drive (marked as spare) to the controller but it still gives no option for rebuilding. 

       

      When I look through documentation it sounds like there should be options to rebuild the array, but since I do not have those options I am worried that I am missing something.  From reading the other posts it sounds like if I mark the other disk as non-RAID then I will get a disk with my data from the original array.  However, I have yet to see anyone respond that it worked for them.  If I mark the sole remaining drive as non-RAID, will I have a drive containing data or will I simply complete the data loss and have a second unreadable drive?

       

      Attaching images of status details for the failed array, the good disk in the array, the missing disk in the array and the same disk in the system marked as a spare.  Note, the Serial Number of the missing disk matches the spare except that in the array the SN cuts off the first "W" and tacks on a ":0" at the end.  This is not the case on the good drive in the array. 

       

      Using latest version of RST: 15.8.1.1007