1 Reply Latest reply on Dec 12, 2017 3:15 PM by Intel Corporation

    OFFBOARD mode using Intel Aero

    kkumar12

      Hey!

       

      I've been tinkering around with the Intel Aero RTF kit. I've successfully updated the BIOS, OS, etc. I've recalibrated the sensors using QGroundControl via Wi-Fi. When I arm the drone and try to fly it in Manual mode it doesn't seem to be flying in a stable fashion.

       

      Right after lifting off the ground the drone seems to be going front and back and it is not stable in the same place. I even tried with position control mode and it still was oscillating a lot (but better response than manual mode, not sure why that is happening)

       

      I would like to send out custom setpoint_velocity or setpoint_position values to the Aero by switching to OFFBOARD mode. I cannot try that out owing to the lack of control in the manual mode.

       

      Any assistance will be very much appreciated!

       

      Note: I ran my OFFBOARD control on the PX4 SITL, and the response was very satisfactory. I would like to know if it is possible to implement the same in Aero, and if yes, how can I make it better?!

       

      Regards,

      Kumar

        • 1. Re: OFFBOARD mode using Intel Aero
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Kumar,

          Thank you for your interest in the Aero RTF Drone, I understand you are having flight stability issues. Can you please provide me the output of the following command:
          aero-get-version.py

          Have you also flashed the flight controller? You can find the PX4 or Ardupilot flight stack in the /etc/aerofc and flash it with aerofc-update.sh <px4 or ardupilot>.px4

          In manual mode, the drone will not use the GPS nor barometer to stabilize the drone. You mentioned seeing similar behavior in GPS mode, is the GPS antenna firmly attached and in an upward position?

          Regards,
          Jesus