2 Replies Latest reply on Dec 13, 2017 12:45 PM by Intel Corporation

    Monoprice 4k Monitor Stuck at 1280x720

    kevsox33

      Hi all. I recently purchased this 4k monitor https://www.monoprice.com/product?p_id=27771. I know the 4k works because I used it with my Xbox One S. However, when using the included HDMI 2.0 cable to plug into my computer (integrated graphics (Intel HD-630) through the i7-7700, Gigabyte H270-HD3P, advertised native 4k@60hz), it gets stuck at 1280x720 resolution in the Intel Graphics Control Panel and Windows 10 display settings. I also tried to plug this monitor into a new laptop and got the same result - so it seems to be isolated to the Intel software maybe? Even trying a custom resolution does not work. All my 1920x1080 monitors get recognized correctly by both desktop and laptop, I just can't make the resolution change for this Monoprice monitor. I've uninstalled and reinstalled the graphics driver from the latest version and tried the one specifically from the Gigabyte website. With the Intel graphics driver completely uninstalled, the Microsoft basic graphics driver allows the monitor to be at 1920x1080, but no more. Any guidance would be appreciated. Also attached are my Intel SSU results.