3 Replies Latest reply on Dec 4, 2017 5:44 AM by Al Hill

    asus sabertooth p67 i7-2600k with g.skill ripjaws kits, RAM issue

    psixgame

      Hello!

      Does anybody have same set as I have:

      asus sabertooth p67

      G Skill Ripjaws F3-12800CL7-2GBRM (2x2GB)

      G Skill Ripjaws F3-10666CL7-4GBRH (2x4GB)

      Intel i7-2600k?

      The problem is that mb sees only 8GB of RAM when all sticks are installed. Whatever I did, i couldnt get 12GB. I see 8GB of ram In bios, but also I can see all sticks installed, can read infrormation about every slot: timings, voltage etc. I have tried all things I can do: software: changing bios options for 100500 times, voltages, timings, enabling-disabling various stuff etc; hardware - placed every stick in every slot, combined them in all possible ways, cleaned connectors, slots, checked cpu pins for bent, changed cmos battery, tryied another pairs of ram - got previous 8GB max, but my ram works perfectly on other machines.

      I have this problem for years now, tried many times to fix it, but without success. Its not very critical to me, because I still have 8GB ram and its more or less enought for me, but anyway i want to know wtf can be reason for this problem.