10 Replies Latest reply on Mar 25, 2010 12:23 PM by Snakeyeskm

    X-25M Unable to update firmware

    TroelsL

      I've just got a brand new X-25M drive which causes Windows 7 to lock up when performing the last steps of installation. I've tried on both a ASUS Striker II Formula and a ASUS P5E Deluxe.

       

      I read a few places online (including here) that updating the firmware might solve the problem, so I burned the .iso to a DVD and booted it. The problem is that when it reaches "Scanning system for Intel SSDs......" it stops there, cursor blinking.

       

      I've experimented with various AHCI/IDE modes - disabling S.M.A.R.T. etc. to no avail. I get no error (that it is unable to detect the drive).

       

      Is there anything I can do, or is it a faulty drive?

        • 1. Re: X-25M Unable to update firmware
          Dverez

          You should`ve more success with ASUS P5E Deluxe because it has Intel chipset.

          Lot of times the Sata cable connector becoming loose, try to change it for another one or a brand new one.

          The latest firmware version is 2CV102HD.

           

          When you trying to install windows, connect your SSD to Sata1 port and disconnect the other HDDs, set Sata to AHCI in BIOS.

          1 of 1 people found this helpful
          • 2. Re: X-25M Unable to update firmware
            TroelsL

            I doubt it's the cable, as I've been able to install Windows almost completely with it, but it's worth a try unless someone else has input.

             

            I am able to detect the drive perfectly in Windows, create new partitions and install up to the point where it boots. After boot, it hangs at the logo. Not even safe mode will boot.

             

            But in the Intel utility, it just hangs during detection as described above. (No errors, just hangs). I have tried AHCI mode as well as IDE. I have placed it in port 1, and disabled all other ports.

            • 3. Re: X-25M Unable to update firmware
              Dverez

              Have you checked your SSD Firmware version?

              Maybe worth to check the motherboard firmware version too, or have a look in the motherboard manufacturer`s forum.

               

              My last idea is if you can see your ssd in windows (Vista/win7), (boot from another drive), try to format it and install windows on, without formatting that time.

              • 4. Re: X-25M Unable to update firmware
                TroelsL

                Thanks for the input so far. The drive belongs to a friend, and I will try from windows on his normal disk soon.

                • 5. Re: X-25M Unable to update firmware
                  mmintel

                  I am having the same problem.  I bought a gen2 80gb intel x-25m.  I have updated my mobo's bios as far as I can without a mod.  I have cloned Windows 7 onto the drive using Acronis True Image.  I cannot update the firmware using the downloadable ISO.  It hangs at "Scanning system for Intel SSD's".  I have seen a post on another site that recommended booting the firmware from a usb stick.  I have tried that, but have had no success and feel that I should not have to go to such lengths to simply update the firmware.  Obviously my mobo recognizes the ssd, seeing as how I can boot from it.

                   

                  At this point I am ready to return the drive as it truly isn't that much faster than a standard 7200rpm.

                   

                  Intel, step up, answer this issue with a WINDOWS-BASED firmware update, asap.

                  • 6. Re: X-25M Unable to update firmware
                    GTVic

                    I was unable to detect but after switching to AHCI it worked fine even though I had 2 other HDs and a DVD burner connected and the SSD was not on the first connector. I am using a GA-P55A-UD4P.

                     

                    Perhaps you are not waiting long enough. It takes a long time to find the drive, maybe 30 seconds to 1 minute.

                    1 of 1 people found this helpful
                    • 7. Re: X-25M Unable to update firmware
                      mmintel

                      I have no way of checking AHCI in the bios, as this mobo has a proprietary setup.  I made the switch to AHCI in Windows using a registry edit.

                       

                      I have waited as long as 12 hours, it never finds the ssd.  It just hangs there.

                       

                      INTEL - A windows-based solution please?  And a better setup guide would be nice.  People shouldn't have to fumble around trying to get these things to work.

                      • 8. Re: X-25M Unable to update firmware
                        TroelsL

                        Well.. By some combination of black magic and pure, blind luck I got the HDD updated. My solution?

                         

                        I added all the other drives back in, and it worked. (!) I was already on latest firmware.

                        • 9. Re: X-25M Unable to update firmware
                          TroelsL

                          See previous post.

                          • 10. Re: X-25M Unable to update firmware
                            Snakeyeskm

                            Before updating the firmware, go into BIOS and set the drive to IDE. Once the firmware has been updated reset the bios to the original setting.