3 Replies Latest reply on Dec 7, 2017 3:56 AM by RobeDM

    My distributed mpi executions never finish

    RobeDM

      Hello,

       

      I am trying to test some distributed code (hybrid MPI/openmp).

       

      My tasks never finish so I have tried an mpi hello world and the result is always the same:

       

      >>qstat

      Job ID                    Name             User            Time Use S Queue

      ------------------------- ---------------- --------------- -------- - -----

      28637.c009                 myhello          u7040           00:00:00 R batch         

      28638.c009                 myhello          u7040           00:00:00 R batch

       

      >>qstat -a

      Job ID                  Username    Queue    Jobname          SessID  NDS   TSK   Memory      Time    S   Time

      ----------------------- ----------- -------- ---------------- ------ ----- ------ --------- --------- - ---------

      28637.c009              u7040       batch    myhello           93273     3      3       --   06:00:00 R  00:11:03

      28638.c009              u7040       batch    myhello           93328     1      1       --   06:00:00 R  00:04:15

       

       

       

      This is an example of my mpi "hello world" script

       

      #PBS -l nodes=3:skl

      cd $PBS_O_WORKDIR

      echo Launching the parallel job from mother superior `hostname`...

      mpirun -machinefile $PBS_NODEFILE ./hello_mpi

       

      Am I doing anything wrong?