3 Replies Latest reply on Dec 15, 2017 7:54 AM by Anju_Paul

    Installing intelpython2_full on DevCloud

    EdF

      I am having trouble installing the python2 full version.  I was able to install the python3 version. Can someone help me install the conda2 full version?

       

      Steps to reproduce: I tried installing Python following the instructions at https://access.colfaxresearch.com/?p=learn

      Expected: a message saying that the conda environment is created.

       

      Observed: I received the following error upon submitting

      (root) [u6184@c009 ~]$ conda create -n  intelpython2_full python=2

      ...

      ERROR conda.core.link:_execute_actions(335): An error occurred while installing package 'intel::setuptools-27.2.0-py27_intel_0'.

      CondaError: Cannot link a source that does not exist. /glob/intel-python/versions/2018/intelpython2/pkgs/setuptools-27.2.0-py27_intel_0/lib/python2.7/site-packages/setuptools/lib2to3_ex.pyc

       

      Attempting to roll back.

       

      What I have tried:  Upon looking into the dir I see that this file is indeed not there:

       

      (root) [u6184@c009 ~]$ ls /glob/intel-python/versions/2018/intelpython2/pkgs/setuptools-27.2.0-py27_intel_0/lib/python2.7/site-packages/setuptools

      archive_util.py   extern         msvc.pyo           sandbox.py         unicode_utils.pyo

      archive_util.pyc  __init__.py    package_index.py   sandbox.pyc        utils.py

      archive_util.pyo  __init__.pyc   package_index.pyc  sandbox.pyo        utils.pyc

      command           __init__.pyo   package_index.pyo  script (dev).tmpl  utils.pyo

      depends.py        launch.py      py26compat.py      script.tmpl        version.py

      depends.pyc       launch.pyc     py26compat.pyc     site-patch.py      version.pyc

      depends.pyo       launch.pyo     py26compat.pyo     site-patch.pyc     version.pyo

      dist.py           lib2to3_ex.py  py27compat.py      site-patch.pyo     windows_support.py

      dist.pyc          monkey.py      py27compat.pyc     ssl_support.py     windows_support.pyc

      dist.pyo          monkey.pyc     py27compat.pyo     ssl_support.pyc    windows_support.pyo

      extension.py      monkey.pyo     py31compat.py      ssl_support.pyo

      extension.pyc     msvc.py        py31compat.pyc     unicode_utils.py

      extension.pyo     msvc.pyc       py31compat.pyo     unicode_utils.pyc

       

      Note that the source file is there.  I tried generating the pyc myself, but the dir is read only.  

       

      (root) [u6184@c009 ~]$ python -m compileall /glob/intel-python/versions/2018/intelpython2/pkgs/setuptools-27.2.0-py27_intel_0/lib/python2.7/site-packages/setuptools/lib2to3_ex.py

      Compiling /glob/intel-python/versions/2018/intelpython2/pkgs/setuptools-27.2.0-py27_intel_0/lib/python2.7/site-packages/setuptools/lib2to3_ex.py ...

      Sorry [Errno 30] Read-only file system: '/glob/intel-python/versions/2018/intelpython2/pkgs/setuptools-27.2.0-py27_intel_0/lib/python2.7/site-packages/setuptools/lib2to3_ex.pyc'

       

      Can someone with permissions compile the file or can someone suggest other work-arounds to try?

       

        • 1. Re: Installing intelpython2_full on DevCloud
          Rajeswari_Ponnuru

          Hi,

           

          We are also facing the same issue with Python 2. We have posted the issue to product SME. Will get back to you.

           

          Thanks,

          Rajeswari Ponnuru.

          • 2. Re: Installing intelpython2_full on DevCloud
            Ratheesh_Intel

            Hi,

             

                Now you can try installing python 2. Please try the same steps you followed and requesting you to confirm the status.

             

            Thanks & Regards

            Ratheesh A

            • 3. Re: Installing intelpython2_full on DevCloud
              Anju_Paul

              Hi,

               

              Please check if you had already added intel channel. If yes, please remove and try,

               

              conda config --get channels # This will give you all the available channels.

              conda config --remove channels intel # Run this command only if you find the intel channel is listed for the above command

               

              Please try the following steps  after the above commands and let me know if you face any issue:

               

              qsub -I

              conda create –n ipy2full python=2

              source activate ipy2full

              conda install intelpython2_full

               

              You can also try conda clean --all and try again if you still face issue.

              If none of this works, please share what you get for the command "which python" and provide the error you got, if it is different from the one before

               

              Regards,

              Anju