5 Replies Latest reply on Dec 7, 2017 9:34 AM by Intel Corporation

    Intel ME update breaks HDCP 2.2?

    Gary_Berry

      Hi. My apologies if this is not the correct place to post this message. I figured it was the most relevant since it had to do with an HDMI handshake protocol (HDCP 2.2 in particular).

       

      I recently installed a fix for INTEL-SA-00086. After installing the update supplied by my motherboard manufacturer, rebooting my PC, and confirming that the correct ME version was listed in the UEFI, I tried to watch an Ultra HD Blu-Ray disc. Playback failed. I saw an odd error message from PowerDVD and used Cyberlink's playback advisor to make sure everything was in line. Much to my surprise, it said that HDCP 2.2 was "not available." There's no reason I know of why this should be the case. To be safe, I reinstalled the latest Intel display driver. No dice. HDCP 2.2 is still marked as not being available.

       

      I'm writing to seek further advisement. To be honest, my gut suspicion is that this is an ME issue. Before installing the ME fix, there had been some playback issues under certain circumstances. For example, when trying to watch UHD discs (and Netflix using various apps and browsers), the video would drop out every few seconds, like a handshake had failed and needed to be done again. Something about the ME fix might have been the fatal blow. To be clear, before the ME fix was installed, the new display driver had dropouts but I was able to play back UHD discs, even if the end result was essentially unwatchable.

       

      As a troubleshooting step, I reinstalled my older display drivers. No luck. HDCP 2.2 was still broken. So, it's almost certainly an ME issue, unless the display drivers need some sort of update (or Cyberlink's software needs an update, which wouldn't surprise me at all).

       

      Here's what I consider to be the relevant portion of my setup. There's other stuff but I don't think it's relevant.

       

      ASRock Fatal1ty Z370 Gaming-ITX/ac motherboard (1.11 beta BIOS)

      Coffee Lake i7-8700 CPU

      LG WH16NS60 Ultra HD Blu-Ray drive

      Windows 10 (1709 - fully up-to-date)

      PowerDVD 17 Ultra  (fully up-to-date)

      Intel UHD 630 driver version 15.60.0.4849

      Intel ME consumer driver version 11.8.50.3425

      No discrete graphics cards

       

      Thanks.

        • 1. Re: Intel ME update breaks HDCP 2.2?
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Thank you very much for contacting the Intel® Graphics communities. We are sorry to hear there is a video problem with your computer.

          In order to provide the most accurate response, we will do further research on this matter, as soon as I get any updates I will post all the details on this thread.

          Any further questions, please let me know.

          Regards,
          Alberto R

          • 2. Re: Intel ME update breaks HDCP 2.2?
            Gary_Berry

            Hello. Are there are updates? I'm stuck at this point. I can't downgrade the Intel ME firmware to the original version (11.7.4.3314) and get error 8805, which basically says the SVN doesn't allow downgrades. Reinstalling firmware, graphics drivers, ME drivers (11.7.0.1032), etc. None of it works. I'm assuming the Protected Audio Video Path (PAVP) is either broken somehow, or Cyberlink is misinterpreting data it's receiving.

             

            I do have one last ace in the hole. I did find MEInfo and was able to run it. I'll see if I can find someone who hasn't upgraded their motherboard and can get them to report back. In any event, here's what I'm seeing. Maybe this will help an engineer troubleshoot where the failure is occurring. Nothing jumps out at me but I don't totally understand ME.

             

            Thanks.

             

            ------------

            Intel(R) MEInfo Version: 11.6.25.1229

            Copyright(C) 2005 - 2017, Intel Corporation. All rights reserved.

             

             

             

            Intel(R) ME code versions:

             

            BIOS Version                                 L1.11

            MEBx Version                                 0.0.0.0000

            GbE Version                                  0.2

            Vendor ID                                    8086

            PCH Version                                  0

            FW Version                                   11.8.50.3425 H

            LMS Version                                  11.7.0.1037

            MEI Driver Version                           11.7.0.1032

            Wireless Hardware Version                    2.1.77

            Wireless Driver Version                      20.10.2.2

             

            FW Capabilities                              0x31101140

             

                Intel(R) Capability Licensing Service - PRESENT/ENABLED

                Protect Audio Video Path - PRESENT/ENABLED

                Intel(R) Dynamic Application Loader - PRESENT/ENABLED

                Intel(R) Platform Trust Technology - PRESENT/DISABLED

             

            TLS                                          Disabled

            Last ME reset reason                         Firmware reset

            Local FWUpdate                               Enabled

            BIOS Config Lock                             Enabled

            GbE Config Lock                              Enabled

            Host Read Access to ME                       Enabled

            Host Write Access to ME                      Disabled

            Host Read Access to EC                       Disabled

            Host Write Access to EC                      Disabled

            SPI Flash ID 1                               C22018

            SPI Flash ID 2                               Unknown

            BIOS boot State                              Post Boot

            OEM ID                                       00000000-0000-0000-0000-000000000000

            Capability Licensing Service                 Enabled

            OEM Tag                                      0x00000000

            Slot 1 Board Manufacturer                    0x00000000

            Slot 2 System Assembler                      0x00000000

            Slot 3 Reserved                              0x00000000

            M3 Autotest                                  Disabled

            C-link Status                                Disabled

            Independent Firmware Recovery                Disabled

            EPID Group ID                                0xFFB

            LSPCON Ports                                 None

            5K Ports                                     None

            OEM Public Key Hash FPF                      0000000000000000000000000000000000000000000000000000000000000000

            OEM Public Key Hash ME                       0000000000000000000000000000000000000000000000000000000000000000

            ACM SVN FPF                                  0x0

            KM SVN FPF                                   0x0

            BSMM SVN FPF                                 0x0

            GuC Encryption Key FPF                       0000000000000000000000000000000000000000000000000000000000000000

            GuC Encryption Key ME                        0000000000000000000000000000000000000000000000000000000000000000

             

                                                         FPF                      ME

                                                         ---                      --

            Force Boot Guard ACM                         Disabled                 Disabled

            Protect BIOS Environment                     Disabled                 Disabled

            CPU Debugging                                Enabled                  Enabled

            BSP Initialization                           Enabled                  Enabled

            Measured Boot                                Disabled                 Disabled

            Verified Boot                                Disabled                 Disabled

            Key Manifest ID                              0x0                      0x0

            Enforcement Policy                           0x0                      0x0

            PTT                                          Enabled                  Enabled

            PTT Lockout Override Counter                 0x0

            EK Revoke State                              Not Revoked

            PTT RTC Clear Detection FPF                  0x0

            • 3. Re: Intel ME update breaks HDCP 2.2?
              Gary_Berry

              Okay. After doing a lot of research elsewhere - Intel, ASRock, and Cyberlink all continue to ignore me - it looks like the problem might have to do with the ME firmware. There's an entry for "LSPCON Display Port 1" (description: "The setting determines which port for LSPCON will be connected to the HDCP 2.2 bridge adapter Display 1"). When I run MEInfo, no LSPCON ports are listed. I'm hoping to hear back from somebody today who has a functional system and can let me know if a port is listed. If so, that's probably the issue. At that point, I'm going to have to either resort to hardcore trickery in order to reprogram the ME firmware or hope that somebody from Intel or ASRock will take pity on me and offer me a reasonable way to fix the problem.

               

              In the meantime, I'd really appreciate it if somebody from Intel could assist me. I put a lot of money into specialized hardware so that I can play UHD discs, only to have it all blow up in my face when I try to apply a fix recommended both by Intel and ASRock. This is unacceptable, quite frankly.

               

              Thanks.

              • 4. Re: Intel ME update breaks HDCP 2.2?
                Gary_Berry

                Hello. Just FYI, the problem has been solved. A new BIOS had what appeared to be a slightly modified version of ME firmware 11.8.50.3425. Around the time it was released, ASRock's INTEL-SA-00086 mitigation site was updated to imply that Z370 board owners couldn't rely on the generic ME firmware. I guess that, unlike Z170 and Z270 versions of the board I own (I corresponded with a Z170 owner who apparently updated ME firmware willy-nilly and had no HDCP 2.2 problems), the firmware somehow has to be tied to the board via HDCP licensing and such. I don't like this, as it implies that future fixes can't be applied without breaking HDCP 2.2 once ASRock stops supporting my board. Oh well. That's a battle for another day. For now, I'm good.

                 

                Thanks.

                • 5. Re: Intel ME update breaks HDCP 2.2?
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Thank you so very much for letting us know those results and for sharing all this information in our communities. Let me apologize that I did not answer to your comments before, the reason was that we were doing further research on this matter to try to provide the best resolution for this scenario. We are glad to hear the problem got fixed, and if you have any other inquiry do not hesitate in contact us again, we are here to help and to provide the best support we can.
                   
                  Any questions, please let me know.
                   
                  Regards,
                  Alberto R