5 Replies Latest reply on Nov 28, 2017 4:25 PM by Intel Corporation

    Intel Pro 2500 512GB , Lenovo X220 Tablet , Windows 8.1 freeze hang problem

    Sami_Hamid

      Hello there.

      2 Weeks ago I broke my rule not to get any second hand storage media but the price was too tempting.

      In short I have 2.5” Intel SSDSC2BF512A5 with Firmware: LB1i which turned out to be Dell OEM version of the drive obviously with custom firmware.

      Before I go to the problems and what I did my question is simple is there any newer firmware for this device and can you provide it to me ? I checked Dell drivers section but there are firmwares only for the 2.5” 360GB and 180GB and mSATA 180GB.Any way I executed their setups and they informed that as of their current version there is no newer version of the firmware for my SSD.
      I also downloaded and checked 2 of the latest versions of Intel SSD Toolbox and the Intel SSD Firmware Update Tool but they state I’m with latest version of the firmware.
      Let me repeat I’m with LB1i Intel lists TG21 as the latest one for the Pro 2500 series (on multiple places says I should use OEM provided firmware for the OEM drives).
      The 512GB version of the drive is not listed anywhere as supported by the Toolbox and FW Update Tool so I believe it is intended only for OEMs this is why I’m writing this because I’m unable to find any newer FW since the release of this drive but the rest of the Pro 2500 series obviously received one update.

      Problem 1
      BOOT - BIOS is not detecting for boot Windows 8.1 64bit from the drive after what I would call soft RESTART (both after Win restart or some other OS or Ctrl+Alt+Del reboot after being in the BIOS). SSD is in MBR style partitions boot is done in Legacy mode. SSD drive is detected but the BIOS is not finding anything to boot in this condition If I have bootable USB drive I can load an OS and can freely copy,paste and modify the SSD.

      Solution
      Problem is not occurring on full Power Cycle (Power OFF and Power ON the machine)
      Problem is not occurring with Windows 7 64bit in MBR style
      Problem is not occurring when the drive is in GPT style and booth is in UEFI mode.
      Let’s say this is solved but still I can reproduce it easily.

      Problem 2
      Windows 8.1 Freezes / Hangs.
      One by one all the open apps are freezing ( I can’t also start new ones) until everything freeze and I need a power cycle.
      Nothing in the Event Log for this events (it hangs also and is unable to write errors in the event log , I tried to solve this by redirecting the event logs to external USB storage) but the only 2 times I was able to refresh it before it frezes I could see “Event ID : 129 – storahci resetting raidport0” this error was not recorded and not visible after system reboot.
      This is the most annoying problem. After full 2 weeks spending 6 hours every night at home trying a lot of stuff I’m still unable to resolve it.

      Let’s clarify system was working without any of this issues with the Lenovo OEM Samsung 128GB SSD drive. Initially I cloned the Win 8.1 from the old drive but afterwards I did clean install in UEFI mode.

      System : Lenovo x220 Tablet (model 4299CV8) , i7 -2640m , RAM Lenovo OEM Samsung 4GB + 2GB DDR3 1333MHz
      BIOS : 1.43 (latest/modded)
      Intel Management Engine Frimware 7.1.91.3272
      Lenovo Battery Firmware 1.16
      ALL the Firmwares were updated to the latest ones

      So what I did so far
      Lenovo X220 Tablet updated BIOS from 1.30 to 1.40 to 1.40 modded to 1.43(latest) to 1.43 modded BIOS no change in the behavior at all.
      SATA is in AHCI ( I tried IDE It crashes the system just after 5min in idle reboots and drive is not detectable)
      From the modded BIOS when in AHCI I set the “Aggressive Link Power” to Disabled and Port 0 “ALPM Mode Select” is Disabled this 2 settings are bringing some stability.

      Windows 8.1 settings

      SATA Drivers – the default Microsoft ones (edited registry more on that later) the latest one for the system from INTEL AHCI 12.9.0.1001 are freezing the machine in no more than 15 min work and 5 min idle in some cases with Blue Screen stating CRITICAL_PROCESS DIED and no dump for this screen/crash it is not going beyond 0% reboots and HDD is not detectable by BIOS (BIOS screams “2100: Detection error on HDD0 (Main HDD)” .

      Power Options: All power plans both battery and AC power
      Hard Disk – Turn Off hardisk after : Never

      I edited the registry:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\0b2d69d7-a2a1-449c-9680-f91c70521c60 and here “Attributes” is set to 2 to Expose “AHCI Link Power Management” in Hard Disk power Options.
      “Active” It can still freeze.
      “HIPM” – freezes very fast sometimes I don’t have the time to get to the Control Panel after boot.
      “DIPM” – the most stable one I can get the system up to 12h constant work without letting the machine idling for more than a minute (that is the record without freezeing)

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\0012ee47-9041-4b5d-9b77-535fba8b1442\dab60367-53fe-4fbc-825e-521d069d2456
      “Attributes” is set to 2 to Expose "AHCI Link Power Management - Adaptive" tried both 0 milliseconds and 300000 milliseconds

      PCI Express link power management is OFF

      Microsoft storahci
      I edited the registry in the following way.
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device
      NoLPM – I added the following to the list of devices there
      INTEL SSDSC2*
      INTEL SSD?C??????A5*
      INTEL SSD?C??????A5?*
      INTEL SSD?C??????A5??*
      INTEL SSDSC2BF512A5*
      INTEL SSDSC2BF512A5 SATA 512GB*

      NoidleD3 : I saw that INTEL SSD?C??????A4* series are added there on Windows 8.1 and in the office I also saw my SSD added on Windows 10 INTEL SSD?C??????A5*
      so I copied the settings from my office computer and added my own like this

      INTEL SSD?C??????A5
      INTEL SSD?C??????A5?
      INTEL SSD?C??????A5??
      INTEL SSDSC2BF512A5
      INTEL SSDSC2BF512A5 SATA 512GB

      NoFUACommand – after some reading here and there I understood that most of the SSDs most probably are disregarding this command so I decided to add the following here

      INTEL*
      INTEL SSDSC2*
      INTEL SSD?C??????A5*
      INTEL SSD?C??????A5?*
      INTEL SSD?C??????A5??*
      INTEL SSDSC2BF512A5*
      INTEL SSDSC2BF512A5 SATA 512GB*

      All this changes made the system much more stable and is even capable in 2/3 of the times to enter and exit sleep while solely on battery.

      Next iaStorV
      Under
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV\Parameters I added new key Port0 and there I added the following DWORDS
      LPM = 0
      LPMDSTATE=0

      I haven’t felt any change from the last but it was worth trying.

      If you gonna ask me about SSD Toolbox SMART shows all OK Media Wear shows 75% left and I have run Quick Diagnostic scan.

      I did all the dumb stuff like switching off prefetch , defragment , pagefile , assuring that TRIM is running and all the basic stuff you can think of.

      Since the easiest way to hang the system is by letting it go on it’s own in Sleep and wake it up in which cases depending on the configs and drivers is either hanging just prior to enter Sleep or when it get out of it or 10min after it got out of Sleep I believe that the problem is purely in the way the SSD is handling the power states either the SATA ones or the ACPI ones. And my ultimate conclusion given the fact that I saw it added to the Windows 10 NoidleD3 that it has troubles with the D states. In some very rare cases when windows is able to crash with bluescreen after the freeze and restarts the SSD is not visible for the BIOS which means that a soft restart is not able to get it out of the power state it got itself into.

      I tried both with and without the Lenovo Power Management driver installed and no difference.
      So if someone knows how and from where I can completely disable the power states for the SSD in Win8.1 you are welcome to share it either of this I believe the solutions are Windows 7 (not yet fully tested) or newer SSD firmware in order this system to work in its current config Win8.1 + X220+ Pro 2500.

      Fun fact about Intel SSD Toolbox it says that DIPM is not set and when I click Optimize and check the Power Settings I see it set on HIPM

        • 1. Re: Intel Pro 2500 512GB , Lenovo X220 Tablet , Windows 8.1 freeze hang problem
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Sami_Hamid

          We understand your situation regarding the Intel® SSD Pro 2500 Series. 

          We would like to let you know that this SSD has a feature that is called "Devsleep" which allows the SSD to go into a really low power consumption mode, if the motherboard is not compatible with it you could have the situations you already described.  We usually recommend our costumers to update the BIOS on the motherboard but you already did that.  

          Since this is an OEM drive you can not use the Firmware we have available for retails SSDs. They are customized by the OEMs in order to work with their systems. 

          We recommend you to contact the OEM that the SSD came from in order to check if they have other solutions for you. 

          Regards, 
          Junior M.
           

          • 2. Re: Intel Pro 2500 512GB , Lenovo X220 Tablet , Windows 8.1 freeze hang problem
            Sami_Hamid

            In such case is the following SSD flashable with the Intel 530/535 SSD Series Firmware Update Tool 2.0.14 that gives the option to reflash with DevSleep disabled.
            Intel SSD 530 Series 480GB
            Firmware DC32 - I asume this is intel retail firmware cause this is also the listed version here Firmware Versions for Intel® Solid State Drives and Intel® Optane™...

            S/N : CVDA534400FK4805GN

            • 3. Re: Intel Pro 2500 512GB , Lenovo X220 Tablet , Windows 8.1 freeze hang problem
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Sami_Hamid

              In order to disable the Devsleep feature you need to follow the next steps: 

              1- Go to: https://downloadcenter.intel.com/download/25348
              2- Download the issdfut_2.0.15.iso
              3- Go to https://rufus.akeo.ie/ and download Rufus.
              4- Connect an empty USB flash drive to the PC.
              5- Open Rufus and change only the options "Device" and select your USB. Then go to ISO image, click on search and select the issdfut_2.0.15.iso you previously downloaded.
              6- Go to your BIOS -> Boot -> Boot priority -> select the "USB" as primary.
              7- Re-boot your PC. It should enter the firmware update tool for your SSD.
              8- Update the firmware and then boot windows.
              9- If it does not boot to the "USB" or it gives you an error, please go to BIOS and change the boot mode to "legacy only". Then try again.

              Please bear in mind that this troubleshooting only applies to the Intel® SSD 530 Series and the Intel® SSD 535 Series.

              NOTE: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there. We do not offer support for any third party tool mentioned here.

              Regards, 
              Junior M. 

              • 4. Re: Intel Pro 2500 512GB , Lenovo X220 Tablet , Windows 8.1 freeze hang problem
                Sami_Hamid

                Thank you very much for the help.
                I took a 530 series 480GB reflashed it with the DevSleep disable firmware (it was an effort , it disappeared 2 times from the moment the utility loaded till the moment i click update i didn't followed your instruction for USB/boot/install instead i used my multiple utilities USB with grub4dos to load the iso ) , cloned the UEFI partitions from the Pro 2500 ,and the Intel SSD 530 worked already for 28 hours going through multiple sleep/wake/restarts and actual work without any trace of the problem.

                 

                As of the Pro 2500 i still have not decided its fate , there is no answer from Dell at all. I'll try it on a old desktop with win 7 and if it is not behaving properly will resell it to someone with newer platform (Intel 8 series chipset and beyond if informed my self correctly).
                Again thank you very much for the help.

                • 5. Re: Intel Pro 2500 512GB , Lenovo X220 Tablet , Windows 8.1 freeze hang problem
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi Sami_Hamid

                  We are glad to hear that you were able to disable the Devsleep feature from the Intel® SSD 530 Series. 

                  If you have further questions then feel free to contact us again.

                  Regards, 
                  Junior M.