12 Replies Latest reply on May 19, 2013 11:38 PM by Joeb_

    IAStorUI stopped working

    Zeppel

      Hello,

      I have an Asus P5W DH Deluxe with x975-chipset and running Windows7x64 Professional. Today I upgrade the raid driver from MSM 8.9 to RST 9.6.

      Every time I start the RST UI, I instantly get the "IAStorUI stopped working" message. Same for Intel Control Center. I already updated .net framework and Windows is up2date. The rst service is running and the driver is installed.

       

      What else can I do to get the UI working?

       

      rst.jpg

        • 1. Re: IAStorUI stopped working
          az-djt

          What OS are you running with?  Did you install/enable .NET 3.0?

          • 2. Re: IAStorUI stopped working
            amunaor

            I have this very same problem after installing RST-9.6.0.1014 -- I get the following error report:

             

            Description:
              Stopped working

            Problem signature:
              Problem Event Name: CLR20r3
              Problem Signature 01: iastorui.exe
              Problem Signature 02: 9.6.0.1014
              Problem Signature 03: 4b8f2447
              Problem Signature 04: PresentationFramework
              Problem Signature 05: 3.0.0.0
              Problem Signature 06: 4b595113
              Problem Signature 07: 6253
              Problem Signature 08: e1
              Problem Signature 09: System.Windows.Markup.XamlParse
              OS Version: 6.1.7600.2.0.0.256.1
              Locale ID: 1033


            IAstorUI Stopped working Event: CLR20r3

            Sometimes:

            IAstorIcon Stopped working Event: CLR20r3

             

            Tried repetitive reinstalls of previous working version RST-9.5, only to be greeted with Blue Screens. So, now I'm stuck with RST-9.6 which, after each reboot, greets me with: IAStorUI has stopped working.

             

            Although, I can launch the RST-9.6 User Interface program; use Status, Create, Help buttons, but as soon as I hit the 'Preference' button, I get a dialog box with: IAStorUI stopped working - Check online for soulution and close program.

             

            ***

            My System:

             

            System Information
            OS name:  Microsoft Windows 7 Ultimate
            OS version:  6.1.7600  7600
            System name:  xxxx
            System manufacturer:  INTEL_
            System model:  DX58SO__
            Processor:  GenuineIntel Intel64 Family 6 Model 26 Stepping 5 2.661  GHz
            BIOS:  Default System BIOS, INTEL  - 150e

            Intel® Rapid Storage Technology
            Kit installed:  9.6.0.1014
            User interface version:  9.6.0.1014
            Language:  English (United States)
            Intel RAID controller:  Intel(R) ICH8R/ICH9R/ICH10R/DO/5 Series/3400 Series SATA RAID Controller
            Number of SATA ports:  6
            RAID option ROM version:  8.9.0.1023
            Driver version:  9.6.0.1014
            ISDI version:  9.6.0.1014

             

            ***

             

            System Manufacturer INTEL_
            System Model DX58SO__
            System Type x64-based PC
            Processor Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz, 2661 Mhz, 4 Core(s), 8 Logical Processor(s)
            BIOS Version/Date Intel Corp. SOX5810J.86A.5390.2010.0614.1053, 6/14/2010
            SMBIOS Version 2.5

             

            I've spent all day trying to figure this one out, to no avail. It appears impossible to go back to the previous, working, version of RST-9.5, probably because of my newly applied Intel Chipset instructions - INF_allOS_9.1.2.1007_PV - along with a slew of Microsoft .NET Framework 3.5 updates, no doubt responsible for the Blue Screens mentioned above, when this retrograde action is attempted.

             

            I hope someone can iron this out quickley! It sure is a nuisance not being able to rely on IRST, yet again!

            • 3. Re: IAStorUI stopped working
              Masoa

              Zeppel, try running the program as Administrator and make sure your security software is not blocking it.

               

              I had this same issue on a EVGA x58 SLI on Windows 7 x64 Ultimate, and I had to set my Comodo Internet Security to not run IAStorUI in the sandbox. Besides that, the utility just displays basic information on whats plugged in on the intel ports. If you do not need this information, then I would not waste time trying to fix it.

              • 4. Re: IAStorUI stopped working
                amunaor

                 

                I’ve fixed the ‘IAStorUI stopped working’ error messages; a compound fracture, which apparently, began from the ‘failed’ installation of 2 Microsoft update components: Microsoft .NET Framework 4 Client Profile for Windows 7 x64-based Systems (KB982670) along with -- Microsoft .NET Framework 3.5 SP1 Update for Windows 7 and Windows Server 2008 R2 for x64-based Systems (KB982526), items which were then successfully installed on a second pass. This little hiccup might have been further aggravated by what followed: the mistake of installing suggested Nvidia, video card updates from Microsoft, which left me with two instances of Nvidia Desktop Controls within the Control Panel folder, which I had to uninstall and reinstall from scratch.

                A couple of days prior to the MS .NET Framework/Nvidia driver fiasco, I had updated the BIOS on my Intel DX58SO to  (SOX5810J.86A.5390) at which point I thought it safe to go ahead with the installation of Intel’s latest Chipset and IRST 9.6 drivers also, something I had been putting off for a while. Before this I was successfully running IRST 9.5 along with Chipset version – 9.1.1.1025.

                I didn’t immediately notice anything unusual until later when my LAN connections began to drop after coming out of S3 sleep mode, necessitating a reboot to reacquire internet connection, which had never been a problem before. Uninstalling a reinstalling the Intel Network drivers didn’t clear up the problem either. After several reboots, other things began to go south: IAStorUI, then MS web cam, then my Quicken program wouldn’t launch. I even tried a recovery to an earlier point in time, to no avail. I was about to throw in the towel, dreading, preparing for a clean W7-64-BIT installation, when I remembered the Command Prompt Utility: sfc /scannow.  One pass with this and everything cleared right up! My IRST-9.6 User Interface utility works correctly; without any sort of ‘IAStorUI has stopped working’ issues; MS Video Cam back on line; LAN connection working; Quicken, all working as they should!!!

                ***

                SOLUTION:

                Sfc (System File Checker Instructions)

                1. Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.
                2. Type the following command, and then press ENTER:

                sfc /scannow

                The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.

                ***

                Next day, 3-disk RAID-0 is still running as it should under IRST-9.6; no IAStorUI error messages; all User-Interface aspects of IRST-9.6 working correctly, as advertized.

                Hope this helps.

                 

                 



                • 5. Re: IAStorUI stopped working
                  dvlad666

                  OK, i've also caught that bug!

                  I did nothing except i had some drive dropouts from RAID1 array and a couple of reboots. I did not apply any updates, upgrades and changed no setting except i added new 2TB drive to do a backup.

                  I'm using Server 2003 x86, so i did not get any message, just a hung RST app  and 100% CPU load.

                  In 50% cases i got 0.000000c5 STOP BSOD after that!

                  So beware, if you use this and manage server remotely, enable automatic restart in case of BSOD =)

                   

                  Sorry i had to revert to 8.8, too much time spent on 9.6 bugs already.

                   

                  UPDATE:

                  Oh, sorry. i forgot the main point. However the sfc command restores RST interface, that's totally stupid IMO! sfc restores files to their state either from initital system install or last service pack. If we restore them withour step-by-step control (impossible given the number of libraries), we loose updates, patches and special libraries that might be added with 'good' purpose.

                  • 6. Re: IAStorUI stopped working
                    amunaor

                     

                    A little update, with great agony, I decided to reinstall Win7 from scratch, yet again; not because I had problems with sfc /scannow results, but other issues developed after a router swap that was more WIN7-64BIT compliant, which led to my Ethernet LAN connection being dropped while entering sleep mode, requiring a reboot to get the Internet connection back.

                     

                    Following the fresh clean install of WIN7, my RST-9.6.0.1014 continues to perform as it should but now the LAN connection is in disarray with: e1yexpress Event ID: 27 Intel(R) 82567LM-2 Gigabit Network Connection Link has been disconnected; along with WHEA-Logger Event ID: 17 issues, tied to the PCI-Express slot. See Here:

                    http://communities.intel.co.jp/thread/6707?start=90&tstart=0

                     

                    First of all, why is Microsoft glomming onto and taking possession of the Intel motherboard's real estate, making it impossible to install Intel's most resent Chipset drivers; through their simple .exe installer packagees, requiring instead a need to extract and force-feed the Intel drivers via the Device Manger? Why does Intel even bother to release these Chipset update packages if Microsoft bars its installation process?

                     

                    Isn't it just great to be silently volunteered as BETA testers for two retail products: WIN7-64BIT and Intel DX58SO. I've had this Motherboard (DX58SO - AAE29331-503) and system for 7 months now, and that's all I've been doing!!! This is now my 4th - 5th or 7th clean installation of the operating system...I've lost count!!!

                     

                    I've been using Intel Motherboards for over a decade and a half...this is the worse I've ever seen! I think it flows from everyone dragging their feet in implimenting 64BIT drivers and components, even though a 64BIT operating system has been around ever since WIN-XP. There is no end to what could be accomplished if one cared not who got the credit, but from this what appears to have evolved is that the brain surgeon no longer knows what the foot doctor is doing and the foot doctor doesn't know how the brain makes the foot move.

                     

                    Sorry for what appears to be a disjointed rant, for underneath all these issues are related: flawed drivers; hardware and a rush to market.

                     

                    Those of you having this same board with revision number: AAE29331-701 ...please let us know if your experiencing any of these same issues. I may need to consider dumping this one for a newer revision. This certainly is not what I purchased the board for! At least IAStorUI is working! THANKS!

                    • 7. Re: IAStorUI stopped working
                      platypus

                      SFC/ SCANNOW did not work for me.

                       

                      Nor did trying to run IAStorUI.exe with Administrative privileges (nor running IAStorIcon.exe with Administrative privileges.)

                       

                      Brand new fresh install of Windows 7 Ultimate (x64). Patched with the latest patches (as of 2010/07/27). Installed RST 9.6. Radeon HD 5830 if that matters (Catalyst 10.7). No errors at all with any software installs.

                       

                      I got a slightly different error:

                       

                      Description:

                      Stopped working

                      Problem signature:

                      Problem Event Name: CLR20r3

                      Problem Signature 01: iastorui.exe

                      Problem Signature 02: 9.6.0.1014

                      Problem Signature 03: 4b8f2447

                      Problem Signature 04: PresentationFramework

                      Problem Signature 05: 3.0.0.0

                      Problem Signature 06: 4b595113

                      Problem Signature 07: 756

                      Problem Signature 08: 57

                      Problem Signature 09: System.InvalidOperationException

                      OS Version: 6.1.7600.2.0.0.256.1

                      Locale ID: 3081

                       

                      Interestingly the system tray applet (IAStorIcon.exe) reports that "Intel(R) RST service is not running."

                       

                      But it certainly is being reported as running through the Services MMC.

                       

                      Pathetic... How can Intel get it wrong yet again... (Had so many problems with IMSM and now RST...)

                      • 8. Re: IAStorUI stopped working
                        hrana

                        I just had this problem today and your question came up on a Google search. The solution was quite simple...

                         

                        The problem popped up when I had switched the on-board Intel controller's mode in the BIOS from AHCI to "compatible" so I could test a Western Digital SATA drive with a DOS boot CD. When I rebooted into Windows 7 many hours later, I had forgotten about changing it back to AHCI. Windows 7 installed the normal Ultra ATA drivers upon boot-up and that's when the IAStorUI crashes began. I simply rebooted and changed the settings in the BIOS back to AHCI. Rebooted again. Then Windows 7 came up and the problems went away.

                         

                        For those of you dealing with this crash the basic troubleshooting steps are like this:

                         

                        1. Open up Device Manager and expand the IDE ATA/ATAPI controllers list.

                        2. If you see an Intel Ultra ATA controller but not an Intel SATA AHCI controller listed then that's your problem.

                        3. Right click on all the Intel storage controllers and pick "uninstall" or "delete." In some versions of Windows it'll let you uninstall/delete the driver packages too. If so, then pick yes. Don't reboot just yet.

                        4. Uninstall Intel Matrix storage manager. Again, don't reboot.

                        5. Uninstall Intel Rapid Storage. Again, don't reboot.

                        6. Go to: http://www.sevenforums.com/tutorials/61869-ahci-enable-windows-7-vista.html and follow the directions to enable AHCI.

                        7. Now reboot but don't let Windows start!

                        8. Quickly go into your BIOS and make sure your SATA controller is running in AHCI mode. If it's not, then change it to AHCI. Save your changes and reboot.

                        9. Let Windows start.

                        10. It'll start installing drivers and may ask to reboot several times. Make sure you have a copy of the Intel chipset drivers, SATA drivers, Intel Matrix storage manager, and Intel Rapid Storage just in case Windows ask for the drivers.

                        11. Once all the installing and reboots are done. Then reinstall all the Intel drivers and software. Then reboot again.

                        12. If you did everything correctly, then you shouldn't get anymore crashes. Also you can look in Device Manager and should see an Intel SATA AHCI controller.

                         

                        Good luck.

                         

                        Disclaimer: If you screw up your computer then you can't hold me responsible. Make sure you have a current backup before performing these sorts of changes on your computer!

                        • 9. Re: IAStorUI stopped working
                          SmellyLlama

                          Thanks for the help on this one guys, I'm having very similar problems. My friend has the same board and has used an Adaptec Raid controller, which I shall be doing also. I have had problems turning RAID on in the BIOS. Getting BSOD when I do. The "IAStorUI stopped working" was also happening. I will try these solutions tonight if I get a chance.

                           

                          Cheers

                          • 10. Re: IAStorUI stopped working
                            welby

                            HI there,


                            I had the same issues and tried all the "recommended" options offered all over the internet without success so I decided to debug the executable using:


                            Debug Diagnostic Tool v1.2

                            http://www.microsoft.com/en-us/download/details.aspx?id=26798

                             

                            It also has a built in analyser for the dump files that it creates and after I launched the application IASTOREUI.exe in the debugger and analysed the dump it created in the analyser tool.

                             

                            The analyser reported back on the dump file that the debugger created:

                             

                            In IAStorUI__PID__9460__Date__08_13_2012__Time_02_23_18PM__344__Second_Chance_Exception_E0434F4D.dmp the assembly instruction at KERNELBASE!RaiseException+58 in C:\Windows\SysWOW64\KERNELBASE.dll from Microsoft Corporation has caused a CLR Exception on thread 0 with the following error information:

                            Type:

                            1. System.TypeInitializationException

                            Message:

                            The type initializer for 'System.Windows.Media.FontFamily' threw an exception.

                             

                             

                            This pointed me to the font error :

                            Message:

                            The type initializer for 'System.Windows.Media.FontFamily' threw an exception.

                            So what I did is made a copy of my fonts folder for safe keeping and used Font Frenzy (FREE) to reset my fonts folder back to windows default.

                            http://www.sdsoftware.org/tag/fontfrenzy/

                            I then rebooted the pc and launched the application IASTOREUI.exe and all is working and I can set my SDD Cache again.

                            NOTE: Don't forget to remove the listing in the debug tool once finished as you wont be able to launch the progamme and also you can add the fonts back one at at at a time until you find the corrupt one. Also you could have a malformed path that links to a font should you choose the option under font settings to enable font linking - so after setting back the fonts folder to default windows I turned this option off and installed fonts directly into the windows default fonts folder.

                            I hope this helps.

                            Mark

                            • 12. Re: IAStorUI stopped working
                              Joeb_

                              I'm now using 12.6.1033 of RST drivers, i had tried re-installing v11 and v10 with no luck either).

                               

                              Here was my resolution:

                               

                              Interesting, that fonts were issue for you, Welby.   after 2 days of trying uninstalls/and re-installs I never could hit on the conflict.  But your debug sparked something in my memory..   One tool i used before was microsoft sysinternals suite, in particular, procmon.   And discovered when the IASTORUI.EXE goes belly up it was reading registry for  file associations.. in particular .png. (why it needs that i don't know).    I recall another microsoft application Calc.exe (the common calculator) also has a weird display issue/related type bug when it reads registry there in the file associations.  And Sure enough, uninstalling FastPicture Viewer (which googling also showed other users were having issues) resolves the problem (for me at least).