7 Replies Latest reply on Dec 2, 2017 12:58 AM by MuteMan

    Nuc7i5bnk gigabit lan negotiation fail

    MuteMan

      I have all the latest bios/drivers installed and noticed my network speed fails to initialize a 1000Mbps connection and uses a fallback to 100Mbps.

      (Network driver is version 22.7.1)

       

      I have the nuc connected to a gigabit switch which shows the connection speed with its leds ... orange being 100Mbps, green 1000Mbps

      When the nuc boots, I see the network come up 3 or 4 times for 1 or 2 seconds in gigabit mode always losing connection (all lights out), then eventually it stays active in 100Mbps mode.

      When I go to the properties of the network adapter, I see in the link speed tab, (its set to auto negotiation) current speed is: "100Mbps Full Duplex (EEE: Not Negotiated))"

       

      I know gigabit was working before, unfortunately I cannot say what version of the driver was working and when it stopped ...

        • 1. Re: Nuc7i5bnk gigabit lan negotiation fail
          N.Scott.Pearson

          Have you tried replacing the cable?

          • 2. Re: Nuc7i5bnk gigabit lan negotiation fail
            MuteMan

            I tried to avoid these kind of questions by saying it worked before ...

            Anyway to be 100% sure of this, I connected my laptop to the same cable and get instantly gigabit speed without problems, just as all of the other devices connected to the switch.

            It's definitely the nucs lan drivers...

             

            My guess is there is a bug in the negotiation process, you see the driver try 5 times and finally it just uses a fallback ... that's why the info panel also shows 'EEE: Not Negotiated'

            When I googled the string 'EEE: Not Negotiated', I found some references in an opensource linux driver for intel (https://patchwork.ozlabs.org/patch/329311/ ) where it is used in some of the error paths.

             

            Is there a separate channel to report these kind of issues directly to Intel?

            I was kind of hoping they would see it here.

            • 3. Re: Nuc7i5bnk gigabit lan negotiation fail
              N.Scott.Pearson

              You mentioned 22.7.1, so this means that you are on Windows and not Linux. I have this version installed on a plethora of NUC models (KY, SY, GY, AY, RY, WY, MY and 7BN) and all are connecting at Gb speeds (my switch shows all green). Still, you could try uninstalling this version and installing a previous one to see if this makes a difference.

               

               

              This is a community forum, where community members can share their results and issues and help each other resolve these issues. At the same time, however, Intel Customer Support engineers *are* monitoring these forums and helping folks with their issues as well. While it can happen as a result of postings occurring within these forums, if you truly want to ensure that a ticket is opened under which an issue will be formally tracked, you should contact Intel Customer Support directly. Here is contact information, broken down by geography:

               

              Intel Customer Support Contact Information for US and Canada

              Intel Customer Support Contact Information for Europe, Middle East and Africa

              Intel Customer Support Contact Information for Asia-Pacific

              Intel Customer Support Contact Information for Latin America

               

              I recommend calling ICS directly. Intel has regional centers with folks who can communicate in virtually every language (as opposed to these forums, where English is the only language offered). You can also contact ICS via the Intel Customer Support Chat Service, but this is only offered in English and I believe its availability is subject to PST TZ hours.

               

              Hope this helps,

              ...S

              • 4. Re: Nuc7i5bnk gigabit lan negotiation fail
                MuteMan

                I followed your advise and installed an older driver from an old installer I found in my downloads folder... and it works again ...

                I'm currently using 22.3.108.0

                I  see the network's Link Speed tab now says 1.00Gbps Full Duplex (EEE. Not negotiated)

                so the "EEE. Not negotiated" must have another meaning?

                I still have some other versions in my downloads folder, so I'll try some more and see when it breaks ...

                • 5. Re: Nuc7i5bnk gigabit lan negotiation fail
                  BigMot

                  EEE is "Energy Efficient Ethernet" - "Nor negotiated" means your switch/peer either does not support it or it is disabled. It should not affect link speed. You can disable it from the "Power Management" tab of your adapter if you wish.

                   

                  Anyway we also have issues with Gigabit LAN port on NUC7 but not NUC6 or NUC5 - it either links at just 100Mbit or drops down upon resume or drops at some speed. It is very picky about the cable - or just give up and use a USB3 Gigabit adapter.

                   

                  On the "Link Speed" tab you have the "Diagnostics" button where you can run various tests, e.g. cable quality/frequency response - again they can all be fine but Gigabit remain elusive so trying a different CAT6, 6A or F/UTP or S/FTP cable you may find one that it likes

                  • 6. Re: Nuc7i5bnk gigabit lan negotiation fail
                    MuteMan

                    Thx for you response.
                    I can confirm the nic having a flaky connection.

                     

                    After a reboot with the old drivers, I had the same problem again ...fallback to 100Mbps, remarkable is that the cable diagnostic check reports a cable length of 255m while it is actually just 1.5m, the option 'test cable connection and frequency response" is also greyed out.

                     

                    I just reinstalled the latest drivers again and I have now gigabit speed ... cable length: 0m, and the frequency response option became available. all passed, cable quality reported: 'Excellent'

                    Now wondering, if it will still be working after the next reboot ... I'll keep you posted.

                    • 7. Re: Nuc7i5bnk gigabit lan negotiation fail
                      MuteMan

                      It's been about a week now, and still on gigabit speed

                       

                      Totally have no idea what fixed it though ... after switching back and forth between old and new lan driver versions, the problem just disappeared.

                      I did install the latest BT, TB and GFX drivers during my search for a solution, but it would be strange if that helped solving it ...