3 Replies Latest reply on Mar 22, 2010 11:29 AM by gabiz_ro

    D945GCL and BIOS bug or half job done?

    gabiz_ro

      Until now,because using IDE disk in this pc all seems fine but recently I upgraded with SATA disks.

      Switched from BIOS ATA/IDE Mode from legacy to native then install OS.

      All seems ok but then I see device id,same 8086:27C0,old one and I know

      8086:27C0     -legacy emulation

      8086:27C1     -native SATA AHCI

      8086:27C3     -RAID

      I double check settings in BIOS but still same result.

      I updated BIOS to latest version but still same result.

      I see on internet on few places that Gateway and Emachine use same or similar D945GCL but on their boards is one option :

      Configure SATA as IDE/AHCI/RAID but this option is missing on Intel BIOS.

      I have tried with Intel Integrator Toolkit to enable or switch to AHCI but no result.

      I take a look at PCI registers and only one difference was found at offset 90 is 00 for legacy and 40 for native but that is not enough to switch controller from legacy to native.

      Did Intel forget to do proper initialization of controller?