5 Replies Latest reply on Nov 15, 2017 9:13 AM by Intel Corporation

    i7-7820X & tsc

    x86br

      Hi All,

       

      I have a trouble with a brand-new i7-7820X on Gigabyte X299 UD4( BIOS revision F4 ).

      The server is used as a router/shaper in replacement for a previously one on i5-3570 which worked fine with Linux kernel 4.1.44.

       

      Simply changing the hardware I got in dmesg:

      [0.000000] tsc: Fast TSC calibration failed
      [0.000000] tsc: Unable to calibrate against PIT
      [0.000000] tsc: No reference (HPET/PMTIMER) available
      [0.000000] tsc: Marking TSC unstable due to could not calculate TSC khz

       

      and as a consequence:

      cat /sys/devices/system/clocksource/clocksource0/available_clocksource

      refined-jiffies jiffies

       

      and even no HPET available:

      [0.241000] pci 0000:00:1f.0: RCBA disabled; cannot force enable HPET

       

      Hyper-Threading and all energy-saving options in BIOS setup are disabled.

       

      Trying to solve the problem I added to kernel boot options:

      intel_pstate=disable tsc=reliable clocksource=tsc processor.max_cstate=1 intel_idle.max_cstate=0

      but it did no effect.

       

      The most frustrating issue that old hardware with i5-3570 worked well without any additional tuning.

       

      It critically for me to make tsc as a clocksource worked.

       

      UPD: The problem has been solved by installing the newest 4.13.12 kernel.

       

      UPD2: But the server's clock is not accurate( slowing down ). And possibly it is reflecting the unreliable work of tsc in this processor.

       

      UPD3: The server started crushing under heavy network load and I returned to 4.1.44 kernel and excluded using tc utility( for shaping and QoS traffic ) as it can not work correctly because of broken tsc in this CPU .

      The problem must be in i7-7820X CPU as it cannot afford stable tsc. The previous i5-3570 CPU worked without any glitch and I do not recommend to buy the newest CPUs - use the old ones - they simply work.

       

       

       

      Сообщение отредактировано: Anatoly Muliarski

        • 1. Re: i7-7820X & tsc
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello x86br,

           

          Thank you for joining the Processors Community.

           

          Please let me double check this matter and see what I can find from my end, I will update the thread as soon as possible.

           

          Regards,

          Amy C.

          • 2. Re: i7-7820X & tsc
            x86br

            Hello Amy,

             

            Thank for your response.

            A little detail - the CPU uses mcirocode version 0x200002b.

            I am ready to give any additional information to help to resolve this annoying problem.

             

            P.S. I've already had a request for support about ixgbe driver using 4 years ago and it was successfully resolved.

            • 3. Re: i7-7820X & tsc
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              x86br, thank you for patience.

               

              We have reviewed this matter, and I believe this matter could be potentially related to compatibility between the microcode and the Linux distribution build you are using. Our suggestion based on this is to install the latest BIOS from your computer manufacturer and to check with Linux support for more information.

               

              Regards,

              Amy C.

              • 4. Re: i7-7820X & tsc
                x86br

                Thanks,

                 

                I have already installed the latest BIOS from Gigabyte ( version F4 from 09/14/2017 ) and did not solve the problem.

                The latest Linux kernel works unstable with tsc and I suppose this reflects some hardware issues with the newest CPU.

                I understand that I have nothing to do but wait for a new BIOS release ( Gigabyte's support answered that they support only Windows 10 ) and a new Linux kernel which will may be ( or not ) tackle the issue.

                The pity of the situation is the old i5-3570 CPU worked without any problem.

                • 5. Re: i7-7820X & tsc
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  x86br, my apologies for the inconvenience.

                   

                  Hopefully the BIOS is released soon.

                   

                  Regards,

                  Amy C.