0 Replies Latest reply on Nov 7, 2017 2:19 PM by laquebrada

    PCIe issue with NUC7 Bios

    laquebrada

      Our PCIe Express hardware device (PCIe x4 GEN I interface) is connected to the 4 Lanes PCI Interface on the M.2 slot.

      We did some basic tests with an older BIOS version 0031 from 14th December 2016 and everything was working fine.

      After upgrading to the latest BIOS version BNKBL357.86A, Version 0054 from October 25th 2017 we see PCI Express link issues.

       

      We analyzed the behavior with the PCI Express analyzer and saw repetitive PCIe LINK trainings.

      It seems like ASPM (Active State Power Management) is activated which is not supported from our hardware.

       

      We tried to downgrade to an older BIOS version but this is prohibited with the latest ME version.

      Therefore, I cannot tell you since which BIOS version this problem is present.

      We also changed the Windows 10 power management settings but it didn’t have any affect to the PCIe Link.

      The same issue was present on both NUC7i7 and NUC7i5 systems we tested. We did not observe the same issue with NUC6i5 systems.

       

      It would be very nice if you could help me with the following questions:

       

      1. Do you have an explanation for this behavior?
      2. Is this PCIe Link behavior activated by accident or on purpose enabled for M.2 SSDs?
      3. Can we expect that a BIOS upgrade will fix our link problem?

       

      Thanks a lot for your help.