2 Replies Latest reply on Nov 21, 2017 5:53 PM by Intel Corporation

    Issues with MSI install PROSet 19.70 and 20.00

    TobiasHvA

      Intro

      We are having trouble with the MSI update package on our systems. The issue is that between 1-3% of our systems are not able to boot after the update is applied. Are there more organizations with this issue and is there a sollution?

       

      Background

      - We have machines, HP (elitebook) and Dell (lattitude), laptops all running on Win 7 64b, with Intel Wireless 7260, 7265, 8260 or 8265 chipsets.

      - We are updating them with SCCM since version 17.00 and haven't had a problem until version 19.70 and now 20.00 of the msi installer.

       

      Problem

      The machines with the problem in some cases get a bluescreen after the installation and all are not booting after "Windows is Starting". We haven't had much luck reproducing the issue on our test machines and we cannot detect a a pattern in chipset/model etc.. It looks like a random 3% of our laptop population. Our total population is 5000 laptops and we have now updated about 1500 to version 20.00. And have put the update on hold until we have more information.

       

      Troubleshooting

      All the issues have now been restored by starting in Save Mode and locally repair the MSI, this works almost all cases, but this is not a tactic we're willing to continue .

       

      Possible cause?
      The only thing we now have is that all machines with the issue took 12 minutes to complete the installation and 'normal' machine took only 30sec. The difference in time is explained in de msi log by two timeouts that occur in de CA LaunchAppandWait:

      Log (8408)(09:02:00:403): CA_Drv - LaunchAppandWait entering

      Log (8408)(09:02:00:403): CA_Drv - LaunchAppandWait calling CreateProcess for [C:\Program Files\Intel\WiFiDrivers\Drivers\iprodifx.exe] with argv ["C:\Program Files\Intel\WiFiDrivers\Drivers\iprodifx.exe" /Silent]

      Log (8408)(09:08:01:103): CA_Drv - LaunchAppandWait - Wait Timed Out: [102]

      Log (8408)(09:08:01:103): CA_Drv - LaunchAppandWait leaving

      MSI (s) (28:74) [09:08:01:113]: Executing op: ActionStart(Name=CA_PSM_DRIVER4_InstallDrivers,,)

      Log (8408)(09:08:01:103): CA_Drv - IProDifxDriver4InstallOrRepairDrivers leaving

      MSI (s) (28:74) [09:08:01:113]: Executing op: CustomActionSchedule(Action=CA_PSM_DRIVER4_InstallDrivers,ActionType=3073,Source=BinaryData,Target=PsmDriver4InstallOrRepairDrivers,)

      MSI (s) (28:D0) [09:08:01:133]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSIE36A.tmp, Entrypoint: PsmDriver4InstallOrRepairDrivers

      Log (8408)(09:08:01:183): CA_Drv - PsmDriver4InstallOrRepairDrivers entering

      Log (8408)(09:08:01:183): CA_Drv - GetIntelProductID - Entering

      Log (8408)(09:08:01:183): CA_Drv - GetIntelProductID - [ProductCode]={EC68A5E6-D014-41B9-A741-63B57439ACEC}

      Log (8408)(09:08:01:183): CA_Drv - GetIntelProductID - WiFiDrivers - Exiting

      Log (8408)(09:08:01:183): CA_Drv - LoadInstallDirectory - Looking for InstallDir in [SOFTWARE\Intel\WiFiDrivers]

      Log (8408)(09:08:01:183): CA_Drv - LoadPsmDriverDirectory [C:\Program Files\Intel\PowerSharingManager\Drivers\]

      Log (8408)(09:08:01:183): CA_Drv - LaunchAppandWait entering

      Log (8408)(09:08:01:183): CA_Drv - LaunchAppandWait calling CreateProcess for [C:\Program Files\Intel\PowerSharingManager\Drivers\InstallPsm.exe] with argv ["C:\Program Files\Intel\PowerSharingManager\Drivers\InstallPsm.exe" install]

      Log (8408)(09:14:01:377): CA_Drv - LaunchAppandWait - Wait Timed Out: [102]

       

      We don't know for sure why the timeouts occur and if that is indeed the cause of the issues.