6 Replies Latest reply on Nov 3, 2017 4:47 AM by MartyG

    Unable to ssh to RTF drone

    Trixie

      Hi,

       

      I recently got a Ready-to-Fly Intel Aero and I am now trying to connect to it. I am following the GitHub guide to access the drone using ssh since I was unable to also get video output to my HDMI monitor, but when I try to ssh root@192.168.8.1, I get the message that the "Network is unreachable" even when my remote computer is already connected to the drone's CR_AP-xxxxx wi-fi access point.

        • 1. Re: Unable to ssh to RTF drone
          MartyG

          The ssh root command that you are using is the correct one, so it looks like the problem isn't in that instruction.

           

          There have been known cases of a computer's internet firewall blocking communication with an Intel Aero drone, in which case the recommended advice would be to disable the firewall, or set up a rule in the firewall that permits the drone to be connected to.

          • 2. Re: Unable to ssh to RTF drone
            Trixie

            Unfortunately, I have also tried turning off my computer's firewall but it still wouldn't let me connect. I am using a Macbook Air btw, if that detail helps even a little.

            • 3. Re: Unable to ssh to RTF drone
              MartyG

              Usually, wi-fi connections to a drone are made using a computer running the Linux operating system (the Ubuntu type of Linux is recommended).  So a Mac may be able to detect a wi-fi access point but not know how to talk to the drone via wi-fi.

               

              This page has deep details about connecting to the drone's wi-fi.

               

              08 Aero Network and System Administration · intel-aero/meta-intel-aero Wiki · GitHub

               

              As suggested on this page, maybe you need to use the drone's wi-fi password 1234567890 to get past security.

               

              Edit: the page says "On macOS and Linux it's possible to use the link-local name rather than fixed IP.  Refer to the documentation of your distro on how to enable it ... ArchLinux's documentation works on several Linux distributions and macOS "

               

              https://wiki.archlinux.org/index.php/avahi#Hostname_resolution

              • 4. Re: Unable to ssh to RTF drone
                Trixie

                I've been able to ssh and scp to other compute boards before like the raspberry pi using my Macbook so I find it a bit unusual that I am unable to do the same with the Intel Aero.

                 

                About the drone's wi-fi password, I believe that 1234567890 is only for connecting to the access point itself since the documentation states that there is no password to ssh to the drone. I don't think I would be able to enter that password anyway since I immediately receive the message "Network is unreachable" as soon as I hit enter on the ssh command instead of being prompted for a password.

                 

                I will try the link-local approach that you mentioned and see if that works.

                • 5. Re: Unable to ssh to RTF drone
                  Trixie

                  It turns out that the command: ssh root@intel-aero.local does work. I first tried to make the connections to my Macbook be "link-local only", but it somehow still worked even when this isn't the case and I didn't have to install avahi. The solution was simply to login to root@intel-aero.local instead of using the IP address!

                   

                  In any case, thanks for the help MartyG!

                  • 6. Re: Unable to ssh to RTF drone
                    MartyG

                    I had seen the ssh root@intel-aero.local command during my initial research into your case, but as I only found one case where it was used and everyone else was using the IP address, I wasn't sure that it would work for you and wanted to offer more well-documented solutions first so that I didn't risk wasting your time.  I apologize for not suggesting local-link earlier.    At least Mac users who research wi-fi connection problems in future will have this post to refer to

                     

                    Have a great weekend!