3 Replies Latest reply on Oct 30, 2017 3:35 AM by Intel Corporation

    intel joule 570x crash

    hgs

      Hi All,

       

      I see the following crash infrequently while I was working the console through uart interface. Any thing alarming about this crash?

       

      [ 1365.245813] irq 467: nobody cared (try booting with the "irqpoll" option)

      [ 1365.253419] CPU: 0 PID: 106 Comm: irq/41-bxtwc_ir Tainted: G           O    4.9.27-intel-pk-standard #1

      [ 1365.263893] Hardware name: Intel Corp. 570x DVT3/SDS, BIOS GTPP1J2A.X64.0143.B30.1706270056 06/27/2017

      [ 1365.274269]  ffffc90000427d60 ffffffff813fc6da ffff88017897c200 0000000000000000

      [ 1365.282526]  ffffc90000427d90 ffffffff810c6cde ffff88017897c200 0000000000000000

      [ 1365.290778]  ffff88017a130d00 ffffffff81eca0a0 ffffc90000427dc8 ffffffff810c7063

      [ 1365.299031] Call Trace:

      [ 1365.301758]  [<ffffffff813fc6da>] dump_stack+0x4d/0x63

      [ 1365.307475]  [<ffffffff810c6cde>] __report_bad_irq+0x2e/0xc0

      [ 1365.313779]  [<ffffffff810c7063>] note_interrupt+0x233/0x270

      [ 1365.320083]  [<ffffffff810c5180>] ? irq_forced_thread_fn+0x70/0x70

      [ 1365.326969]  [<ffffffff810c7495>] handle_nested_irq+0xa5/0xc0

      [ 1365.333365]  [<ffffffff81579349>] regmap_irq_thread+0x1b9/0x360

      [ 1365.339961]  [<ffffffff810c5180>] ? irq_forced_thread_fn+0x70/0x70

      [ 1365.346845]  [<ffffffff810c51a0>] irq_thread_fn+0x20/0x50

      [ 1365.352858]  [<ffffffff810c543d>] irq_thread+0x10d/0x190

      [ 1365.358774]  [<ffffffff810c5270>] ? wake_threads_waitq+0x30/0x30

      [ 1365.365467]  [<ffffffff810c5330>] ? irq_thread_dtor+0xc0/0xc0

      [ 1365.371869]  [<ffffffff8109a257>] kthread+0xd7/0xf0

      [ 1365.377300]  [<ffffffff8109a180>] ? kthread_park+0x60/0x60

      [ 1365.383413]  [<ffffffff81917692>] ret_from_fork+0x22/0x30

      [ 1365.389441] handlers:

      [ 1365.391972] [<ffffffff810c4c70>] irq_nested_primary_handler threaded [<ffffffffa067d020>] wcove_gpio_irq_handler [gpio_wcove]

      [ 1365.404589] Disabling IRQ #467

       

        • 1. Re: intel joule 570x crash
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Hari,

          Thank you for your interest in Intel products. 
          I would like to know a little bit more information regarding your issue. Could you please provide the following information?
          How are you powering the Joule board? Are you using a 12VDC supply in the DC input jack?
          Additionally, I would like to let you know that the official Joule’s image we support is the Ref-OS-IoT, for that reason I’d suggest you to try installing that one to do your tests.

          Regards,
          Alexandra

          • 2. Re: intel joule 570x crash
            hgs

            Hi Alexandra,

             

            I have joule module mounted on to our custom baseboard which is battery operated and has provision to be chargeable with 12 V supply.

            We use 6900mAh 3.7V 25.53Wh battery.

            Between I am using OS 1706 release package-precompiled.

             

            Thanks

            • 3. Re: intel joule 570x crash
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Hari,

              The board was designed and tested for a specific use case, running off a 12V, 3A power source, as specified in the link below: 
              https://software.intel.com/en-us/intel-joule-getting-started

              Please try to connect your board directly to a 12 VDC power supply.
              Let me know if you still get the same error.

              Regards,
              Alexandra