1 Reply Latest reply on Oct 30, 2017 1:31 AM by Intel Corporation

    Error when trying to install new packages

    rsmart

      Hi,

       

      I have the latest SD card image from https://software.intel.com/en-us/iot/hardware/galileo/downloads (running cat /etc/version gives 201703081404) and have added the following two files in /etc/opkg:

       

      iotdk.conf

      src iotdk-all http://iotdk.intel.com/repos/3.5/iotdk/galileo/all

      src iotdk-i586 http://iotdk.intel.com/repos/3.5/iotdk/galileo/i586

      src iotdk-quark http://iotdk.intel.com/repos/3.5/iotdk/galileo/quark

      src iotdk-x86 http://iotdk.intel.com/repos/3.5/iotdk/galileo/x86

       

      mraa-upm.conf

      src mraa-upm http://iotdk.intel.com/repos/3.5/intelgalactic/opkg/i586/

       

      However- after opkg update when I run opkg upgrade or try to opkg install I'm getting the following error:

       

      check_data_file_clashes: Package libc6 wants to install file /lib/libpthread.so.0

        But that file is already provided by package  * libpthread0

       

      Am I missing something obvious? Sorry if it's a stupid question but I've searched through various threads on here am I'm yet to have any luck! I'm guessing I don't have the right repos and it's conflicting, could anyone point me in the right direction please? Huge thanks!

        • 1. Re: Error when trying to install new packages
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello Richard,

          Thank you for contacting Intel Technical Support.
          I have seen this kind of issue reported by other users when trying to install a package. They have solved it by forcing the installation, you can try this command opkg install motion --force-reinstall –force-overwrite . 

          Hope this information helps.

          Regards,
          Octavian