1 2 Previous Next 16 Replies Latest reply on Oct 24, 2017 1:07 PM by N.Scott.Pearson

    No display on new Intel NUC6CAYH

    evantong623

      Hi,

      I got my NUC (NUC6CAYH) today and was very excited until I found out there is no video output. Below are what I put in the NUC:

       

      - 1x Crucial 4GB 204-Pin SODIMM DDR3 PC3-14900 1866 MT/s Memory Module from B&H Photo Video 

      - 256GB SSD

      - USB flash drive with Ubuntu 16.04

       

      I tried to connect a 1080p monitor with both VGA and HDMI. Neither of them gave display on the screen. The screen was tested with other computer and it worked fine. I tried to use the upper RAM slot and lower RAM slot, and neither of them worked. The blue power button light was on after I pressed it to power on and there was no blinking/flashing on the power button light during start up. I was able to reboot the machine once with "Ctrl+Alt+Del" and saw the power light went off and then on.

       

      Can some one explain me what else I should try to bring out the display?

       

      If nothing work, should I contact Intel or the seller (B&H) for refund/replacement?

       

      Thanks in advance!

       

      Xin

        1 2 Previous Next