1 2 Previous Next 16 Replies Latest reply on Jan 18, 2018 3:03 PM by Intel Corporation

    Euclid hardware problems


      Hello community, hello support,


      I have strange problems with Euclid hardware. Once a week I need to install the system from scratch, when somebody forgets to switch off the the system properly.

      It seems for me, that the system is completely overheated after 2-3 day (e.g. after a weekend). There is nothing else running, but the operating system.

      I've tried it with accu and with direct power connector - no difference. After 3 days the system is dead.


      Any idea or suggestions ?


      Thanks and cheers


        • 1. Re: Euclid hardware problems

          Do you have access to the Euclid's web interface?  If so, there is a tab option called 'Power'.  Under this should be 3 options, one of which is 'Restart OOBE'.  OOBE stands for Out Of Box Experience - the initial setup process when Euclid is first taken out of the box after you have purchased it.  If you can, it might be worth trying that before doing a complete system wipe and re-install.

          • 2. Re: Euclid hardware problems

            Hi MartyG,


            thanks for your friendly answer, but I have to tell you:


            1. no web access

            2. no icmp ping

            3. no ssh access


            Connecting Euclid to HDMI shows the truth:

            1. filesystem is mounted read-only

            2. a lot of error messages from Intel Euclid scripts


            I've tried to repair the filesystem with fschk and it finished with success, but after reboot the same situation.


            Installing the system from ISO and external DVD is the last chance to restore the system.


            Thanks for more



            • 3. Re: Euclid hardware problems

              If people keep forgetting to turn the Euclid off then it may be worth considering using a parental timer plug with it (like the ones used by parents to manage their kids' usage of devices such as TV and games consoles) so that it switches off when a certain time of day is reached, such as 6 pm.

              • 4. Re: Euclid hardware problems

                Hi MartyG,

                Wrong way :-)

                Euclid is a robot system and must survive by software design.

                1. heating must be monitored

                2. power supply must be monitored


                In case of problem, the system must shutdown into save state and should not damage filesystem or something else.


                Sorry to say: Euclid SDK (hardware and software)  is still a preview prototype and not a production release.


                Happy day



                • 5. Re: Euclid hardware problems

                  The ZR300 camera module is being discontinued.  Intel's recommended replacement is the D430 module, which is inside the powerful new RealSense D435 camera.  The D-camera product line was designed with autonomous vehicles, robotics and drones in mind.  It may therefore be worth considering the D435 if you are thinking about purchasing another Euclid in the near future.


                  The D435, unlike the Euclid, is a camera and not a mini-PC though, so you would have to connect it to a compatible single-board computer on your robot.


                  Intel® RealSense™ Depth Camera D435 - Intel® RealSense™ Developer Kits

                  • 6. Re: Euclid hardware problems

                    strange, every piece I've bought, is discontinued.

                    • 7. Re: Euclid hardware problems

                      I believe that a period of stability in the RealSense product lines is beginning.  Until now, the RealSense ecosystem was fragmented - RealSense SDK for Windows, and Librealsense for Linux (and Windows if you wanted to), and the RealSense SDK For Linux for use with the ZR300.


                      From this point on though, Intel's RealSense focus will primarily be on the D415 and D435 cameras, and the new RealSense SDK 2.0 (an advanced open-source version of Librealsense for Windows and Linux, with Mac OSX support in the works).  It will also be easier for developers to contribute their own modules.

                      • 8. Re: Euclid hardware problems

                        Hi Chrimo,


                        First off, it should be noted that the Euclid is a development kit at this stage, not in product stage.

                        As for overheating, if you're sure that that is the cause of the malfunction - could you try and find out the cpu temperature in which the Euclid crashed? You can echo the rostopic called "cpu_info" to see the cpu temperature.

                        Overheating shouldn't be an issue. My Euclid was powered on for around two weeks while I've been out of office and it's perfectly fine.

                        If it is indeed caused by overheating, the Euclid's BIOS can be configured to make an emergency shut down when the device overheats. This might be what you could do to prevent harm to the device.

                        Keep me posted,





                        Intel Euclid Development Team

                        • 9. Re: Euclid hardware problems

                          Hello again Meitav,


                          this is, what I'm doing now :-)

                          1. monitoring euclid network connection with NMS (ICINGA2)

                          2. monitoring temperature, cpu load and preparing graphs with RRD tools.


                          I will give you feedback, when I have details to show.


                          >If it is indeed caused by overheating, the Euclid's BIOS can be configured to make an emergency shut down when the device overheats. This might be what you could do to prevent harm to the device.

                          possible, YES: BUT this will not be a save shutdown and corrupts the filesystem again.


                          Better solution: rosnode which monitors temperature and triggers a controlled shutdown.

                          I have something like this for my NUC+accu, which shuts down system when voltage becomes low.


                          How it works ?

                          ros node monitors topic and writes a flag to /tmp/powerdown.req


                          root crontab shellscript checks for /tmp/powerdown.req and execs shutdown



                          Thanks for your productive answer.




                          • 10. Re: Euclid hardware problems

                            Hi Chrimo,


                            The solution I described using the BIOS would have the same effect as a rosnode monitoring the CPU temperature, but would probably require less resources, which is why I'm recommending this.

                            Let me know what you discover. In any case, it's important for me to mention that although this is a dev kit like I said, we're here to help you out with the issues you run into.




                            Intel Euclid Development Team

                            • 11. Re: Euclid hardware problems

                              Hi Meitav,


                              reproducible results for a crash after 30 minutes.


                              no ping

                              no ssh

                              no web



                              cmock$ ping

                              PING ( 56 data bytes

                              64 bytes from icmp_seq=0 ttl=63 time=24.550 ms

                              64 bytes from icmp_seq=1 ttl=63 time=162.880 ms

                              64 bytes from icmp_seq=2 ttl=63 time=103.223 ms

                              64 bytes from icmp_seq=3 ttl=63 time=41.268 ms

                              64 bytes from icmp_seq=4 ttl=63 time=187.880 ms

                              64 bytes from icmp_seq=5 ttl=63 time=21.541 ms

                              64 bytes from icmp_seq=6 ttl=63 time=54.153 ms

                              Request timeout for icmp_seq 7

                              Request timeout for icmp_seq 8

                              Request timeout for icmp_seq 9

                              Request timeout for icmp_seq 10




                              cmock$ ssh euclid@

                              euclid@'s password:

                              Connection to closed.

                              x49ws40cmock:~ cmock$ ssh euclid@

                              euclid@'s password:

                              Connection to closed by remote host.

                              Connection to closed.


                              last seen cpu temperature: 78 °C


                              Euclid started: Xnet Cloud

                              Euclid running: Xnet Cloud

                              Euclid dead:  Xnet Cloud


                              SDK is OK, I use it for a long time with Intel NUCs and Realsense R200.


                              My problem is the euclid hardware + firmware :-)


                              Friendly greetings from Hamburg



                              • 12. Re: Euclid hardware problems
                                Intel Corporation
                                This message was posted on behalf of Intel Corporation

                                Hello Crimo,

                                Thank you for contacting Intel® RealSense™ Technology support. 

                                For future references, your ticket number is 03071514. Please keep this number handy in case you are asked for it.

                                We apologize for the late response. We received feedback from the Euclid team. It seems that your Euclid has a hardware problem. If you cannot use it and would like a refund, please, contact click.support@intel.com or return to the Click page to begin the RMA process. 

                                Unfortunately, Euclid is out of stock so you may not be able to get a replacement, but you should ask anyway just in case they have any.

                                I hope you find this information useful.

                                Thank you for your patience and understanding on this matter.

                                Best regards.

                                Josh B.
                                Intel Customer Support

                                • 13. Re: Euclid hardware problems

                                  I am looking through the Euclid's BIOS right now, and both the Thermal Failsafe and the Intel Dynamic Platform & Thermal Framework settings are all disabled.  Things like critical shutdown points at 85 or 90 celsius are disabled, possibly leading to this failure you had.


                                  I suppose the shutdown is handled at a BIOS level, so it will probably not play nicely with OS level stuff like file system corruption being an issue still. Just thought you should know that by default these safety precautions are turned off. Can find the categories in the BIOS (get to BIOS with F5 at boot up) under System Setup -> Thermal.

                                  • 14. Re: Euclid hardware problems

                                    Hello KyranF,


                                    Good idea to check this, I will check it this week.

                                    To survive my Euclid envirnonment, I've disabled boost mode for CPU and it works.

                                    Now my device runs longer than 15 minutes 6DoF-Person scenario :-(

                                    Current temperature is now between 61 and 63 °C, not over 75 °C with boost.

                                    Slow as a RPI, but stable.




                                    1 2 Previous Next