5 Replies Latest reply on Oct 19, 2017 6:30 PM by Intel Corporation

    Intel I218-V doesnt work with 1Gbs speeds

    vex3um

      Hello!

       

      I've recently upgraded my router so that it now supports 1Gbs transfer speeds. However my ether port I218-V on a motherboard (Z97-pro) doesn't want to connect with the home network in full duplex 1Gbs. It auto negotiates on 100mbs full duplex, and if forced in 1gbs it just stops working ( says its unpluged).  I've tried handful of different cables, updated and reinstalled drivers, tried forced modes and so on, but nothing seems to work (also tested this with another computer and it got full connection). What seems to be the problem is that driver wrongly assumes length of the cable. In diagnostics mode, on first connection tab I always get error:

      "Cable Link Status : Failed

              This device requires a restart."

      And in the next tab which diagnoses the cable it weirdly amuses that the cable is 255meters long.

        "Cable Length Status : Passed

              Cable Length: 255 meters"

      I think that these wrong diagnostics make driver refuse to connect in full duplex 1gbs speed and that it goes for 100mbs.  Is there any known solution to this or something I could do or is it just a defect. I would immensely appreciate any heko. I can provide further information if needed.

       

      Thanks for help

        • 1. Re: Intel I218-V doesnt work with 1Gbs speeds
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Vex3um,

            Thank you for posting in Wired Communities. Can you share additional information below:
          1) What is the operating system?
          2) What is the driver version installed? Where did you download the driver? 
          3) What is the router's brand and model? 

          Thanks,
          Sharon
           

          1 of 1 people found this helpful
          • 2. Re: Intel I218-V doesnt work with 1Gbs speeds
            vex3um

            I'm using Windows 10 pro ver. 1703 (OS build 15063.674).

             

            I downloaded driver from here Download Intel® Network Adapter Driver for Windows® 10 ; After installing Windows updated driver further to: 12.15.25.6712 from 12.15.25.6.

            Intel PROSet version is 22.7.18.0

             

            Computer is connected to Linksys EA6900 running latest firmware (2.0.2.181247).

            • 3. Re: Intel I218-V doesnt work with 1Gbs speeds
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Hi Vex3um,

               Thank you for the information.

              1)  Just to double check if Linksys EA6900 is forced to Gigabit speed as  well when you force the NIC to Gigabit. If not, please make sure both site has the same configuration.

              2)  I can see you are using the latest driver already, have you try checking Asus* for Windows* 10 customized driver for I218-V on the board? It is recommended to use the driver provided by the board vendor. 

              3)  Have you encountered the same issue if using other operating system on this Asus Z97 PRO? 
               
              4)  Try disabling "energy efficient ethernet" in the power management tab of adapter.

                  I would recommend you to contact Asus* to check on the hardware part as they are in better position to assist on the onboard NIC embedded on their system. Thank you.

              Regards,
              Sharon 

               

              1 of 1 people found this helpful
              • 4. Re: Intel I218-V doesnt work with 1Gbs speeds
                vex3um

                I'm really grateful for your support mr. Sharon I'm happy to announce that I solved my problem, it wasn't a hardware or software one, but a technical one on my side. Most likely its a fault of a hub switch,which is probably badly connected, so I'll have it inspected by a professional tomorrow. Its interesting how older computer with which I tested this same connection didn't have this problem. I think that was due to I218-v being way more sensitive to cables and because it also has smart diagnostic abilities, being able to identify cable length. As I wrote before cable length was measured incorrectly  (255m insted of <10m) which lead to automatic blockage of higher speeds.

                 

                Thank you for your support once again

                • 5. Re: Intel I218-V doesnt work with 1Gbs speeds
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hi Vex3um,

                    You are welcome and thank you very much for the update. Glad to know you manage to find out the cause and hopefully all works well after checking on the switch. Thank you.

                  Regards,
                  Sharon