2 Replies Latest reply on Oct 16, 2017 10:04 AM by BoL3g3nd

    Why Linux computer not detecting Euclid?

    BoL3g3nd

      Hello,

      I am trying to use camera features that come with Euclid on my Ubuntu Linux.

      I installed necessary libs as much as I am aware off. (SDK , Realsense, librealsense etc.)

      Still not able to detect the device.

       

      $ lsusb

      Bus 002 Device 002: ID 413c:5534 Dell Computer Corp.

      Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

      Bus 001 Device 009: ID 17ef:6018 Lenovo

      Bus 001 Device 008: ID 1a40:0801 Terminus Technology Inc.

      Bus 001 Device 006: ID 413c:301a Dell Computer Corp.

      Bus 001 Device 004: ID 413c:2513 Dell Computer Corp. internal USB Hub of E-Port Replicator

      Bus 001 Device 003: ID 8087:0a2b Intel Corp.

      Bus 001 Device 002: ID 413c:2134 Dell Computer Corp.

      Bus 001 Device 007: ID 0bda:57c3 Realtek Semiconductor Corp.

      Bus 001 Device 005: ID 0a5c:5832 Broadcom Corp.

      Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

       

       

      Is it even possible to access Euclid camera from a computer?

      If yes then could you please tell me how?

       

      Thank you,

        • 1. Re: Why Linux computer not detecting Euclid?
          MartyG

          I would imagine that the problem is that you are trying to use the Euclid like an ordinary RealSense USB camera.  Euclid is more than that though: it is a mini-PC with a camera.  So its architecture is more complex than that of a RealSense camera.  You are not the first person I have known who has tried to replicate the setup of Euclid's software on a full Ubuntu machine though. 

           

          Another factor complicating the matter is that Euclid does not use the main branch of Librealsense, but instead uses a special "forked" version that enables the camera components to function properly.  The camera is not validated by Intel to function without this forked version.

           

          I do not know if a full Ubuntu PC can function as a Euclid machine, with the Euclid module effectively acting just as a ZR300 camera plugged into the full machine.  The Euclid is effectively though an Ubuntu mini-PC.  So I would think that the best chance of getting your project to work, if it is possible, would be to wipe your PC and install the full Euclid disk image on it, which includes the special forked version of Librealsense.

           

          You can get this restoration image as a 2 GB iso file download from a link on the page below.

           

          Re: Restore Euclid / download software

          1 of 1 people found this helpful
          • 2. Re: Why Linux computer not detecting Euclid?
            BoL3g3nd

            MartyG Thank you for your response. That is quite helpful.