3 Replies Latest reply on Oct 12, 2017 12:44 PM by Intel Corporation

    Windows 10 Intel usb 3.0 eXtensible host controller driver does not work properly

    horisonten

      Hi!

      I am having problems with my usb ports on my laptop which has Windows 10 installed.

      I upgraded to Windows 10 a couple of years ago, and at first all of my usb ports worked like a charm. But then somehow the native Intel extensible host controller got replaced with the Microsoft one. And now only one of three usb ports work (and only if I have something connected to that usb port upon turning on the laptop).

      I really need to force install the Intel extensible host controller Windows 7 driver to get it to work, but when I try to force install it my laptop blue screens and restarts.

      I have read about others having this exact problem, and other forums have suggested to install a modified version of the driver from here Forum - USB 3.0/3.1 Drivers (original and modded) . I have tried that solution, but it didn't work...

       

      I have tried to contact Microsofts support about this problem, but they said that I should contact Intel support instead.

      So I'm being sent back and forth between the to companies because no one is willing to help me solve this problem.

      Should I just accept that I can not use all of my USB ports anymore? Or does someone here have the knowledge to how to get them working again?

       

      Steps I have done so far:

       

      - Uninstalled/reinstalled the drivers multiple times.

      - Tried to force install the Intels extensible host controller Windows 7 drivers in compatibility mode (they were installed and worked until recently).

      - Tried to install modified drivers.

      - Sent my laptop to a local computer service company that couldn't solve it either.

       

      Any help to solving this is much appreciated. My chipset is a Intel® 7 Series Chipsets/Intel® C216 Chipset

      I really hope that I don't need to buy a new laptop just because Intel won't provide working drivers to their products...