2 Replies Latest reply on Oct 3, 2017 10:01 AM by Intel Corporation

    error there is a mavlink version or baud rate mismatch.

    Narveer

      I followed all the steps in https://github.com/intel-aero/meta-intel-aero/wiki  to connect the RTF with QGC on my ubuntu laptop. But i got an error message that QGCMessageBox (unit testing) "MAVLink Protocol" "There is a MAVLink Version or Baud Rate Mismatch. Please check if the baud rates of QGroundControl and your autopilot are the same."

       

       

      Over on the RTF drone I see this after the gst-launch command:

      root@intel-aero:~# gst-launch-1.0 v4l2src  device=/dev/video13 do-timestamp=true ! video/x-raw, format=YUY2, width=640, height=480, framerate=15/1 ! autovideoconvert ! vaapih264enc ! rtph264pay !  udpsink host=192.168.8.2 port=5600

      Setting pipeline to PAUSED ...

      error: XDG_RUNTIME_DIR not set in the environment.

      libva info: VA-API version 0.39.0

      libva info: va_getDriverName() returns 0

      libva info: Trying to open /usr/lib/dri/i965_drv_video.so

      libva info: Found init function __vaDriverInit_0_39

      libva info: va_openDriver() returns 0

      Pipeline is live and does not need PREROLL ...

      Got context from element 'vaapiencodeh264-0': gst.vaapi.Display=context, gst.vaapi.Display=(GstVaapiDisplay)NULL;

      Setting pipeline to PLAYING ...

      New clock: GstSystemClock

       

      i found no ways to match the baud rate of autopilot with qground control.Also i tried to

      disabled the MAVLink router by running

      /etc/init.d/mavlink-routerd.sh stop but unfortunately i found no file named mavlink-routerd.sh in init.d directory but have a file named mavlink_bridge.sh in the init.d directory.