4 Replies Latest reply on Sep 19, 2017 8:56 AM by Intel Corporation

    7265 AC Link Speed limited to 433 Mbps

    phoenx97

      Hello,

      I'm trying to figure out why the Intel 7265 that came with my motherboard (ASRock x370 ITX) is limited to 433 Mbps link speed as opposed to 867. I did a search for others that had similar problems and tried to apply the settings recommended in those threads (in driver configuration and power plan) but without success. On the newest Intel wireless drivers (package 19.70.0 - motherboard's site just offers an older one) and Windows 10 has all the latest updates.

       

      I am about 8 feet from an Netgear R7000 and my iPhone getting 867 Mbps from the same desk. Couple of weird things I noticed: upon disabling then re-enabling the device in Network Adapters, I get the 867 link speed for a few seconds before it reverts back (maybe because it's just initializing). Also, when detaching one of the antennas (left one), the link speed will stay the same but removing the other one will reduce it (even with the left one still connected). Are there other methods through software I can use to debug this, or might this be a hardware issue with the wiring of the antenna?

        • 1. Re: 7265 AC Link Speed limited to 433 Mbps
          mjeffrey1

          Looks as if you only have one antenna connectrd to the 7265. to get 867 Mbps you need 2 antennas.

          1 of 1 people found this helpful
          • 2. Re: 7265 AC Link Speed limited to 433 Mbps
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hi phoenx97, 

            We understand your situation regarding the connection rate that is limited to 433.3Mbps. We checked the SSU logs provided and all the settings are set up properly in order for you to get 867Mbps connection rate speed. 

            This situation could be related to the channel width that is not set up properly on your router, we were checking manage this option but we were not able to find the specific setting, however we fond on the Netgear* Communities site this thread. They mentioned that there is no a specific option to manage it but on the message 14 of 20 one user mentioned that if you change the option "Enable 20/40Hz Coexistence" it will automatically set up the connection rate to 40Mhz.

            We advise you to try disabling the "Enable 20/40Hz Coexistence" setting on your router, you can check the Netgear* User Manuals on page 110 you will see how to do it. 

            NOTE: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there.

            Please let us know if that helps. 

            Regards,
            Junior M.

            • 3. Re: 7265 AC Link Speed limited to 433 Mbps
              phoenx97

              Router was set to 20/40/80 so it wasn't the problem. I went ahead and took the card from the motherboard and opened up the casing; one of the antenna leads was disconnected from the card. Everything is working as expected now

              • 4. Re: 7265 AC Link Speed limited to 433 Mbps
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Hi phoenx97, 

                We are glad to hear your situation has been resolved.

                If you have further questions or concerns then feel free to contact us again. 

                Best regards,
                Junior M.