10 Replies Latest reply on Sep 15, 2017 2:51 AM by MartyG

    My MacBookPro2015 fails to get depth image

    NGC6543

      Hi all,

      I'm trying to get my SR 300 work.

      On my iMac 5k, the examples worked (though slightly unstable).

      And I tried to do the same on my laptop(MacBook Pro 2015) but it doesn't work.

       

      So I checked the system report,

      and it shows that 'BlasterX Senz3D VF810' is connected through USB 2.0

      'while Intel RealSense Camera SR300' is connected through USB 3.0.

      realsense sr300.png

      I'm away from my iMac so I can't compare this with what is shown on my iMac.

      but I'm wondering if this is a normal behaviour or not. I thought the realsense devices won't work on USB 2.0, will it?

        • 1. Re: My MacBookPro2015 fails to get depth image
          MartyG

          Do you have a BlasterX Senz3D camera plugged into your USB 2.0 port, or do you only have the SR300 camera plugged in to your USB 3.0 port?

          • 2. Re: My MacBookPro2015 fails to get depth image
            NGC6543

            Hi MartyG,

             

            I only have 1 SR300 connected to the laptop.

            But it shows both SR300 and blasterX on the system report.

            • 3. Re: My MacBookPro2015 fails to get depth image
              NGC6543

              Hey,

              The hardware casing tells that it requires 6th Gen Intel Core processor or above,

              whereas my laptop (MacBook Pro 2015) has 5th Gen Core-i5 2.9GHz(5287U I guess).

              Could this can cause this kind of problems?

              • 4. Re: My MacBookPro2015 fails to get depth image
                MartyG

                Ok.  I have seen this before, where it lists both the SR300 and Creative BlasterX Senz3D (a version of the SR300 sold by Creative under their own brand name).  It is unusual but I don't think it stops the camera from working.  Even stranger, all the cases I have seen of this occurring involve Chinese users. 

                 

                You are correct that RealSense cannot work in the USB 2.0 port.  Also, having a 5th generation processor could potentially reduce the chances of an SR300 working.  There have been a small number of cases where the SR300 was able to work fine with a non-6th processor such as 5th generation Intel Xeon enterprise processors though.  In those cases with the Xeon, it was 50-50 odds whether it worked or not.

                 

                Your issue with your other Mac where the camera does work, but erratically, sounds as though it is related to the power stability of the USB port.  This can vary between machines, which is why it may work on one machine but not another.  If the power supplied is unstable then the camera may disconnect often.  Using a mains-powered USB hub can help to increase the camera's stability a lot.  They can be purchased for around $15 from stores such as Amazon by searching for 'powered usb 3.0 hub'.

                 

                There was also a recent case where a Macbook user achieved the same effect as a mains-powered hub by attaching the camera to their Macbook's s external USB-C to HDMI/USB extension. 

                 

                Re: camera not responding after cdm firmware update

                • 5. Re: My MacBookPro2015 fails to get depth image
                  NGC6543

                  I'll try again on iMac with a USB 3.0 hub with external power supply.

                  Also, do you mean that buying from the 'official intel store'  won't have this weird dual-name phenomenon?

                  If so, I'll buy from it then.

                   

                  Anyway, I appreciate your kind and thorough reply. I'll try above tomorrow. Have a good day!

                  • 6. Re: My MacBookPro2015 fails to get depth image
                    MartyG

                    It hasn't been established exactly why this dual name phenomenon occurs particularly with users n the Chinese region.  My own theory is that as the BlasterX and SR300 look practically identical (being made by the same company), some non-Intel stockists may sell the BlasterX as an SR300.  There's no evidence of that though, it's just my personal hunch.    The BlasterX is just as good a product as the SR300 though, so people who were supplied with one are not getting a bad deal.

                     

                    If you purchase from the official Intel store though then you will be guaranteed to get an official SR300.  The SR300 is being retired this month though, so you should order one soon or the Creative BlasterX and Razer Stargazer may be the only options left for purchasing an SR300-compatible camera.

                     

                    Good luck! 

                    • 7. Re: My MacBookPro2015 fails to get depth image
                      NGC6543

                      Hey,

                      I tried again on my iMac and also on a Mac Mini. Both Mac shows the dual-name problem above, but it works anyway.

                       

                      To my surprise, SR 300 runs on Mac Mini(which has only 4th Gen 1.4GHz Core i5 CPU).

                      I guess my laptop has some issue with SR 300, trying to figure it out...

                       

                      ++ In the examples my device failed to retrieve infrared2 image.

                       

                      ++ Using the USB 3.0 Hub with external power supply works on my macbook pro. Looks like the laptop USB power wasn't enough.

                      Thanks!

                      • 8. Re: My MacBookPro2015 fails to get depth image
                        MartyG

                        A Mac Mini probably counts as the kind of 'exotic' configuration that, like the Xeon processors, defy the SR300's official minimum spec and offer more flexibility when it comes to the chances of whether it works or not.

                         

                        You are not the first person to have had trouble displaying the INFRARED2 stream.  The last time I researched the topic,  one person suggested " re-running the patch script (noting if anything fails, and remembering to sudo modprobe uvcvideo after)."

                         

                        It also seems to be an issue that occurs or does not occur depending on the machine you are using - users found that the camera was fine on some machines but did not show infrared2 on other machines.  This was believed to be related to the particular USB 3.0 chipset that each machine uses.

                        • 9. Re: My MacBookPro2015 fails to get depth image
                          NGC6543

                          It seems you are right. I accidentally unplugged the power cord to the hub while running an example,

                          but the device just worked fine. So I tested again and the result is...

                           

                          The SR300 works fine with an USB 3.0 hub with or without an external power supply on my MacBook Pro.

                          But it fails when it is plugged right into the USB port of the laptop.

                          It's just getting weird and weird...

                           

                          About the patch script, can you point me where I could find it, please?

                          • 10. Re: My MacBookPro2015 fails to get depth image
                            MartyG

                            A couple of other people have found recently that the camera functioned for them with a powered hub even when the hub was switched off.  Another person whose camera wouldn't work with their machine's USB port found that it still didn't work when plugged into a powered hub, but then the camera worked when they plugged it back into the machine directly afterwards.  So clearly there's some USB configuration issues going on. 

                             

                            The instruction in Librealsense for patching uvcvideo for the 4.4 kernel is this:

                             

                            ./scripts/patch-uvcvideo-4.4.sh v4.4-wily