1 Reply Latest reply on Sep 6, 2017 10:26 AM by Stefan3D

    No 2560x1440 via HDMI on recent Kaby Lake notebook

    SF6

      Hi all,

       

      I just tried to attach my brand new Panasonic CF-SZ6, i5 7200U, HD620 (Japanese model) to my ASUS PB328, 2560x1440p capable LCD.

      My notebook only recognizes the LCD as a "Digital Television (which it is not) PB328" and a maximum resolution of 1920x1080p60Hz.

       

      What I tried so far:

      1. Installed two drivers from the manufacturer 21.20.16.4550 and 21.20.16.4727 -> no change

      2. After some messing around (wouldn't let me install a generic Intel driver) I installed 22.20.16.4771 from Intel's website -> no change

       

      Nothing so far, still 1080p only.

       

      Then I tried this:

      3. Booted a Fedora 26 live image -> success (full 2560x1440p60Hz out of the box)

      4. Set up a custom resolution in the Intel driver -> success (although I get a warning about "exceeding the maximum bandwidth")

      5. Tried a different HDMI cable -> no change

      6. Tried a different notebook (Dell E5470) via HDMI -> success

       

      I know, the custom resolution actually works, but I still wonder why it wouldn't work out of the box. I'd appreciate any help.

       

      Thank you.

       

      SF6