3 Replies Latest reply on Aug 28, 2017 5:04 PM by Al Hill

    Intel DX58SO2 socket b & modern graphic cards: Radeon Rx560 etc

    Frappedieros

        Hello everyone ! I have been struggling to get a Sapphire RX560 4GB  working with  this board -DX58SO2- but I have no luck so far; it seems it cant recognize it.

      On my first install of the card with a legacy bios I couldnt even get the system to post. The famous no post, no beep, no signal whatsoever issue that drives people

      crazy.

         I used the old card again (Radeon 7770 Ghz edition) and flashed the latest 920 bios  version from windows. Then tried again and my-oh my- the system boots ! I log to windows normally but the card was identified only as Standard Vga. I say no biggie, lets update the drivers .  Next step : Install Raddeon drivers, being super excited that my i7-920 rig will continue to triumph for a few more years , being prompted by the system to reboot...aaand  BLACK SCREEN.

         Once system enters Windows7, black screen and signal goes off. Computer is still running though, you can still  hear all the Windows 7 sounds. No matter what I do, the result always the same,

      black screen whilst windows still running. I can only enter windows 7 in safe mode, where the RX560 is listed as Standard Vga.

       

      So has anyone else tried with newer graphic cards ? Is it a drivers issue ? Is it an incompatibility issue because of the old motherboard ? 

      Am I the only one still struggling on a DX58SO2 ? 

       

       

       

       

      Some useful information : I have an UEFI install of Windows 7  and 16gb of RAM (4x4) installed. I also tried with legacy on another volume & a clean install, same results : Black Screen when Win7 loads.