1 Reply Latest reply on Aug 27, 2017 1:26 PM by N.Scott.Pearson

    1 out of 3 usb controller suddenly dissapears and appears as "unknown device"

    ibasicallysuck

      so all my usb ports worked fine yesterday, and when i got on my computer today, 1 out of 3 of the usb ports just won't scan for anything. i know this because yesterday it was where i originally plugged in my mouse,  and when i got back to my pc, my mouse suddenly stopped working. so i checked the device manager under the universal serial bus controllers, and i only see 2 usb intel driver controllers, and 1 other device marked as "unknown device" with a yellow mark sign. i quckly assume that it is the third usb port and its not working. i tried reinstalling the chipset family, but it ended up the same, 2 usb intel driver controllers, and the unknown device. i tried to check if its broken or spilled by water, so i grabbed a data cable and my phone. to my surprise, its charging so i quickly assume its still working. i don't want to reset my pc because im afraid that i would sacrifise my data and to be greeted by the usb port with the same status. i tried a bunch of methods, ranging from simply restarting my pc to restoring my settings to previous times, even restoring the settings doesn't work, i restore it to yesterday, then a week ago, then a month ago.

       

      what to do?