9 Replies Latest reply on Aug 28, 2017 3:35 PM by Artim

    driver problem with Windows 10 1704?

    Artim

      I recently made the upgrade to Windows 10 1704 (after rolling back because of too many bugs).

      Besides another bug, Chrome was crashing/freezing quite often. So I looked into Windows'  ressource monitor and saw a red entry of chrome.exe saying "chrome.exe is waiting for another process: svchost.exe (NetworkService)" in the queue. Killing Chrome or the svchost-subprocess on any way resulted in an access denied. So I thought Windows was the cause and that they screwed up an upgrade yet again. Adding to this, it didn't matter if I used Chrome dev or stable and even Edge crashed on me even "lying" about it by not giving a "not answering" and not exactly freezing but not really reacting on much and not being able to load any site.

      About three days I had enough and made a fresh installation of Windows...without any success. So I took a look into the event viewer (or whatever they call it in english) and found following error:

      Das Schließen einer UDP-Socket mit der lokalen Portnummer "59217" im Prozess "3024" dauert länger als erwartet. Die lokale Portnummer ist möglicherweise erst nach Abschluss dieses Vorgangs wieder verfügbar. Der Grund hierfür liegt in der Regel im fehlerhaften Verhalten von Netzwerktreibern. Stellen Sie sicher, dass die neuesten Updates für Windows und für die Netzwerksoftware von Drittanbietern einschließlich NIC-Treibern, Firewalls oder anderer Sicherheitsprodukte installiert sind.

      For those not speaking german in short: it's some problem about closing a UDP-Socket and that the reason is mostly a bad network driver.

      Well, I'm using the SetPRO version from Lenovos website since this is a lenovo laptop, but I also tried to uninstall the driver and Proset and install it from Intels download section but nothing changed. Chrome keeps freezing, especially after waking up my laptop from sleep or hibernation (which happens very often since I pretty much never shut down my laptop because a I still have an HDD running b because I am too lazy to open up all programs again after the system is finally ready to work at an appropiate speed and c I deactivated hybrid shutdown since it often either causes problems or at least stops solving them since that often needs a real restart).

      I also experienced that a simple restart is often helping only for a very short time, a restart via shutdown -g -t 0 gives me a bit more time to the next freeze. And Chrome doesn't exactly crashes, it freezes for a few minutes and then returns to normal. But then it's pretty much guaranteed that it will freeze again in the next minute and if it goes back from showing that blue Windows bar of "process not responding" it is frozen completely, it's not reacting to anything and killing it from task manager does nothing.

       

      My WiFi device is a Intel Dualband Wireless N 7260.

        • 1. Re: driver problem with Windows 10 1704?
          Al Hill

          What is the model number of your processor?

          What is the model number of your motherboard or system?

           

          Doc

          • 2. Re: driver problem with Windows 10 1704?
            Artim

            I'm running the i5-4210U , but I'm not sure what my motherboards model number is. A  wmic baseboard get product,Manufacturer,version in PowerShell gives me

            Manufacturer  Product     Version

            LENOVO        20ALCTO1WW  SDK0E50510 PRO

            • 3. Re: driver problem with Windows 10 1704?
              Al Hill

              Is your lenovo system a laptop? 

              Did your system come with the N7260?

               

              Doc

              • 4. Re: driver problem with Windows 10 1704?
                Artim

                Yes, it is, it's a Thinkpad x240 and yes, it came with a Intel Dual Band Wireless-N 7260 (802.11a/b/g/n, 2x2, Bluetooth 4.0)

                • 5. Re: driver problem with Windows 10 1704?
                  Al Hill

                  Ok, thanks for the information.  It will help the Intel support staff when they respond.

                   

                  Doc

                  • 6. Re: driver problem with Windows 10 1704?
                    Intel Corporation
                    This message was posted on behalf of Intel Corporation

                    Hello Artim,

                     

                    Thank you for joining the General Questions community. My apologies for the inconvenience. 

                     

                    I would like to know if you have contacted Lenovo's support regarding this matter, the support for your wireless card should be provided by them and it is also possible that they are aware of the situation and can provide more troubleshooting steps in order to address this behavior. 

                     

                    Regards,

                    Amy C.

                    • 7. Re: driver problem with Windows 10 1704?
                      Artim

                      I will and I'll report back if I know more

                      • 8. Re: driver problem with Windows 10 1704?
                        MartyG

                        This message should not be taken as an attempt at solving the case, but just some additional insight that may or may not be relevant. 

                         

                        A couple of weeks ago I was helping with a case in the RealSense camera forum where someone had problems with a JavaScript web file that kept causing failure during an installation process.  They had Proset installed.

                         

                        Someone on that discussion thought that using Windows to manage WiFi settings worked much better than letting Proset do it.

                         

                        Re: Laptop wireless set up problem

                        • 9. Re: driver problem with Windows 10 1704?
                          Artim

                          Well, that would need some JavaScript file in google.com that crashes every browser randomly after waking up from sleep mode. And I'm not trying to install anything, I wake up my laptop from sleep mode and just try to use Chrome. It seems just slow which isn't surprising when Superfetch is sucking on your HDD like crazy when waking up (but has notthing to do with the problem since I disabled it before the reinstallation and it hadn't any effect) but then you notice it takes longer than normal to load anything and then Chrome just gets that blue Widnows-typical bar at the top. Then you know it's screwed and you have to restart through shutdown -g -t 0. Thankfully Windows' execute windows you get with Win+X remembers the last thing you entered...

                          And I pretty much just haave ProSet for the drivers, I haven't managed anything through ProSet. If I set up a WiFi network it's throuh Windows itself. So as long as ProSet doesn't suddenly takeover everything network in Windows after installation I don't think it should be much of a problem.

                          I also have no ProSet Icon in the utility bar and the only proSet processes running are Wireless event Log Service, Wireless Registry Service, Wireless Bluetooth iBtSiva Service and Wireless zero Configure service