14 Replies Latest reply on Aug 28, 2017 8:08 AM by MartyG

    camera not responding after cdm firmware update

    AlexSmirnoff

      Just got new SR300. It worked fine until I decided to upgrade firmware with CDM intel_rs_dcm_sr300_3.3.27.5718

      Any idea how to restore it?

      It is virtually bricked as nor windows nor CDM does not recognize it anymore.

        • 1. Re: camera not responding after cdm firmware update
          MartyG

          If you have successfully installed the DCM software at least once then you should have a file on your computer for installing the firmware only without having to do so with the DCM.  This has an option to 'force' the installation.

           

          The posting linked to below explains how to do a force-install of the firmware for the SR300, and how to submit a returns claim for refund or replacement if recovery of the camera is not possible.  Please be aware that the SR300 and R200 camera models are about to be retired as the super-powerful new D415 and D435 models go on sale in September, so if you are going to request a replacement SR300, you should do so sooner rather than later whilst stocks last.

           

          Re: SR300 Not Recognized Anymore

           

          If you wish to go the route of purchasing a replacement SR300 now and then submit the current one that you own  for a return, the SR300 is now on sale in the Intel Click store at a discount ahead of the D-cameras' launch.

          • 2. Re: camera not responding after cdm firmware update
            AlexSmirnoff

            After trying to restart few times and disconnecting USB port I managed to get SR300 recognized by Windows. However, depth camera is not working. Device Explorer is not working either: it states "Device failed due to malfunctioning".

             

            Tried to use the utility FWUpdateSR300.exe, but it is very confusing what exactly it expects to do.

             

            FWUpdateSR300.exe  -update

             

            not working: "Failed to get FW file revision"

             

            FWUpdateSR300.exe  -update -force

             

            not working either. Similar problem to find "FW file"

             

            The only successful command is:

             

            FWUpdateSR300.exe  -isConnected

             

            The output is like this:

             

            Camera Connection State = Connected

             

            Camera Generation:      Ivcam 1.5

            Camera Connection Type: Peripheral

            Device ID:              1eb99ea6

            Serial Number:          619205002296

            OEM ID:                 0xcafecafe

            Firmware Revision:      3.21.0.0

             

            Command:                Camera Connection Check

            Status:                 No Error

             

            **********************************************************

            FW update return code: 0

             

            When doing this:

             

            FWUpdateSR300.exe -getConnectedDevices

             

            in addition to above message, I am getting: "Recommendation:  Downgrade Required".

             

            So how to downgrade the FW? Is there an additional utility for this?

            • 3. Re: camera not responding after cdm firmware update
              AlexSmirnoff

              I have 7th generation of intel processor. The requirement is 6th. Could this be a problem?

              • 4. Re: camera not responding after cdm firmware update
                MartyG

                A 7th generation processor is not a problem.  It's only a problem if you have an older processor (e.g 5th generation). 

                 

                You would perform a downgrade by installing an older version of the DCM program.  But trying to downgrade the firmware can get you into more problems than trying to install the current version.

                 

                During my research, I found a new version of the SR300 'force' instruction that adds an additional command oemID.  It offers the option to write a new firmware by pressing the Y key to say yes.

                 

                FWUpdateSR300.exe -oemId:0xcafecafe -force

                • 5. Re: camera not responding after cdm firmware update
                  AlexSmirnoff

                  I have reinstalled Windows 10 it did not help.

                   

                  I have upgraded to Windows 10 Pro (spent additional $200) - it did not help. I do not count my personal time that cost, even more.

                   

                  The driver is recognized and installed, but the camera does not work.

                   

                  • 6. Re: camera not responding after cdm firmware update
                    MartyG

                    Can you confirm please that you have the RGB, Depth and Virtual drivers listed in the Imaging Devices section of the Device Manager window?

                    • 8. Re: camera not responding after cdm firmware update
                      MartyG

                      Ok, that looks fine.

                       

                      At the start of this discussion, you stated that Windows did not recognize the camera.  Now after the Windows upgrade, you said that Windows does now recognize the camera.  This suggests that the firmware is functioning correctly, and that there is an additional problem.

                       

                      It is possible that your SR300 is being affected by the current problems with Build 15063 of Windows (also known as the Creators Update).  This particularly affects the Depth part of the SR300.  Could you check your System Information window please to see if the Build number is 15063?

                      • 10. Re: camera not responding after cdm firmware update
                        MartyG

                        Having minimized the likelihood of other possibilities, I would say that there is a very strong chance that you are one of the SR300 users who have unfortunately been affected by the issue with Build 15063 of Windows 10 that causes some peoples' cameras to malfunction, whilst others do not experience the problem.  Intel and Microsoft have been working together on a fix for some months but a patch has not been able to be developed yet that corrects the problem.

                         

                        Intel's advice for now is to use DCM version 3.3.27.5718.  I note that installing that DCM is where your problem seemed to begin at the start of this case though.

                         

                        There are workarounds that have been posted on the forum, but they do not work for everyone, and I appreciate that you have already invested money and valuable time in trying to solve the problem.

                         

                        How to get SR300 working on Windows 10 Build 1703 - Including SDK Apps such as Segmentation (Updated 5/17/2017)

                         

                        I would therefore identify your options now as being:

                         

                        1.  Install an earlier build of Windows 10 that pre-dates 15063, such as the Anniversary Edition

                        2.  Try some of the workarounds.

                        3.  Plug the camera into a mains-powered USB 3.0 hub instead of directly into the PC's USB ports.  or

                        4.  File a claim for a refund or replacement of the camera whilst it is still inside the 90 day warranty period

                        • 11. Re: camera not responding after cdm firmware update
                          AlexSmirnoff

                          Thank you, Marty.

                           

                          For me, finally, the work around was using my Macbook external USB-C to HDMI/USB extension.

                           

                          20170826_121425.jpg

                           

                          • 12. Re: camera not responding after cdm firmware update
                            MartyG

                            Awesome news, I'm so glad that one of the suggested solutions worked for you.  Please come back to the forum any time you need further help.  Have a great weekend!

                            • 13. Re: camera not responding after cdm firmware update
                              MrJam_HH

                              This is so incredibly ridiculous that a company as Intel sells a product to the customers and does not keep up with the updates of the OS. It seems to me that Intel is on the level of a 6 employee chinese company selling a product and then closes its doors. It is really shamefull, INTEL!!!!!

                              • 14. Re: camera not responding after cdm firmware update
                                MartyG

                                I truly understand the frustration of affected users.  Intel have made a lot of effort to fix the problem, working with Microsoft, but unfortunately a single definitive solution has not been able to be found.  Part of the problem is that it affects some users but not others.  Also, some of the workarounds work for some people but not others.  I realize that to the users such as yourself who are among those that are affected, there are no words that can make it feel better.  I am not an employee of Intel and so cannot speak for them, but I know they have tried everything possible to rectify this situation.