7 Replies Latest reply on Sep 1, 2017 8:35 AM by MartyG

    SDK sample browser fails to work

    sophia_h

      Hi~

      I used to install F200 camera and SDK R2, and they work well. Recently, I found that SDK sample browser is slow to response and it can't detect the camera. Running source code also failed to initialize the camera. However, other apps can use depth camera and RGB camera successfully.

      To solve the problem, I uninstalled and reinstalled DCM and SDK R2 several times, and tried to use SDK R3. But neither of them worked out.

      I guess that it is related to Windows 10 creators update, but I am not really sure.

      Cound someone offer me some hints?

      Thanks in advance

        • 1. Re: SDK sample browser fails to work
          MartyG

          Comparing your case to previous cases, the pattern fits the characteristics of a problem where the camera works fine for a while and then something in Windows has updated and changed the behavior of your PC's USB ports so that they can no longer supply the camera with power as stably as they used to.  This causes the camera to disconnect, which may result in freeze-ups of programs that use the camera and the 'not connected' message in the Camera Explorer.

           

          I note though that you are able to use the camera with other applications.  I would expect the RGB to work even if the camera had problems, because if a computer cannot use it as a RealSense camera then it simply uses it as an ordinary webcam, meaning that it will work in programs with video functions such as Skype.  I am more surprised that the depth is working though.

           

          In that green image that you attached (which I assume shows a view of yourself), is the image of you moving or is it a frozen static image?

           

          When you say 'sample browser', do you mean the Camera Explorer?  The Sample Browser application does not require the camera to browse through its contents and so so should not be affected by camera problems.

           

          It does not seem as though the problem is with your RealSense drivers, as the driver listings in the Device Manager look fine.

          • 2. Re: SDK sample browser fails to work
            sophia_h

            Hi, MartyG,

            Thank you for your reply.

            Right, I once suspected that it has something to do with  camera drivers, but then I found that other applications use the camera stably, even the depth camera (the attached image indeed shows a view of myself, and in fact it is a continuous depth information stream). So I denied that assumption.

            "SDK sample browser" I said refers to  examples for F200 that include Camera Explorer (such as 3D Scan, Hands Viewer, etc.). I can open these examples but they're slow to response, and they can not detect or link to the camera (though other apps do well). For example, I could see RealSense Camera under the “Device” Tab before. But there is nothing or just shows "Integrated Webcam" of my laptop now, as shown in attached image. It is also not feasible to run  code in the directory D: \ Program Files (x86) \ Intel \ RSSDK \ sample. It seems that something stops  sample codes from initializing or calling the camera. (I have chosen "Run as Administrator".)

            • 3. Re: SDK sample browser fails to work
              MartyG

              On the 3DScan sample, you need to tick the 'Landmarks' option at least before you click 'Start Camera' or it will not work.  You can tick a combination of options, but one of them should be 'Landmarks'.

               

              You cannot run the samples from the Program Files(x86) folder because it is a protected folder that cannot have data written to it.  You have to copy the samples to a different location on your computer or run them from the Sample Browser application.

              • 4. Re: SDK sample browser fails to work
                sophia_h

                    Sorry for late reply

                    I have tried these two solutions, but they doesn't help.

                    Thanks for your help again!

                • 5. Re: SDK sample browser fails to work
                  MartyG

                  I read your earlier message again.  Can you please confirm that when you took the picture of your Device Manager that showed the drivers successfully installed, this was before the drivers disappeared and you now only have 'Integrated Webcam' there?

                  • 6. Re: SDK sample browser fails to work
                    sophia_h

                    Yes,I am sure that the camera is installed successfully. Especially I found that it can be used by other apps. However, it still can't be detected in the SDK sample browser.

                    • 7. Re: SDK sample browser fails to work
                      MartyG

                      What kind of apps are you running successfully?  If it is video apps like Skype and you are using a laptop computer then it is probably your integrated webcam in the laptop producing the video picture and not the RealSense camera.