13 Replies Latest reply on Sep 4, 2017 1:31 PM by Intel Corporation

    R200 Color Camera issue with Librealsense library. no matching media type for  pixel format 59555932

    pratzz

      Hello all,

       

      For quite sometime, I am facing this weird issue with R200 color camera. Librealsense library worked awesome for few days and then all sudden it started giving me a weird texture when I run the base cpp-config-ui project. Unable to use R200 in default windows camera app as well. The depth and infrared streams are pretty normal. I attached the images of the issue. I have to redo entire work if librealsense doesn't work well with color.

       

      Error : "RealSense error calling rs_start_source(device:000001DF94F42470, source:VIDEO): no matching media type for  pixel format 59555932"

       

      I tried looking for answers for this behavior and did reinstall(SDK+DCM), update and restart several times. Some people got it fixed with simple restarting and updating drivers, but that is not the case with me.

       

      I changed my processor twice and it worked fine with new processor for a month and then the issue is back. I changed 3 different R200s, everything worked fine for the first time and then again the issue is back.  With F200, I did not face this problem. On the other hand, Camera explorer of SDK works good.

       

      Any help is highly appreciated. I am hoping logical explanation from Intel for this behavior. Is it realiable to use R200 with librealsense library ?

       

      Thanks in advance,

      Prathyusha