1 2 Previous Next 20 Replies Latest reply on Jan 26, 2018 1:14 PM by Ronald_Intel

    Bug in Intel Vulkan driver


      It is currently impossible to use a reverse-z technique with your Vulkan driver as it completely ignores minDepth and maxDepth fields in VkViewport structure.


      The driver always defaults to minDepth = 0.0f and maxDepth = 1.0f, even if both fields are set to minDepth = 1.0f and maxDepth = 0.0f, producing wrong depth buffering results.


      This technique is mentioned in one of your tutorials:

      API without Secrets: Introduction to Vulkan* Part 3: First Triangle | Intel® Software


      More info on Khronos pages:



      Drivers affected:

      -15.45 and 15.46 on Windows 7 x64 / Windows 10 x64


      Hardware used:

      -Intel HD 530 (Intel Core i7 6700k)


      NVIDIA / AMD hardware works as expected, only Intel is affected.


      SSU scan attached.

        • 1. Re: Bug in Intel Vulkan driver

          Hello thom36,


          Thank you for reporting this issue to us. If it is not asking too much, can you add the issue details using the table format as detailed here: IMPORTANT - Required information for reporting Graphics issues

          Once we have this info I'll report it directly to our development team.


          Kindest Regards,

          Ronald M.

          • 2. Re: Bug in Intel Vulkan driver

            Thank You, Ronald.





            Answers (N/A if not applicable)


            Provide a detailed description of the issue

            Intel's Vulkan driver ignores minDepth and maxDepth fields in VkViewport structure, always defaults to minDepth=0.0f and maxDepth=1.0f disallowing to use a reverse-z technique

            Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' <- This would be "Often")

            Always (100%): X

            Often (51-99%):

            Sporadic (20-50%):

            Very Sporadic (<20%):

            Hardware (HW)

            Brand and Model of the system.

            Custom built desktop PC

            Hybrid or switchable graphics system?
            ie Does it have AMD or NV graphics too?

            PC also has GeForce GTX 960 in PCI Express slot, monitor cable connected to Intel HD 530 (i7 6700k)

            Make and model of any Displays that are used to see the issue (see note2 below).
            = Local Flat Panel (Laptop panel)
            EFP = External Flat Panel (Monitor you plug in)

            Tested on 3 monitors:

            ASUS MX239H EFP

            SAMSUNG 743BM EFP

            SAMSUNG 797MB EFP

            but the issue can be observed on any display

            How much memory [RAM] in the system (see note2 below).


            Provide any other hardware needed to replicate the issue.
            ie: Cables&brand, cable type [vga, hdmi, DP, etc], dock, dongles/adapters, etc


            Hardware Stepping (see note1 below).





            Software (SW)

            Operating System version (see note2 below).

            Windows 10 AU x64 and Windows 7 x64

            VBIOS (video BIOS) version. This can be found in “information page” of CUI (right click on Desktop and select “Graphics Properties”.


            Graphics Driver version; for both integrated Intel and 3rd party vendors (see note2 below).

            Intel: (15.45, tested on Windows 7 x64) and (15.46, tested on Windows 10 AU x64)

            NVIDIA: 384.94 on Windows 7 x64, 382.05 on Windows 10 AU x64

            SW or Apps version used to replicate the issue.

            Vulkan SDK 1.0.51, custom built app


            Single display, clone, or extended (see note2 below).

            Single display

            Display resolution & refresh rate setting of each display (see note2 below).

            ASUS MX239H: 1920x1080@60

            SAMSUNG 743BM: 1280x1024@60

            SAMSUNG 797MB: 1024x768@100

            AC or DC mode, i.e. is power cable plugged in or not?

            AC mode

            How to repro

            Please provide steps to replicate the issue.  These steps are very crucial to finding the root cause and fix.
            A screenshot to illustrate the issue is a huge plus. A video of the failure is even better! Attach to the post or provide the YouTube link.

            1. set minDepth=1.0f and maxDepth=0.0f in VkViewport
            2. clear depth buffer to 0.0f or render a triangle with depth=0.0f
            3. notice depth buffer isn't calculated in reverse


            • 3. Re: Bug in Intel Vulkan driver

              Hello thom36,


              I apologize for not replying sooner, I try to stay away from the "we're working on it" kind of updates.

              With the information you provided, I filed internal bug ID 1406462374, and our devs were able to reproduce the issue.

              Today I was informed that we have a fix checked-in, so please look forward to our next 15.46 and higher driver releases.


              Thank you for taking the time to report this issue to us.


              Kindest Reegards,

              Ronald M.

              1 of 1 people found this helpful
              • 4. Re: Bug in Intel Vulkan driver

                That's an excellent news, thank you for doing a fantastic job.


                I will be waiting for the next driver update.

                • 5. Re: Bug in Intel Vulkan driver

                  I installed the latest update that has been released yesterday ( ( but I see no changes whatsoever.


                  Could you please check if the fix has been included in the mentioned update?


                  With viewport.minDepth=1.0f and viewport.maxDepth=0.0f, depth that should be written for a triangle with depth=0.95f is 0.05f, not 0.95f.


                  I use VK_FORMAT_D32_SFLOAT_S8_UINT format.

                  • 6. Re: Bug in Intel Vulkan driver

                    Hi again thom36,


                    Thank you for your reply. Let me check with our devs, I think the fix was checked-in after this particular driver package was finalized, but need to confirm it first to be sure.

                    I'll let you know once I have more details.


                    Best Regards,

                    Ronald M.

                    • 7. Re: Bug in Intel Vulkan driver

                      Hi thom36,


                      I got confirmation from my dev that this fix is going to be included in the upcoming 15.60 driver baseline, which should be coming out sooner rather than later. Unfortunately I cannot provide any ETA since release dates can shift at any time.

                      As I have more information I'll post it here.


                      Best Regards,

                      Ronald M.

                      • 8. Re: Bug in Intel Vulkan driver



                        Will 6th Gen be still supported in 15.60 baseline?

                        • 9. Re: Bug in Intel Vulkan driver

                          I just tested the latest 15.60 release and I can confirm the bug I reported has been sucessfully fixed.


                          6th Gen Core processors are supported in this baseline.

                          • 10. Re: Bug in Intel Vulkan driver

                            Hi again thom36,


                            Ahhhh you beat me on the reply time!

                            I am happy to hear that this is working fine now with 15.60.

                            Once again, thank you for taking your time reporting this issue and helping us make a better product.


                            Kindest Regards,

                            Ronald M.

                            • 11. Re: Bug in Intel Vulkan driver

                              Hi Ronald_Intel, Xavier told me i should asking help in this thread. Yups and i have the same issue, after installation driver, Vulkan reports 1.0.0 version API. All programs that check level support of API says that Vulkan driver is 1.0.0 instead 1.0.61, even Intel HD Graphics Control Panel reports 1.0.0.  I tried everything, nothing helps. All system scans, you can take from this thread.

                              • 12. Re: Bug in Intel Vulkan driver
                                Intel Corporation
                                This message was posted on behalf of Intel Corporation

                                Hello Parapele,
                                Let me do further research about this and come back to you.  I will post information on this thread as soon as I have it.
                                Fred D.

                                • 13. Re: Bug in Intel Vulkan driver

                                  Hello Fred! Just quick update. You probably have noticed, some Intel driver files different and wonder why. That's because first time i installed driver 11/11/2017, found that Vulkan broken, then downloaded and installed driver again - nothing change. Today i decided check MD5 and found that it different. Driver zip package was updated when Bryce made official post . Old zip 4849 MD5 - 081FA73B48D6F4B6A1F1DE5F0540D2E2, new zip 4849 MD5 30EBDB2ADD1D8778F180A544522B842E. Difference between driver package.

                                  2017-12-05 07_04_18-.jpg

                                  Installation_Readme.txt says only difference is Intel(R) Display Audio Driver: (old) and Intel(R) Display Audio Driver: (new) So, in the world now exist two driver package and it can be very confusing. After installing new driver nothing change. I attached new scans files, just in case..

                                  • 14. Re: Bug in Intel Vulkan driver
                                    Intel Corporation
                                    This message was posted on behalf of Intel Corporation

                                    Hello Parapele,
                                    I believe we are targeting for a new 15.60 release in the next couple of weeks, so I would suggest checking our site and let us know once this driver is available if it has any issue.  I tried here internally and so far it looks good, no conflicts in the versioning.
                                    Can you check how many different Vulkan packages you have installed under "Programs and features"? This can help me compare with my systems here just in case I'm missing something.
                                    Fred D.

                                    1 2 Previous Next