8 Replies Latest reply on Nov 9, 2017 11:37 AM by Intel Corporation

    Unable to re-install SST Audio driver after having removed it (Comput Stick STCK1A32WFC / Windows 10 Creators)




      Earlier in August I upgraded Windows 10 to the Creators release.

      From then I started having sounds issues when watching videos. After a while, getting cracks and other strange effects.

      Restarting the app was not solving the issue, the sound problem was still there. So I though the sound system / driver was getting unstable, not the app itself.

      Only a reboot was, temporarily, solving the issue.


      So I decided to re-install the audio driver. I went in the devices manager and removed the device + the driver for Intel SST Audio. I was surprised Windows would not detect the device at reboot and automatically re-install / download the driver. So I had to look for the driver online and downloaded the SOC archive from there https://downloadcenter.intel.com/fr/product/86612/Intel-Compute-Stick-STCK1A32WFC


      The device manager is strangely telling me about 3 bluetooth unknown devices.

      One of them is "Device ACPI\808622A8" and I forced installation of the sst driver which can be found in the /Audio/ of the archive. I did not know what to do with Realtek one ?


      I then tried to reboot, keeping the two other unknown bluetooth devices untouched ... but Windows would not start again. Crash looping. Only way to boot is to go in recovery mode and remove the sst device again.


      I am now stuck with no sound and would appreciate some help please.




      Hi again,


      I worked a bit on it tonight.


      The two other unknown devices where actually Bluetooth device : my iPhone and another system. removed them and they are gone.


      I re-installed again the Intel SST Audio Device, from the drivers list, Intel Corporation. It looks like it is installing as it should, the audio icon on the task bar becomes active, it detects my Panasonic TV etc ...

      But no sound. And I also noticed that the drivers details say "Intel SST audio device ACPI\808622A8\1 requires further installation". Just like in this thread Intel SST audio device ACPI\808622A8\1 requires further installation (repost per Intel request)


      And if I reboot, then it does not want to start, keeps crashing. Only option is recovery mode.


      Something which could be helpful : I noticed that the system actually boots, if not plugged to the TV.

      If I let is start unplugged, then plug it, I see the desktop but then ... blue screen. It says something about unable to handle an event.