12 Replies Latest reply on Sep 18, 2017 3:26 PM by Möhre

    Upgrading BIOS from 0047 to 0049 broke all LEDs

    Möhre

      Right after the upgrade all LEDs are no more functional. What happened and what can I do?

        • 1. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
          Orillion

          If the problem you have is what i think it is, i have it to.

           

          After a bios update i can´t disable harddrive led anymore.

          • 2. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
            dougho

            One thing sometimes suggested when there are problems like this after BIOS update is to go into the BIOS and find the feature to reset all parameters to defaults.  Then put things back to the way you want them - one convenient thing to help point out what you may want to change is that there may be something like red asterisk (*) next to the items which were changed during reset to defaults.

            If that does not help, someone reported here a month or so ago that their LED problem was solved by updating the BIOS a second time.

            • 3. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
              lw1948

              Hello Möhre

              You can control Power Button and Ring led behavior with BIOS settings in following way:

               

              1. Press F2 during boot to enter BIOS Setup.
              2. Press F9 to set bios to default settings.

                  3.  Go to Advanced > Power. 

                  4. In the Secondary Power Settings pane, you can:

                     - Change the Button LED brightness, blink/fade behavior, and color.

                       In order to use Power button LED to show the power status:

              • Set the Button LED to Power State Indicator
              • S0 Indicator Brightness set to 50% or 100% as you desire
              • S0 Indicator Blinking/Fade I would advise set to Always On
              • S0 Indicator color – I like Blue

              If you want your Power button LED to indicate Sleeping state set:

              • S3 Indicator Brightness to 50% or 100% (as you prefer)
              • S3 Blinking/Fade – I like 1Hz (will blink in 1Hz frequency)
              • S3 Indicator color – Amber
              • S3 State Indicator – Blink

              Of course, the above settings are my preference and you can choose from other options in Bios.

              - Change the settings for Ring LED to show the HDD activity.

              • Ring LED you shall set to HDD Activity Light and in addition check that in Advanced > Devices the HDD Activity LED is checked.

               

              4. After making any changes to the LED settings, press F10 followed by "Y" to save and exit BIOS Setup.

               

              Hope this will help

               

              Leon

               

              • 4. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
                Möhre

                In my case the LEDs do not light up anymore - it doesn't matter what I set them up to. I tried reflashing the current BIOS as well as resetting everything to defaults without any success.

                • 5. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
                  N.Scott.Pearson

                  Just a thought: Did you, by any chance, recently have your NUC's chassis open? If so (or perhaps regardless), open it (again) and check to see whether the cable for the front panel is properly inserted in its connector on the board.

                   

                  Hope this helps,

                  ...S

                  • 6. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
                    Möhre

                    I hadn't it open a long while, but I checked that. There is no voltage on the circuit. Also the Power-LED is fixed at the board... there is no way to disconnect it. So the BIOS update bricked it somehow =/

                    • 7. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
                      Möhre

                      I could bring back the Power-Button to life by setting it to "HDD-Activity" / "blue" / "0 - 50%". All other settings do not cause light coming outta there. Ring is still completely dead =(

                      • 8. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
                        lw1948

                        You shall read carefully my post #3. If you will follow what is written in this post it should work. You can use included translator to translate my post to language you can understand.

                        Now, since you have chosen the Power Button LED to to show HDD activity it will be lighted only when the HDD activity is detected.

                        In this case you can use the Ring Led to show the power status. In order to do it you need the Ring LED set to Power State Indicator.

                         

                        And again, my post above describes the default settings (i.e. Power Button LED indicates Power State and the Rind Led indicates HDD activity). When you chose those settings you can control Power Led brightens and color in S0 and S3 state. However some user don't like the Ring Led showing HDD Activity, finding this LED in this function disturbing.

                         

                        Leon

                         

                        • 9. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
                          N.Scott.Pearson

                          I still gotta say it sounds like the cable for the Ring LEDs is damaged or not plugged in all the way...

                          ...S

                          • 10. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
                            lw1948

                            In order to clarify where the connector for the Front Panel Ring LED (see Scott's comment above) is located. I'm attaching an image of the NUC main board. The LED connector is marked with red circle.

                             

                            Leon

                            • 11. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
                              Möhre

                              It is definetely not an issue with the connector, since I verified good connection using a ohmmeter at several spots.

                              All other settings in BIOS do not work for both LEDs... this points out there is definetely a software problem, because there is no other explanation for the Power LED.

                              • 12. Re: Upgrading BIOS from 0047 to 0049 broke all LEDs
                                Möhre

                                Wow, after doing "Load Defaults" > "Recover BIOS" > remove all USB devices (except keyboard) > "Load Defaults" I got back the "HDD activity" and can assign it to both "Power Button" and "LED Ring". "Power Indicator" mode is still without function.

                                This is sick Oo