11 Replies Latest reply on Aug 30, 2017 11:44 PM by TheScottster

    Having WOL problems with an Intel 82567-LM3 adaptor on a Dell OptiPlex 760 motherboard using Windows 10 Pro 64

    TheScottster

      I've been trying to troubleshoot this issue now for months on and off and have gotten nowhere.

      It seems that WOL is broken when using this hardware under Windows 10.

      I've been using the Windows 10 driver that installs by default (version 12.155.22.6 dated 4/5/2016) and have not been able to find a different one (latest ProSet software doesn't contain a driver for this adaptor).

      I've set everything up that various internet threads I've read have said to do, this includes:

      BIOS:

      Enable the adaptor (duh)

      Enable Remote Wake Up

      Disable Low Power Mode

      Windows:

      Disable Fast Startup

      Make sure, under the Power Management tab, that all the boxes are checked.

      There are no properties for "Waking" in Advanced Properties for the adaptor so I can't set them, nor is there a PME Event Property to check/change.

      ---

      I know that WOL is possible for this machine because I popped in a PCI NIC and got WOL to work on that NIC, but this integrated adaptor just won't comply.

      Lot's of threads out there saying it can be done, but I can't seem to do it on my hardware.

      Here's a capture from BOOTUTIL showing that WOL is supposed to work...

      ---

      C:\Intel22.4.0.1\APPS\BootUtil\Winx64>BOOTUTILW64E.EXE

      Intel(R) Ethernet Flash Firmware Utility
      BootUtil version 1.6.40.1
      Copyright (C) 2003-2017 Intel Corporation

      Port   Network Address     Location    Series     WOL Flash Firmware                                     Version
      ==== =============== ======== ======= ===  ============================= =======
      1       0024E819DC99        0:25.0       Gigabit    YES  FLASH Not Present

      ---

      One suggestion I found was to update the boot agent (mine is 1.3.81) to the latest (1.5.something) and then throw a flag in the boot agent setup that supports WOL.

      However, I do not think I can update the boot agent as BOOTUTIL says there's no flash firmware present to do so, or correct me if I'm wrong.

      Ideas on how to update the boot agent?

      Aside from that any other ideas?

      ===

      Editing to add infomation

      ===

      Well, I never thought I'd see the day that Linux supported old hardware better than Windows but that day is today.

      Reference this thread: Wake on Lan, Windows 10 Pro, integrated 82567LM-3

      And see what the Fabrice person says.

      The instructions in this referenced thread above were too generic to work verbatim, but they were enough for me to figure my own way to try out WOL under a Linux distro lickety-split.

      In a nutshell this person suggests booting to Linux, turning on WOL, then booting back to Windows, as if that would permanently and magically enable WOL in Windows.

      Well, nice try, that doesn't work because, I assume, Windows initializes the adapter when it gets back in control.

      What DOES work is Linux.  I was able to create a bootable Ubuntu USB stick and in under 5 minutes booted the machine into Ubuntu and tested WOL.  It WORKED. Wow.

      So what we have is a crappy Windows 10 driver that doesn't support WOL, at least not with ANY combination of windows settings I've tried.

      There have got to be 10s of 1000s of OptiPlex 760s (and not to mention other models with this common adapter) out in the wilds of the business world, and Microsoft and/or Intel, with this stunted driver, has basically shat all over the owners with regards to the management of these computers with these adapters.  If I was a IT guy for a company with 1000 of these and couldn't wake any up to do remote management, I'd be pretty damn grumpy.  I'm grumpy now and I only have 10 of these.

      Way to go WinTel.

      So, back to the original problem...anyone have any ideas on how it might be gotten to work?

      Custom Driver?

      Hack current driver?

      New driver not commonly known?

      Some setting I've missed?

      Anything...anything to make this work.