14 Replies Latest reply on Aug 6, 2018 4:16 PM by Tyson.Korhonen

    UEFI and PXE/WDS for 7th Gen NUC Non-functional

    Tyson.Korhonen

      So this was mentioned in another discussion that was marked as answered but looks to have just been abandoned by the original poster (Thread 115121).  I am seeing UEFI PXE boot problems on the 7th gen nucs similar to what was mentioned in that thread.  We have 50+ of each of the following NUC models...D34010WYK, NUC5i3RYK, NUC6i5SYK.  All of them transitioned fairly well from Legacy PXE Boot to UEFI PXE Boot (Some did need BIOS updates but that is to be expected).  However our newest stock of NUC7i5BNK's will not boot to PXE in UEFI (BIOS updated and all).  The options exist in the BIOS options and the device recognizes and serves up the option to network boot.  Selecting the IPv4 boot option event initiates the process and sees the network (Media detected message), but it wont go any further.  I can even flip the device to non-secure boot non-UEFI, and PXE boot the device perfectly fine using Legacy network boot.  I would REALLY prefer to move forward and not build the newest NUCs in legacy mode while all the older model NUCs transition over to UEFI and secure boot.

        • 1. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
          N.Scott.Pearson

          Intel Customer Support will need to follow-up on this, but my understanding is that the BN NUC's have PXE support for only Legacy boot. Why UEFI boot was supported in previous generations but dropped in this latest (BN) generation is a mystery to me.

          ...S

          • 2. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
            Tyson.Korhonen

            Ah, I misunderstood the last thread.  So sometime between UEFI Network Driver: 9.0.1045 (the latest network driver on the 6th gen NUCs) and 9.0.1056 (the oldest network driver I could roll back to on the 7th gen NUCs) for the I219-V network adapter, PXE boot stopped working.  However this isn't a supported feature, so chances aren't good it will be addressed?... that would be a bummer

            • 3. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
              Tyson.Korhonen

              Ah correction, the above are the UEFI Video ROM drivers....

               

              Last network ROM drivers on 6th gen were : LAN Option ROM: 0.1.04

              The 7th gen lists 2 separate items : "Option ROM: v0.1.10 PXE-2.1 (build 092) and UEFI Driver: 0.0.15"

              • 4. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                Intel Corporation
                This message was posted on behalf of Intel Corporation

                Thank you to for the comments posted above.
                 
                : Thank you very much for joining the Intel® NUC communities. We will try our best in order to provide the answer you are looking for.
                 
                In order to confirm the information posted previously, I will do further research on this matter. As soon as I gather all the details I will post the resolution on this thread.
                 
                Any further questions, please let me know.
                 
                Regards,
                Alberto R
                 

                • 5. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                  rguevara

                  Hi Tyson.Korhonen,

                   

                  We have validated the PXE boot functionality successfully connected to the PXE server to load the Operating System

                  The only thing that is really different between Legacy and UEFI, is that Legacy will prompt you to press F12 to accept the network boot, but UEFI will not. You just have to “mash it” to accept the request. Similar to how you would get into the boot menu with F10.

                   

                  See below some images we captured during testing:

                   

                  1.jpg

                  2.jpg

                  3.jpg

                  4.jpg

                  I hope this helps,

                  Ronny G

                  • 6. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                    Tyson.Korhonen

                    Hi Ronny,

                     

                    Thank you for running that test!  Can you confirm the BIOS version you are on?  Is that configuration with DHCP on the same PXE server?  If DHCP isn't on the PXE server, are you using a Helper IP for PXE or DHCP Option settings? 

                     

                    I've see the invisible 'press F12 to accept network boot' after the 'Succeed to download NBP File' on some of our older NUCs as well.  Stumbled onto that solution fairly randomly actually hehe.  On the 7i5BNK's though I can't get even get to the download NBP file screen. 

                     

                    This does make me want to fire up wireshark and investigate the network traffic.  We run DHCP and PXE/WDS on separate servers using Microsoft's supported helper IP configuration on the subnets (2 helpers 1 for DHCP 1 for PXE).  I have another PXE/WDS server that also does DHCP for a little sandbox subnet.  I'll give one of the 7th gens a run on that one and see if the problem maybe falls onto the NUC not correctly interpreting the router's helper IP responses in our production environment.

                    • 7. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                      slb

                      We are experiencing the same issue. We can do legacy pxe boot with NUC 7i3BNH, but uefi pxe boot is not working. We installed the latest bios update, but that doesn't help. Other devices can do uefi pxe boot. There is definitely something wrong with the uefi pxe boot function of this type of NUC's...

                      Did anyone solve this?

                      • 8. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                        Speedfly

                        Hi,

                        We have the exact same problem. Latest BIOS, latest version of WDS running on W 2012 R2 and also 2016...Same problem.
                        Booting Legacy we can see the "Press Enter", Booting UEFI we cannot.

                         

                        Any news?

                        • 9. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                          RobUn

                          This still doesn’t work on my NUC7i5BNK, BIOS version BNKBL357.86A.0057.2017.1122.1550

                           

                          I’ve just wasted an hour or so ’mashing’ the F12 key etc

                           

                          Is there a proper solution for this yet?

                          • 10. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                            Speedfly

                            We have open a case with Microsoft, analyzed the network traces and the problem seems to be a bad interpretation of  the NUC's BIOS.

                            Could it be fixed by Intel with a firmware upgrade?

                            • 11. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                              RobUn

                              Oh it‘s definitely something Intel need to fix, I have other UEFI PXE devices that boot fine. Interestingly if I boot into the UEFI shell on the NUC I can ping (with responses) the distribution point and the DHCP server.

                              • 12. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                                slb

                                We contacted Intel Support months ago, but the support is hopeless. They keep saying they can't replicate the issue, but it seems they just lack the knowledge required for this. They keep asking for information, and when we send them the required information, they ask for other irrelevant information, such as 'are you using VOIP?' 'Do you still get the same issue after updating the LAN driver?'. We gave up on this and now use legacy pxe boot.

                                • 13. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                                  MarcB1

                                  Hi,

                                  I also had problems with UEFI PXE boot, but found that this option in WDS solved all problems, also with our new NUCs (NUC7i5BNK)

                                  Does that help you ?

                                   

                                  Marc

                                  • 14. Re: UEFI and PXE/WDS for 7th Gen NUC Non-functional
                                    Tyson.Korhonen

                                    Good news for anyone watching this thread! 

                                     

                                    So the problem is now resolved.  Short story, the bios revision 066 has uses the UEFI network driver Intel Gigabit 0.0.18.  This can be found in the bios under Advanced > Devices > Add-in Config > Configure (Intel Ethernet Connection NOT ISCSI) > UEFI Driver.  I can say as of 0.0.16 UEFI pxe-boot was not working, at least not across subnets, but on 0.0.18 UEFI pxe-boot will work.

                                     

                                    Long story, I had kinda given up and just flipped to "unsecure" Legacy for these models.  For this year's refresh we purchased the only model I could find with a 8th gen CPU in them... the 7i7DNKE.  Why this NUC is called 7i7 as opposed to a 8i7 I don't know.  It is also supremely disappointing this model ditched thunderbolt 3, but I digress.  After initially attempting to UEFI boot this model and failing I assumed the same problem existed.  However, with a recently upgraded WDS server to 2016, I made another go of it.  To my surprise the 7i7DNKE UEFI pxe-booted.  I am unsure if this is because of the updated WDS host, or if I grabbed a 7i7DNKE with a newer BIOS than my original test a few months back.  Either way it booted.  I tried the 7i5BNK but was still unsuccessful.  I checked the UEFI network driver on the 7i7DNKE and discovered it was 0.0.18.  After reviewing the 066 bios release notes history for the 7i5BNK I didn't have much hope the UEFI network driver would be updated as the notes have the exact same Option ROM for the network (LAN Option ROM: PXE 2.1 Build 092).  However I gave it a go anyway.  A wouldn't you know it, it did bump the UEFI network driver to 0.0.18!  I flipped the 7i5BNK over to UEFI and Secure Boot and blamo WDS loaded up!

                                     

                                    Hope this helps anyone still poking around