5 Replies Latest reply on Sep 21, 2018 12:54 PM by Intel Corporation

    Skype for Business Plugin problems

    rhyderstorm

      Hi @all,

       

      i installed a Enterprise Server of Intel Unite with the newest version 3.1.45.26.

      On the hub is the latest Skype Plugin 2.1.10.1 installed.

      We use Office 365 Premium for mailing and Office 2016 is installed out of the O365 account.

       

      My meeting room has a own mailbox configured as ressource in O365. Skype is running and configured as described in the documentation.

      Now I plan a Skype meeting with the room. The meeting will be accepted from O365 as configured in the mailbox.

      My expectation now is that 10 minutes before the meeting will shown up on the hub and I can join the meeting with my client.

       

      But the following happens:

      - The meeting is not shown on the hub

      - If i connect to my Hub with the Client and click to the "Skype-Button" I get: "no meeting available"

      - The Hub Debug Log shows me somthing strange:

      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Appointment States~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Checking OnlineAppointmentAvailable...

        No online appointments found...

      Setting next S4B event timer...

      Number of appointments: 0

      Next Check:

        60000

        11.08.2017 08:23:50

      Created Event received

        Appointment State: 3

        ResponseType:  Accept

        IsResend: False

        IsNew: False

      ...Meeting already accepted, skip

      Modified Event received

        Appointment State: 3

        IsUnmodified: False

        LastModifiedName: C-3PO (Test)

        LastModifiedTime: 11.08.2017 08:23:16

        IsDirty: False

        IsDraft: False

      Couldn't Parse the switch statements: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.

      Skipping  - item is not ItemEvent

      Checking OnlineAppointmentAvailable...

      GetS4BURL Called...

        GetS4bURL:  Appointment.Body.Text is empty

        GetS4BURL Exception: The property JoinOnlineMeetingUrl is valid only for Exchange Exchange2013 or later versions.

        No online appointments found...

      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Appointment States~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Appintment state: 3

      Modified Event received

        Appointment State: 3

        IsUnmodified: False

        LastModifiedName: C-3PO (Test)

        LastModifiedTime: 11.08.2017 08:23:16

        IsDirty: False

        IsDraft: False

      Couldn't Parse the switch statements: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.

      Skipping  - item is not ItemEvent

      Checking OnlineAppointmentAvailable...

      GetS4BURL Called...

        GetS4bURL:  Appointment.Body.Text is empty

        GetS4BURL Exception: The property JoinOnlineMeetingUrl is valid only for Exchange Exchange2013 or later versions.

        No online appointments found...

      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Appointment States~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Appintment state: 3

      Modified Event received

        Appointment State: 3

        IsUnmodified: False

        LastModifiedName: C-3PO (Test)

        LastModifiedTime: 11.08.2017 08:23:16

        IsDirty: False

        IsDraft: False

      Couldn't Parse the switch statements: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.

      Skipping  - item is not ItemEvent

      Checking OnlineAppointmentAvailable...

      GetS4BURL Called...

        GetS4bURL:  Appointment.Body.Text is empty

        GetS4BURL Exception: The property JoinOnlineMeetingUrl is valid only for Exchange Exchange2013 or later versions.

        No online appointments found...

      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Appointment States~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Appintment state: 3

      S4B NextEventTimer Elapsed...

      Checking OnlineAppointmentAvailable...

      GetS4BURL Called...

        GetS4bURL:  Appointment.Body.Text is empty

        GetS4BURL Exception: The property JoinOnlineMeetingUrl is valid only for Exchange Exchange2013 or later versions.

        No online appointments found...

      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Appointment States~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Appintment state: 3

      Checking OnlineAppointmentAvailable...

      GetS4BURL Called...

        GetS4bURL:  Appointment.Body.Text is empty

        GetS4BURL Exception: The property JoinOnlineMeetingUrl is valid only for Exchange Exchange2013 or later versions.

        No online appointments found...

      Setting next S4B event timer...

      Number of appointments: 1

        Using default interval because next scheduled event is further out

        Next Check:

          60000

          11.08.2017 08:24:51

      S4B NextEventTimer Elapsed...

      Checking OnlineAppointmentAvailable...

      GetS4BURL Called...

        GetS4bURL:  Appointment.Body.Text is empty

        GetS4BURL Exception: The property JoinOnlineMeetingUrl is valid only for Exchange Exchange2013 or later versions.

        No online appointments found...

       

       

      Can you please tell me, what goes wrong or what I make wrong?

       

      Thanks in advance.

      Cheers, Markus

        • 1. Re: Skype for Business Plugin problems
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello rhyderstorm,

           

          I am sorry to hear you are having issues with the plugin.

           

          Please let me review this matter, I will update the thread as soon as possible.

           

          Regards,

          Amy C.

          • 2. Re: Skype for Business Plugin problems
            rhyderstorm

            One additional hint i saw in the logfile:

            [16.08.2017 14:20:27] Plugin Manager - LoadPlugins method done

            [16.08.2017 14:20:27] Plugin Load Complete

            [16.08.2017 14:20:27] Plugin Manager: Calling LoadEvent for all plugins

            [16.08.2017 14:20:27] S4B setting setNoAssertKey to False

            [16.08.2017 14:20:27] S4B setting WebRTCClientsStartMuted to False

            [16.08.2017 14:20:27] System culture: de-DE

            Error connecting to exchange: The collection is empty.

            Parametername: items

            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Appointment States~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

            [16.08.2017 14:20:29] S4B Plugin was unable to connect to exchange.  Please check credentials.

            [16.08.2017 14:20:29] Setting Exchange URL Search Keywords to: System.String[]

            [16.08.2017 14:20:29] Injector dll missing, skipping

             

            Why can't the plugin not connect to exchange? The plugin installation with the EWS "https://outlook.office365.com/EWS/Exchange.asmx" finished successfully...

            • 3. Re: Skype for Business Plugin problems
              VW-IT-Bryan

              rhyderstorm I was wondering if you ever found a fix for this issue, as I am experiencing something very similar.

              I am getting (at the beginning) the same:

               

              Error connecting to exchange: The collection is empty.

              Parameter name: items

              ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Appointment States~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

              [16.08.2017 14:20:29] S4B Plugin was unable to connect to exchange.  Please check credentials.

               

              I am also getting:

               

              Appintment state: 3

              Appintment state: 3

              Appintment state: 3

              Appintment state: 1

              Appintment state: 3

              [12/11/2017 2:20:43 PM] S4B Plugin was unable to connect to exchange.  Please check credentials.

              [12/11/2017 2:20:43 PM] Setting Exchange URL Search Keywords to: System.String[]

              [12/11/2017 2:20:44 PM] Injector dll missing, skipping

              [12/11/2017 2:20:44 PM] Plugin Manager: LoadEvent Complete

              [12/11/2017 2:20:44 PM] Slow Init - Plugin init complete

              [12/11/2017 2:20:44 PM] Certificate Creation Started

              Checking OnlineAppointmentAvailable...

              GetS4BURL Called...

                GetS4bURL:  Appointment.Body.Text is empty

                GetS4BURL Exception: The property JoinOnlineMeetingUrl is valid only for Exchange Exchange2013 or later versions.

                No online appointments found...

              Lync Version: 16.0

               

              I know that I am currently using an account that is set up with Exchange 2010, and I'm wondering if that could be the issue (even though the official documentation lists Exchange 2010 as being the minimum).

              • 4. Re: Skype for Business Plugin problems
                YRMC_GUY

                anyone figure this out? I am having this issue.

                • 5. Re: Skype for Business Plugin problems
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Hello, YRMC_GUY. Thank you for joining this thread.

                  I have sent you a private message to discuss more information about your case. Please check your inbox.


                  Antony S.
                  Intel Customer Support Technician
                  Under Contract to Intel Corporation