1 2 Previous Next 19 Replies Latest reply on Sep 15, 2017 11:07 AM by Intel Corporation

    No HDMI audio on Intel HD 4600

    d.mcii

      Hello,

       

      Currently I have an ASUS laptop running Windows 10 Education Insider Preview and Intel HD Graphics 4600. I have noticed that after one of the Windows updates, Intel Display Audio does not work when I have HDMI.

       

      I have recently uninstalled all available drivers and installed the recent driver:

       

      Driver Provider: Intel Provider

      Driver Date: 6/9/2017

      Driver Version: 20.19.15.4703

      Digital Signer: Microsoft Windows Hardware Compatibility Publisher

       

      I have also verified that I have selected the TV as the default audio device:

      Capture.PNG

      However there is still no sound. Hyper-V is enabled on this laptop, I was wondering if that could potentially be an issue.

       

      Thank you,

        • 1. Re: No HDMI audio on Intel HD 4600
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello d.mcii,

           

          I am sorry to hear you are having issues with the HDMI audio.

           

          It seems like is related to the Windows Update your system ran, unless you changed Hyper-V configuration prior to the update. Let's gather your computer model information in order to try to address this matter with other drivers, also; do you remember the previous Intel® HD Graphics driver version installed?

           

          Regards,

          Amy C.

          • 2. Re: No HDMI audio on Intel HD 4600
            d.mcii

            I don't remember the previous driver version as the issue started a while ago and I have been trying to fix it for a while. However, I think it may have happened after upgrading from Windows Home to Windows Education Insider.

            • 3. Re: No HDMI audio on Intel HD 4600
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              d.mcii, thanks for this information.

               

              Could you please provide your computer model?

               

              Regards,

              Amy C.

              • 4. Re: No HDMI audio on Intel HD 4600
                d.mcii

                I have attached a screenshot of my computer specs below and an Intel SSU generated log to this message:

                Capture2.PNG

                • 5. Re: No HDMI audio on Intel HD 4600
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Thank you for the detailed information.

                   

                  Please let's updating the following driver;

                   

                  Installation steps:

                  1. Open Cortana
                  2. Enter cmd in there to open up the command prompt
                  3. Enter cd desktop (For this step the work, after you unzip the files, please save the chipset.exe on the desktop)
                  4. After that enter: setupchipset.exe -overall

                   

                  I provided the chipset driver from our end because I was not able to find it from ROG G56JK | ROG - Republic Of Gamers | ASUS Global, it seems like the driver support is not the same as for Windows 8.1. 

                   

                  One more thing, is there any chance to test a different cable and different TV or monitor? 

                   

                  Regards,

                  Amy C.

                  • 6. Re: No HDMI audio on Intel HD 4600
                    d.mcii

                    I currently don't have another TV nor cable, however I did try it in the past with other TVs and cables and the same issue occured. I just tried attaching another laptop with the same TV and cable and there was sound available so both the wire and the TV are good.

                     

                    Regarding the posted fix, where is the BIOS 202 file used? I just have it unzipped onto the Desktop with the setupchipset.exe.

                     

                    I did the following, with both setupchipset.exe and G56JKAS.202 on my desktop. I then ran the command from cmd prompt and followed through with the installation and restarted, however the problem is still there.

                     

                    capture3.PNG

                    • 7. Re: No HDMI audio on Intel HD 4600
                      Intel Corporation
                      This message was posted on behalf of Intel Corporation

                      For the BIOS update you will have to run it, these steps could help: Update BIOS - How to use Easy Flash to update the Notebook BIOS version? | Official Support | ASUS Global 

                       

                      Please try the following:

                      • Check the audio output settings on your TV. On some Panasonic TVs, you may need to change the speaker output from TV to Digital.
                      • Verify that Intel® Display Audio Drivers is installed. Go to Device Manger then under Sound, Video and Game Controllers, look for Intel® Display Audio.

                       

                      Regards,

                      Amy C.

                      • 8. Re: No HDMI audio on Intel HD 4600
                        d.mcii

                        I have confirmed that the settings on the TV are correct.

                         

                        I have also verified that the Intel Display Audio driver is installed, however there is still no sound even though the TV shows there should be sound.

                         

                        Capture4.PNG

                         

                        I will update once I update the BIOS.

                        • 9. Re: No HDMI audio on Intel HD 4600
                          d.mcii

                          I updated the BIOS, however it did not fix the problem and there is no sound through hdmi.

                          • 10. Re: No HDMI audio on Intel HD 4600
                            Intel Corporation
                            This message was posted on behalf of Intel Corporation

                            My apologies for the inconvenience.

                             

                            I would like to know if you have the chance to test a different Windows® 10 version.

                             

                            Regards,

                            Amy C. 

                            • 11. Re: No HDMI audio on Intel HD 4600
                              d.mcii

                              Unfortunately at this moment I can't change Windows versions. However I have stopped Insider Preview and at the next Windows update, I will be able to test with normal Windows Education.

                              • 12. Re: No HDMI audio on Intel HD 4600
                                Intel Corporation
                                This message was posted on behalf of Intel Corporation

                                d.mcii, if that is possible for you please go ahead and share your results. From the steps taken so far this could be related to the operating system, as you can see we have tried several things in order to address this matter, but the issue is still there. I am thinking that next step after testing a different Windows® 10 version is to get in contact with the computer manufacturer, but let's wait for the results with Windows® 10 Education version.

                                 

                                Regards,

                                Amy C.

                                • 13. Re: No HDMI audio on Intel HD 4600
                                  Intel Corporation
                                  This message was posted on behalf of Intel Corporation

                                  d.mcii, hope you were able to test Windows® 10 Education.

                                   

                                  Regards,

                                  Amy C.

                                  • 14. Re: No HDMI audio on Intel HD 4600
                                    d.mcii

                                    Hi Amy,

                                     

                                    Sorry for the delay. Rolling back to Windows Education led to a large issue in the process where the Windows File System was corrupted.

                                     

                                    I was finally able to recently able to reinstall Windows Education and update to the current Intel driver. This fixed the audio working on HDMI. However this led to another issue with a blue tint in the display which hurts eyes with long term use. This is the same tint that appears when the Intel display adapter is disabled and the Microsoft Basic Display Adapter Driver is in use.

                                     

                                    The tint is apparent in the attached image below. One shows the display on the TV and the other on the laptop. In the laptop one, the tint is blue-ish since the driver is not working correctly. When the display is working correctly, usually both the TV and the laptop monitor have the same shade. However currently the laptop display driver for the laptop display is not working. It is not a setting issue with the TV or laptop monitor as this has appeared in the past when the driver was not working properly for the display.

                                     

                                    IMG_20170909_205649.jpg

                                     

                                    EDIT*

                                    After examining the log saved from dxdiag, i see the following errors under the windows error reporting section:

                                    1.PNG

                                    2.PNG

                                    Could this be potentially related to the driver not installing correctly?

                                     

                                    EDIT* To clarify even further, this is not an issue that can be corrected via color profile. I have gone into the Intel Graphics Control Panel -> Color ->Color Enhancement menu and adjusted the Hue and Saturation but the effects were still different than what the color should look like.

                                     

                                    I did go into safe mode and uninstall all drivers and reinstall the Intel drivers multiple times. On one instance the color came back to normal, however after I restarted, the color went back and I have not been able to achieve the same result since then.

                                    1 2 Previous Next