7 Replies Latest reply on Aug 16, 2017 5:37 PM by Intel Corporation

    Intel HD Graphics installs fine but won't switch to driver

    Darinth

      I have two Optiplex 3010 machines with identical configurations. Both were recently replaced and re-imaged to be redeployed elsewhere in the organization. One machine worked flawlessly. Everything worked exactly as I would've expected. The other... has given be immense issue trying to get it to use the correct video driver for multiple days now.

       

      Windows properly images using DISM. Everything comes up. I install the drivers off of the dell website as usual, windows indicates all of the driver installations have been successful. Except, when I check in device manager the Intel HD Graphics 4000 display adapter is still using the default "Standard VGA Graphics Adapter" drivers. So I tell it to update it's driver, I look at the list of drivers on the computer and the intel HD graphics driver that I installed is there. I tell it to use that driver. Windows goes through it's process saying "Installing driver Software" and then says it successfully updated my driver software and lists the Intel(R) HD Graphics 4000... but when I click close device manager and the property window still shows "Standard VGA Graphics Adapter" and the driver still shows as "vgapnp.sys", not the intel driver.

       

      I've also tried...

      Unzipping and installing the drivers from the dell site manually (by unzipping them to a folder, going through the driver update process, selecting have disk, browsing to the directory and selecting the driver there)

      Letting windows update install the drivers it has

      Downloading the drivers off of the intel website with the .exe installer and installing them.

      Downloading the drivers off of the intel website with the zip file, unzipping them and installing them manually as above.

      I've looked at all of the BIOS settings I can find to see if there's anything related to it.

      I've tried installing drivers in different orders.

      I've wiped the CMOS memory.

      I've completely uninstalled the VGA adapter from the computer.

           When I do so and reboot, it comes back up as "Video Controller (VGA Compatible)". Windows does it's driver software installation and ultimately tells that the driver installation failed. If I look in control panel I can find the "Video Controller (VGA Compatible)" and update it's driver. If I try to install the Intel HD Graphics 4000 driver, it comes back with a code 1 which is the microsoft error code that means there's no driver installed. If I tell it to install the "Standard VGA Graphics Adapter" as the driver, it works perfectly and updates the driver to the standard VGA graphics adapter but once again, I still can't update the driver from there to the Intel HD Graphics.

       

      I'm now on my 4th reimaging of the machine trying different things.

       

      I can't even find someone online who's having the same issue. Lots of other similar issues where the drivers won't install or people don't understand how to force windows to install the very specific driver that they need... but every single source that I use for the intel drivers installs successfully. The driver appears in the store. Windows (with the single exception of completely uninstalling the device and letting windows pick it back up at reboot) always tells me that the install was successful and that it's going to use the new driver... but never actually does so. Eventviewer shows the installation of the new driver every time I do so without an error in the log.