3 Replies Latest reply on Aug 11, 2017 4:15 PM by pnikke

    Error 0x80070643 from SetupChipset.exe on a fresh Win 7 installation

    pnikke

      I have a Asus desktop running Win 7 that has become curiously slow over the past year or so. I suspect that it has to do with Microsoft updates somewhere down the line, and that the slowness is HDD-related.

       

      Having tried all the usual tricks including full system reinstall and disk repartitioning, I wanted to try and update the chipset drivers, but Asus has no updates to offer. So I tried the generic Chipset_10.1.1.42_Public downloadable instead. The installer runs fine but proceeds to fail with an "Unknown error". I get a bunch of logs but haven't been able to decipher them.

       

      I will enclose a few files for more background information. First, the logs themselves are enclosed in a zip file. Next, I downloaded and run the Intel SSU utility, the output of which enclosed as well. Also, Intel ChipUtil.exe prints the following output:

       

      Chipset

      Detected Chipset:

      Mobile Intel® PM45 Express Chipset

      Chipset Components

      Memory Controller:

      Mobile Intel® 82PM45 Memory Controller Hub (MCH)

      I/O Controller:

      Intel(R) 82801IMB Intel(R) I/O Controller Hub (ICH9M-B) SATA Controller found in IDE mode

      Integrated Graphics:

      This chipset does not contain integrated graphics.

       

      As noted, this is a fresh re-install of Windows 7 (Home Premium edition, 32-bit) from the Asus recovery DVD, as I got tired of trying to fix the old installation and instead opted to start again from scratch. However, this hasn't cured the lethargic slowness, and I am still struggling at snail pace. Please help if you can in any way.

        • 1. Re: Error 0x80070643 from SetupChipset.exe on a fresh Win 7 installation
          pnikke

          And yes, the HDD controlled is running in IDE mode. But it's been set up like that from day 1, and the system used to run noticeably faster. Unfortunately, I have been told that the Asus system has a "castrated" version of ICH9M that apparently doesn't support AHCI. Obviously, system BIOS setup doesn't offer an AHCI option, either.

           

          But AHCI or not, surely I should be able to run SetupChipset.exe and install the latest drivers without errors, regardless. But this is not happening. Why?

          • 2. Re: Error 0x80070643 from SetupChipset.exe on a fresh Win 7 installation
            Intel Corporation
            This message was posted on behalf of Intel Corporation

            Hello pnikke,
             
            Thank you for contacting the Intel community.
             
            Please bear in mind that OEM (Original Equipment Manufacturer) system that you have your best contact support is ASUS as they are more familiar with your system and how all the components interact with each other, I understand that this desktop have Intel components but your system manufacturer has better information and support related to the whole system configuration and you can get better support tips from ASUS.
             
             
            Best regards,
             
             
            Ivan U.
             

            • 3. Re: Error 0x80070643 from SetupChipset.exe on a fresh Win 7 installation
              pnikke

              Well, no. Your answer is neither helpful nor correct. As I explained earlier, Asus are no longer offering meaningful support for this system, haven't done so for some time already. And, what I executed and got the error for was not sn Asus file but an Intel installer. Which I executed after another Intel chipset identifier tool suggested that there is in fact a discoverable intel chipset to be found in my system. Obviously, the insight for Intel installers and tools, and any error codes that they may produce, should first come from Intel, who are the best experts on the installer.

               

              I understand full well how the relationship between Intel and OEMs work. I don't benefit from misleading statements or evasive fingerpointing. What I was hoping for was that somebody who understands the SetupChipset.exe 10.1.1.42 installer (either from developing it first hand, or having extensive experience from using it) would be around to explain the error codes that I encountered. As the installer failed without any descriptive prompts or explanations, I figured that my experience could even benefit Intel in making the installer UX more user-friendly.

               

              That was why I went through the trouble of collecting and uploading all the enclosed files, and explaining my predicament at length. If you can't be bothered to readthem through to help, or if you just don't understand them and don't have anything constructive to offer, please don't respond. Just move on to the next question, and leave this one to others who hopefully may drop by.