0 Replies Latest reply on Aug 3, 2017 12:37 AM by McCool

    Euclid and Movidius Neural Compute Stick

    McCool

      Just a quick note to let people know that I have confirmed that it is possible to use the Euclid with the Movidius SDK and the Movidius Neural Compute Stick but there is a slight hitch during installation of the Movidius SDK you have to work around. Basically, the Movidius SDK tries to install OpenCV but the Euclid already has an OpenCV installation under a strange package name, euclid-opencv.   The first time I ran the Movidius installer it not only didn't work, it left behind a bunch of broken packages.

       

      To get my install to work I first had to remove euclid-opencv:

       

      sudo apt-get remove euclid-opencv

       

      If you have to (eg if you tried the Movidius install and it failed) also remove all broken packages using a single command (it doesn't work if you try to remove them separately). Once you have cleared the way, proceed with the Movidius setup (which reinstalls OpenCV).   After the Movidius install all the Euclid scenarios still seem to work, so it seems no harm done...

       

      The other issue is that it does not seem possible to use the NCS with an unpowered USB 3.0 hub with the Euclid.   I've tried two and in both cases the NCS is not recognized.   I don't *think* this is a power problem, since the NCS is only supposed to use 1W, but maybe there is a peak (as opposed to average) power issue... at any rate, if your NCS does not work, try a powered hub.