1 Reply Latest reply on Aug 1, 2017 8:20 AM by fred02476

    How do I enable rx-fcs and rx-all for Intel X710 10-Gigabit SFI/SFP+ Network Card using i40evf v1.4.15?

    fred02476

      I have tried "ethtool -K <devicename> rx-fcs on"  but it does not work and shows this feature as "fixed."  Is there a way to enable this feature using a different method?

       

      Note: "Failed to get lock in i40evf_set_rx_mode" in dmesg output below:

       

      dev@ccapdp:/vob_yukon/farid/share$ dmesg |egrep evf

      [    1.569952] i40evf: module verification failed: signature and/or required key missing - tainting kernel

      [    1.680148] i40evf: Intel(R) 40-10 Gigabit Virtual Function Network Driver - version 1.4.15

      [    1.750595] i40evf 0000:00:08.0: Multiqueue Enabled: Queue pair count = 4

      [    1.751048] i40evf 0000:00:08.0: MAC address: 52:54:00:1b:ad:0c

      [    1.751049] i40evf 0000:00:08.0: GRO is enabled

      [    1.758741] i40evf 0000:00:0a.0: Multiqueue Enabled: Queue pair count = 4

      [    1.759209] i40evf 0000:00:0a.0: MAC address: 52:54:00:b2:ec:90

      [    1.759211] i40evf 0000:00:0a.0: GRO is enabled

      [    1.759655] i40evf 0000:00:0b.0: Multiqueue Enabled: Queue pair count = 4

      [    1.760098] i40evf 0000:00:0b.0: MAC address: 52:54:00:a5:5a:9f

      [    1.760099] i40evf 0000:00:0b.0: GRO is enabled

      [    1.760501] i40evf 0000:00:09.0: Multiqueue Enabled: Queue pair count = 4

      [    1.761010] i40evf 0000:00:09.0: MAC address: 52:54:00:11:b6:d4

      [    1.761011] i40evf 0000:00:09.0: GRO is enabled

      [    1.762715] i40evf 0000:00:0f.0: Multiqueue Enabled: Queue pair count = 4

      [    1.763193] i40evf 0000:00:0f.0: MAC address: 52:54:00:37:64:16

      [    1.763194] i40evf 0000:00:0f.0: GRO is enabled

      [    3.890945] i40evf 0000:00:09.0: Failed to get lock in i40evf_set_rx_mode

      [    3.891501] i40evf 0000:00:09.0: Failed to get lock in i40evf_set_rx_mode

      [    3.891738] i40evf 0000:00:09.0: Failed to get lock in i40evf_set_rx_mode

      [    3.924301] i40evf 0000:00:08.0: Failed to get lock in i40evf_set_rx_mode

      [    3.925066] i40evf 0000:00:08.0: Failed to get lock in i40evf_set_rx_mode

      [    3.925255] i40evf 0000:00:08.0: Failed to get lock in i40evf_set_rx_mode

      [    3.930514] i40evf 0000:00:0a.0: Failed to get lock in i40evf_set_rx_mode

      [    3.931277] i40evf 0000:00:0a.0: Failed to get lock in i40evf_set_rx_mode

      [    3.931493] i40evf 0000:00:0a.0: Failed to get lock in i40evf_set_rx_mode

      [    3.937261] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [    3.937947] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [    3.938125] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [    3.971121] i40evf 0000:00:0a.0: Failed to get lock in i40evf_set_rx_mode

      [    3.972654] i40evf 0000:00:0b.0: Failed to get lock in i40evf_set_rx_mode

      [    3.973811] i40evf 0000:00:0a.0: Failed to get lock in i40evf_set_rx_mode

      [    3.974587] i40evf 0000:00:0b.0: Failed to get lock in i40evf_set_rx_mode

      [    3.975528] i40evf 0000:00:08.0: Failed to get lock in i40evf_set_rx_mode

      [    3.977633] i40evf 0000:00:08.0: Failed to get lock in i40evf_set_rx_mode

      [    3.980099] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [    3.982872] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [  587.017753] i40evf 0000:00:0f.0: Device is still in reset (-16), retrying

      [  587.049125] i40evf 0000:00:0b.0: Device is still in reset (-16), retrying

      [  587.081267] i40evf 0000:00:08.0: Device is still in reset (-16), retrying

      [  587.113735] i40evf 0000:00:09.0: Device is still in reset (-16), retrying

      [  588.079143] i40evf 0000:00:0f.0: Multiqueue Enabled: Queue pair count = 4

      [  588.079779] i40evf 0000:00:0f.0: MAC address: 52:54:00:37:64:16

      [  588.079783] i40evf 0000:00:0f.0: GRO is enabled

      [  588.110108] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [  588.111238] i40evf 0000:00:0b.0: Multiqueue Enabled: Queue pair count = 4

      [  588.112924] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [  588.114463] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [  588.116152] i40evf 0000:00:0b.0: MAC address: 52:54:00:a5:5a:9f

      [  588.116161] i40evf 0000:00:0b.0: GRO is enabled

      [  588.147038] i40evf 0000:00:08.0: Multiqueue Enabled: Queue pair count = 4

      [  588.147553] i40evf 0000:00:08.0: MAC address: 52:54:00:1b:ad:0c

      [  588.147557] i40evf 0000:00:08.0: GRO is enabled

      [  588.258219] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [  588.261729] i40evf 0000:00:0f.0: Failed to get lock in i40evf_set_rx_mode

      [  589.175108] i40evf 0000:00:09.0: Multiqueue Enabled: Queue pair count = 4

      [  589.175644] i40evf 0000:00:09.0: MAC address: 52:54:00:11:b6:d4

      [  589.175648] i40evf 0000:00:09.0: GRO is enabled

        • 1. Re: How do I enable rx-fcs and rx-all for Intel X710 10-Gigabit SFI/SFP+ Network Card using i40evf v1.4.15?
          fred02476

          The above dmesg command was issued on a VM with SR-IOV.  I can understand you may not be able to configure certain NIC attributes on the VF, but shouldn't you be able to do that on the host on the physical port.  It still won't allow me to set the "rx-fcs" attribute.  I am trying to disable the NIC from stripping the Ethernet CRC field.  Here's the output from the host:

           

          dev@dcsu:/etc/network$ sudo ethtool -i em1

          driver: i40e

          version: 1.4.25-k

          firmware-version: 5.04 0x800024bc 17.5.11

          bus-info: 0000:01:00.0

          supports-statistics: yes

          supports-test: yes

          supports-eeprom-access: yes

          supports-register-dump: yes

          supports-priv-flags: yes

           

          dev@dcsu:/etc/network$ sudo ethtool -k em1

          Features for em1:

          ...

          loopback: off [fixed]

          rx-fcs: off [fixed]

          rx-all: off [fixed]

          tx-vlan-stag-hw-insert: off [fixed]

          rx-vlan-stag-hw-parse: off [fixed]

          rx-vlan-stag-filter: off [fixed]

          l2-fwd-offload: off [fixed]

          busy-poll: off [fixed]

          hw-tc-offload: off [fixed]