4 Replies Latest reply on Mar 12, 2010 7:54 PM by msedek

    DX58SO mobo won´t boot

    msedek

      Hello, well I am from Venezuela, South America, 3 months ago I bought a Intel DX58SO mobo with the intel I7-920 processor, also bought 6GB of corsair memory 1333 Mgz and the NVIDEA 9800 GTX 1GB video card, all was working fine but the mobo was not able to work with the memory at 1333 Mhz just 1024 Mhz, my boss also bouth the same computer, and when ever I tried to set the memory multiplier to 10 I had to reset the bios again.. ok i decided to work that way, I mean with the 1024 Mghz.

       

      Today I was looking for  a new BIOS update and downloaded the last version to a pendrive the .BIO one so I tried to upgrade the bios on my boss´s machine with the F7 option from bios and all was OK, i could finally set the memory to 1333 Mghz and all was good.. restarted, loaded windows and no problems..

       

      Once I got home, I wanted to do the same to my computer but I forgot the USB STICK at work, so i just downloaded the .EXE version of the BIOS upgrade, executed it no interuptions, at the the end it resarted but it does not show any video signal no boot no beeps, not response to keyboard or anything.. well  I removed everything but the memory and the video card and nothing happens, if I remove the memory I got the 3 Beeps, I tried to recover via CD (previously removed the bios jumper) with the .BIO and nothing happens, same with a USB STICK, It does not read the CD or the USB Stick, I tried also to start with the jumper in the bios special mode and nothing the cumputer is just on with all the fans working but no video signal, and it does not recognice any media no cd no usb sticks in any of the 3 bios jumper modes, tried everything with cd and usb stick and the .BIO file in the 3 jumper positions (normal position, special position, and with no jumper), also tried with the .iso file and nothing I can not get video signal or any kind of response, also tried changin the video card and nothing.... what could be the solition...

       

      Any help will be apreciated..

       

      Thank you in advance.

       

       

      P.D: My boss and I, bought the computer in the same store, the same day and all the specifications are the same, is the same computer, same video cards, same memories, same prossesor, same case, same powersupply, are exactly the same machine both working with windows 7 ultimate edition, the only difference is that I flashed my boss bios with the F7 option with a usb stick and mine with the Windows.exe... but the same BIOS version..

      Miguel

        • 1. Re: DX58SO mobo won´t boot
          mark19

          Miguel,

          I am also experiencing issues with this board since I got it, my quick solution is to try turning it off at plug for around 10-15 mins, and let me know if it works, if so it is same as mine and I am convinced there is a major problem with these boards/processor. I also got a I7 920.

          • 2. Re: DX58SO mobo won´t boot
            msedek

            I did unplug the power cord and removed the battery for about 2 hours and nothing.. I also googled a lot and seems like many people is getting similar problems and no one solved or at least not that I know.. this forum is my very last shot in try to solve the issue.. thanks for the reply but that is not working

            • 3. Re: DX58SO mobo won´t boot
              mark19

              Miguel,

              Did you experience artefacts at all? For example on my board it will either do absolutely nothing on screen like yours or it will do a windows startup screen with lots of artefacts before screen going blank. It is extremely frustrating, I spent a lot of money attempting to fix issues by replacing power supplies, graphics card etc. Looks like we may need to send our boards back.

               

              Thanks

              • 4. Re: DX58SO mobo won´t boot
                msedek

                No artefacts for me.. mine its just dead... it only spins the fans and nothing else.. , I dont want to know anything else about this piece of crap(dx58so mobo).. intel recognice that its a crap board because they already discontinued it.. I got upset because I got an Acer Mini One netbook, and it has some bios issues, sometimes it will just spins the fans and nothing else (just like the DX58SO) """BUT""" if you put a usb stick with the factory bios version and press FN+ESC keys put the usb stick into the usb port then press the powerswitch.. TADAAAAAAAAAAA!!!!! it will ONLY read the usb stick looking for the BIOS file to reflash it and THATS IT.. no neeed VIDEO or any other **** like JUMPERS or anything... I WONDER WHY INTEL does not implement SO SIMPLE SOLUTION ???????????????? PFFFT and they are "THE TOP OF THE HOME COMPUTERS TECHNOLOGIES!!!"... ASUS FTW!!!...

                 

                Thanks for the response guys.. my mobo is in the way back to the store (already asked for another brand ASUS for example but NO Intel)!!... BYE FOR EVER INTEL MOBOS..!!