5 Replies Latest reply on Aug 2, 2017 6:52 AM by KFindlater

    Depth not working on SR300, Windows 10 builds 14393 and still on Creator update 15063

    KFindlater

      Hello,

       

      I am trying to use the SR300 for a time-sensitive engineering project. I have had lots of fun and good results with the R200 last year. This year, with all the various 'improvements' in the Realsense SDK and Windows 10 I am trying to use the SR300 (also, a brand new fancy laptop).

       

      Unfortunately for me, I've spent almost 2 full days trying to get the SR300 to work. I have had these issues on pre-Creator update (build 14393) and after the Creator update (build 15063), because i thought Microsoft and Intel would have their crap together by now in those builds.. Currently, if I use the Realsense SDK sample browser, and try things like the Raw Streams (C++) I can only make it do anything if i have ONLY the RGB modes active - as soon as I try to use Depth modes, I get the windows sound when USB devices are unplugged/plugged back in, and the camera looks like it tries to start, but quickly stops.  I cannot get any depth based example programs to run. So I dig into the code and try to debug error messages with Visual Studio 2015 and the sample solutions/projects...

       

       

      While running the SDK source code in VS2015 for "DF_CameraViewer" which is a C++ example, the camera system successfully starts, inits and then when attempting to run the depth stream I get the following error when the line:

      sts=pp->AcquireFrame(false); 
      

      is called

       

      sts = error code -301, which is "PXC_STATUS_EXEC_ABORTED".

       

      I also ran the librealsense examples for C++ tutorial 1, which is the 'depth' example program, and this throws an error and exits complaining that it found the SR300, but when it is asked to produce a stream with depth 640x480 with pixel type Z16, and FPS 30, it cannot produce that required pixel type for whatever reason.

       

      Just to clarify, I do indeed have the Intel Realsense RBG, Depth, and Virtual Camera drivers showing up in my device manager. None of the workarounds i've seen on this forum appear to be relevant. Since upgrading to the Creator build of windows, my RGB camera viewer has gotten worse - the thing appears to be grabbing frames but they are not shown anymore in the preview window of the little test programs - whereas it used to at least show the image before.

       

      Help!

       

      stupid_realsense.PNG

        • 1. Re: Depth not working on SR300, Windows 10 builds 14393 and still on Creator update 15063
          MartyG

          RealSense cameras started malfunctioning in Windows builds shortly before 14393, and for a while afterwards until around 15019.  There was a period I believe when they worked again, and then they broke again when Microsoft released the Creators Update (15063).

           

          When the camera is not fully functioning, it is treated by Windows as an ordinary RGB webcam, which is why you can use color functions for applications such as Skype video but not depth and IR functions.  Intel and Microsoft have been working together on a fix for the problem.  Its release status currently remains as "pending" though.

           

          To sum up, your Device Manage drivers are fine and you have tried workarounds on this forum (including the Intel-recommended one by Slothameedes, I assume), and the camera is still not functioning.

           

          If waiting for the Intel-Microsoft fix is not an option and workarounds are not working for you, the final options available may be:

           

          (a) try using the SR300 on a different PC if you have one available, since not all RealSense SR300 users are affected.

           

          (b) if disconnections seem to be at the heart of your issue, purchase a mains-powered USB hub for around $15 and plug the camera into that instead of directly into the PC.  Powered hubs have a very high success rate of instantly curing RealSense problems related to camera detection and connection drops.  You can find them on a store such as Amazon by searching for 'powered usb 3.0 hub'.  Good luck! 

          • 2. Re: Depth not working on SR300, Windows 10 builds 14393 and still on Creator update 15063
            KFindlater

            Thanks Marty,

            I don't have another PC to test on, only this laptop. I'll try getting a USB 3.0 powered hub. I will have it delivered tomorrow so i'll report back then.

             

            I have two colleagues (on another continent) who have no issues using SR300 on Build 15063, so there is definitely some other nonsense going on.

            • 3. Re: Depth not working on SR300, Windows 10 builds 14393 and still on Creator update 15063
              KFindlater

              I can confirm that when the SR300 is plugged in to a powered hub, REGARDLESS if the powered hub is even connected to mains, the SR300 is now able to start up the depth stream successfully each time.

               

              The solution is simply connecting the SR300 to a USB 3.0 hub, powered or not, rather than directly to the USB 3.0 ports on the laptop/PC  which is having the issues.  I have seen others mentioning this solution as well, and I can confirm it.

               

              As an electronics engineer, my theory is that the decoupled circuitry (using the hub's power distribution and capacitors rather than your built in USB 3.0 controller's circuitry) is able to handle the start-up surge current of the two IR cameras plus the IR laser projector turning on. I wonder if the windows drivers are in the background changing how much current is available at the USB 3.0 ports (these are usually smart, controllable devices with programmable current limits, usually for power saving and safety). And therefore the behaviour of certain Windows builds may be making minor changes to how USB ports are working, causing this issue? 

               

              Perhaps Intel can fix this by adding more bulk capacitance on the input power for the SR300?

              1 of 1 people found this helpful
              • 4. Re: Depth not working on SR300, Windows 10 builds 14393 and still on Creator update 15063
                MartyG

                Your interpretation of the USB port power statuses is a reasonable one, given the number of times that cameras have worked fine for a while and then suddenly stopped working immediately after a Windows update has taken place.

                 

                I'll pass a link to your message onto the relevant Intel guy so they can pass it along to the RealSense development team if they wish.  Thanks so much for the valuable insights! 

                • 5. Re: Depth not working on SR300, Windows 10 builds 14393 and still on Creator update 15063
                  KFindlater

                  Indeed, I think the USB 3.0 controller drivers could be put in debug mode or checking logs for a simple comparison between what happens when it is directly connected and try to start up the Depth stream versus what messages are shown (should all be good ones) when the SR300 is instead connected through a USB 3.0 hub.

                   

                  would be nice enforce "max power" mode for a selective device ID by default.  Obviously when things were working properly, the hardware at the base level can handle the power, but the intelligent systems behind the hub controllers may be triggering faults due to sudden rush currents and their levels or behaviours might change in certain Windows builds.. and probably go unnoticed in the changelogs because who would suspect USB controller drivers??