9 Replies Latest reply on Aug 3, 2017 6:44 AM by Wazza_BNE

    NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work

    Wazza_BNE

      Hey group!

       

      I'm a bit disheartened with my NUC right now so I hope I'm making sense!

      So many issues with this tiny computer!

       

      Here's the most pressing ones;

       

      1) The ring and power button LEDs only work when showing HDD Activity, they both stay off/black when set thru BIOS to show Power Status. - This started happening after I used F4 BIOS Recovery to update the installed v42 to the latest v48 BIOS.

      2) The F2/F7 etc keys don't work, and never have, during start up to access BIOS etc.. That's why I updated the BIOS in the first place but that didn't help. The only way I can access BIOS settings or BIOS Update is by the Power Button menu or by using the jumper to do a Recovery.  Even when using the Power Button Menu only F2 Setup and sometimes F4 Recovery work, F7 Update never does - it invokes but doesn't do anything, the NUC just boots into Windows.  F7 also fails if I launch it from within Setup, again just booting into Windows.

      3) I can't seem to revert to an older version of the BIOS to see if that fixes the LEDs because I can no longer update it. All recent attempts to recover or update the BIOS now just add another BIOS Flash Failed error in the log then boot straight into the OS.

      4) Getting desperate I tried a jumper Recovery which did work in that it refreshed the BIOS - but fixed nothing - and now I've read that by doing that I've wiped out the unit's HDCP keys which I assume means my NUC can never be used to play HDMI content to a TV? Great.

       

      What a stuff up this has been!  That said, when I allow the machine to boot into Windows it works fine, it's just the BIOS and LEDs that aren't working.

       

      What makes this even more frustrating is that I can find multiple references to all these issues in this and other forums but none of the solutions suggested there have worked... as you can see I've been trying them - for two days! I've reset the BIOS to defaults many times, tried playing around with different combinations of settings for the LEDs in Power setting but the LEDs never work for Power Status, only HDD Activity. To reiterate, they worked perfectly before I updated the BIOS.

       

      From here what I really want is;

       

      - To get the Power LED working as a Power LED.

      - To get BIOS access working thru F2 during POST.

      - To get BIOS updates working, preferably through F7 during POST, or at least understand why they're not.

       

      Any suggestions would be much appreciated!

        • 1. Re: NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work
          lw1948

          My first suggestion is to bring your bios to default settings. Since you have windows installed and working, you can enter your bios from windows (your F2 key doesn't work?). Use the following tutorial to enter bios: Windows 10 Forums . Once you enter bios, press F9 (followed by "Y") to set bios to default settings.

          After setting bios to its default go to Advanced > Power.

          In the Secondary Power Settings pane check if the Ring LED field is set to HDD Activity LED .

          In order to use this Power Button led as power indicator set the Button LED field  to Power State Indicator.

          After making any changes to the LED settings, press F10 (followed by Yes) to save all settings and exit BIOS Setup.

           

          Hope this will solve your problem

          Leon

          1 of 1 people found this helpful
          • 2. Re: NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work
            Wazza_BNE

            Hi Leon,

             

            Thanks for your response.  I haven't described very clearly what I have already tried because my question is a bit of a mess, sorry.

             

            To follow up on your suggestions. I have reset the bios to default settings many times, and have also made the suggested changes to the Secondary Power Settings repeatedly, saving and restarting as needed. None of this has worked. I can change the colour of the LEDs if I set them to HDD Activity but any settings I make when I set them to Power Status are ignored and the LEDs stay black. They worked normally prior to my initial update to v48.

             

            My F2 key works, the NUC just ignores it during POST. I've checked settings related to handling keys during POST and these seem reasonable. I've never changed any of those from their defaults. F2 works if I force the NUC into the Power Button menu. F7 responds only from the Power Button menu too, it just fails to actually update and logs this failure in the event logs. The same USB stick that fails in F7 works in F4 Recovery if I try repeatedly. It's like there's a timing issue or something and occasionally it just happens to be fast or slow enough to work. Perhaps my monitor is too slow at switching modes or something?  I've tried using my TV instead since it's newer than my monitor but it won't even let the NUC into Power Button menu.

             

            Anything else to do or check?

             

            I've noticed others with similar issues which you've given similar answers to but their issues seem to have resolved themselves in various different ways, one by leaving the unit unplugged overnight (which I've tried - twice) or other lucky rather than planned fixes.

             

            I believe there are bugs here that Intel isn't addressing because we're saying issues are solved when they're worked around rather than fixed.

             

            waz.

            • 3. Re: NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work
              N.Scott.Pearson

              I have some questions...

               

              1. Have you tried setting Ring LED to follow power and Button LED to disk activity?

               

              2. What memory are you using?

               

              3. What keyboard are you using? [Hint: there are known issues with some Logitech wireless keyboards]

               

              You only have to worry about HDCP keys if you have actually put them in (in which case you have them to put back in).

               

              ...S

              • 4. Re: NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work
                Wazza_BNE

                Hey there,

                 

                Thanks for the clarification about the HDCP keys.

                 

                To answer your questions;

                 

                I've tried using both LED ring and Power Button LEDs for Power Status, both for HDD access, and one for each. Both work for HDD access, neither works for Power Status. So long as I use both for HDD access I can set colours etc. and they work.

                 

                My RAM is;

                2 x SODIMM DDR4 8GB 2133MHz Crucial RAM for Notebooks

                 

                My keyboard is indeed a Logitech wireless but I have  also tried wired Microsoft keyboard and mouse with no change.

                 

                The monitor is a ten year old LG, the TV a 5 year old Panasonic. I have no other HDMI capable displays.

                 

                Does any of this give you any ideas?

                 

                Waz.

                • 5. Re: NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work
                  N.Scott.Pearson

                  Well, there are only two possible reasons for why you cannot get into BIOS Setup (Visual BIOS),

                   

                  1. The BIOS is having a problem with keyboard detection (this is the situation with some Logitech wireless keyboards - including the K410 that I bought a whole bunch of (Grrrr) - and the issue exists in multiple generations of the NUC).
                  2. The primary monitor cannot display in 1024x768 mode.

                   

                  What are the model numbers for the LG monitor and Panasonic TV? Have you tried using the monitor in DVI mode (i.e. via DP-to-DVI or HDMI-to-DVI adapter)?

                   

                  As for the issue with the LEDs, my standard response to this (which, unfortunately, I think you have already tried - but do so again please) is to:

                   

                  1. Install the latest BIOS using the jumper-based Recovery Method (see here: Intel NUC BIOS Recovery Update Instructions).
                  2. Enter BIOS Setup. Use F9 followed by 'Y' and then F10 followed by 'Y' (this sets the BIOS configuration to defaults and saves it as-is).
                  3. As the system reboots, power it off and disconnect it from A/C for a minute or two.
                  4. Reconnect and power back on. Enter BIOS Setup. Make your desired changes to the LED programming. Also make any other changes (boot order, etc.) that you need for your H/W configuration. Exit BIOS Setup saving BIOS configuration.

                   

                  This *should* (touch wood) clear the issue and get the LEDs working properly.

                   

                  Hope this helps,

                  ...S

                  • 6. Re: NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work
                    Wazza_BNE

                    Thanks S

                     

                    Yeah. Just to be sure I tried all those steps again.  No change.

                     

                    I also tried reverting to BIOS 45 (the oldest available) but that fires a FwUpdateFullBuffer error when trying to flash it (via all methods) and thus fails, and so appears not to be an option.

                     

                    I reflashed v48 just to see if that might help.  It didn't.

                     

                    What really annoys me about this is that if you search the internet I am not the only person with any of these problems.  Although I do seem to be the only person with ALL of them! LOL.

                    Pity, I want to really like the NUC because it seems aesthetically well designed and it's tiny.

                     

                    My last option is going to be to remove the CMOS battery for an hour - I understand its on the CPU side of the mobo... wish me luck. 

                     

                    I'll report back how that goes!

                     

                    Waz

                    • 7. Re: NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work
                      N.Scott.Pearson

                      After disconnecting the battery for 15 minutes, I suggest that you (a) go right into the reinstallation of BIOS 48 again, using the jumper-based recovery method and (b) reset the BIOS configuration to factory defaults (and set the date and time). This should ensure that everything that could be in the dependency path has been reset. You shouldn't have to do this, I know, but I *have* seen it make a difference...

                       

                      ...S

                      1 of 1 people found this helpful
                      • 8. Re: NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work
                        Wazza_BNE

                        S,

                         

                        Hey.  So it's been a busy couple of days.  I intended to remove the CMOS battery the other day but was unable to do so because there's just too many little wires attached between the mobo and the front panel.  Also something, I'm not sure what, made the mobo not removable even after removing the screws.  I didn't want to break anything so gave up and reassembled it.  It's a bit silly that the battery is this hard to get to - I guess that's the price for a tiny form factor.

                         

                        Since I had a busy couple of days ahead I left the NUC unplugged and unpowered for what turned out to be 49 hours.  Someone else in this forum had had luck fixing this same issue by simply leaving it unpowered for a prolonged period - but not me. :-(

                         

                        Still no change.  I'm about to give up I think.  I'll probably, sadly, get this NUC replaced under warranty even though I'm 90% sure there's nothing wrong with it.  I had planned to get more of them for a lab setup but that's not looking promising with the NUC proving to be a support nightmare! :-(

                         

                        I'm still open to suggestions and would like to get it working but I've got to move on for now and just chalk this one up to a bad purchasing decision. It'll be a week or two before I can exchange it so any ideas very welcome in the meantime.  Maybe BIOS 49 will come out with a fix :-)

                         

                        W.

                        • 9. Re: NUC7i7BNH power led blank, bios flash failure, F2/F7 at POST don't work
                          Wazza_BNE

                          Hey S!

                           

                          Fun news!  Almost immediately after my last post BIOS v49 appeared, I installed it and ... are you sitting down ... my LEDs all work as they should and the BIOS update actually works!

                           

                          Thanks for everyone's input, you too Leon.  It was frustrating for me and I'm sure I was annoying to you guys too when you can't reproduce the problem!  Anyway, it seems Intel did find a bug and they've fixed it.

                           

                          The solution?  BIOS 0049!

                           

                          Thanks for your patience guys.  Now I can stop fiddling with the BIOS and start setting up my cute little NUC! :-)

                           

                          Waz.