5 Replies Latest reply on Aug 16, 2017 11:38 AM by Intel Corporation

    Intel HD Graphics 630 causes Black Screen at login

    Calobban

      Windows 10 Home edition

      Version 1703, OS Build 15063.483

       

      This morning when I sat down at my computer, it had an empty black screen. Repeated reboot attempts didn't fix it. Each time it rebooted, it would display the initial circling dots for a few minutes, and then go back to black. No cursor, no nothing.

      Finally, I got logged into the computer using Safe Mode, and that worked fine. When I disable (or uninstall and delete) my Intel HD Graphics 630 driver, I can reboot into normal startup with no problems, and everything works fine. Until I try to re-enable (or reinstall) that driver, and then suddenly the whole screen goes black again and I can't do anything but reboot back into Safe Mode and start the whole process all over.

       

      So there definitely seems to be an issue with the driver. However, it doesn't look like the driver has changed at all for months (the last time it was updated was in May). After the problem started, I went and downloaded the latest copy of the driver from the site here, and tried that. But I had the exact same issue, as it went through the install process the dots started ticking away to install the Graphics driver, and then after a dozen or so of them, the screen went to black again and once more I had to start the whole process over.

       

      So, it appears that the problem is with this graphics driver. But as I said, the driver hasn't been updated in May (since I first got this computer), and it's been working fine that whole time. So I kept digging around, and found that although THIS driver hadn't changed recently, there was a long list of new drivers that Windows DID update overnight last night. So I'm assuming that probably one of these is having a conflict with the graphics driver, causing this issue?

       

      Realtek Semiconductor Corp. - MEDIA - 5/2/2017 12:00:00 AM - 6.0.1.8142

      Realtek Semiconductor Corp. - MEDIA - 3/28/2017 12:00:00 AM - 6.0.1.8105

      Qualcomm Atheros Communications Inc. - Net - 8/11/2016 12:00:00 AM - 10.0.0.345

      Canon - Printers - Canon MX920 series FAX

      Logitech - WebCam - Logitech HD Webcam C525

      Logitech - WebCam - HD Webcam C525

      Canon - Printers - Canon MX920 series Printer

      Intel Corporation - Display - 11/11/2016 12:00:00 AM - 21.20.16.4550

      Qualcomm Atheros Communications - Bluetooth Controller - Dell Wireless 1707 Bluetooth 4.0 LE Device

      Realtek - LAN - Realtek PCIe GBE Family Controller

      Western Digital Technologies - Other hardware - WD SES Device

       

      These were the only changes made last night (no other windows updates appear in the update history).

      So, any help suggesting where the problem is? Obviously I've got my computer booted now (without my HD Graphics 630 driver), but that also limits the functionality of the computer, so I'd really rather have that (or some other equivalent) driver back up and running ASAP.

       

      Thanks!