3 Replies Latest reply on Jul 31, 2017 11:59 AM by Intel Corporation

    Cannot set boot order

    renegat

      I have the following problem:

      NUC D54250WYKH with two SSDs:

      One MX100 SATA: Windows7, MBR formatted, legacy boot works when set as primary boot device with boot flag enabled.

      One MX200 mSATA: Linux, GPT but set to 'legacy BIOS bootable'

       

      # sgdisk /dev/sdb --attributes=1:show

      1:2:1 (legacy BIOS bootable)

       

      and it boots flawless syslinux but only when chosen from F10 boot menu at power on or from VisualBIOS directly. From the syslinux menu I can choose and boot linux or windows7 than. That is the intended behaviour.

       

      But when I set the mSATA MX200 in VisualBIOS of NUC as primary boot device via drag and drop to the top of the list of legacy bootable devices (with the boot flag disabled on MX100 (SATA W7)) in boot order and save the setting it always fails and tries to boot W7@MX100 (SATA) -> which than also fails as the boot flag is disabled!

       

      Is there any way to make the VisualBIOS respect the boot order and boot permanently from the msata also its partition table is gpt? (As said: It works flawless using the F10 boot menu or directly from the VisualBIOS but you cannot make this permanent as the 'first boot device' setting is ignored)

       

      Why is it possible to boot 'legacy' from gpt using F10 but not when this device is set as primary boot?

      What am I missing?!

        • 1. Re: Cannot set boot order
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hello renegat,
           
          Thank you for contacting the Intel community.
           
          I’m sorry about the issue you have experience, do you have the latest BIOS installed? If not, you can download it here:
          BIOS Update [WYLPT10H.86A]
           
          Please see F7 BIOS Update Instructions for Intel® NUC
           
          When you drag the SSD to the top from you want to boot from make sure you press F10 on your keyboard to save all changes.
           
          The boot from F10 you will be booting from legacy because UEFI is disabled.
           
          Please let me know how it goes after you do the BIOS update.
           
           
          Regards,
           
           
          Ivan U.
           

          • 2. Re: Cannot set boot order
            renegat

            Hello Ivan U.

            Thank you for responding to my question.

             

             

            The latest BIOS Ver. 0045 is installed.

             

             

            When I change the boot order in VisualBIOS by dragging the SSD to the first position (as legacy with UEFI boot disabled) and save with F10 it will not work. The setting will be safed but ignored.

            When I double click on the SSD in VisualBIOS it works for one time but even if I've choosen 'Save settings' the next time it will fail and the NUC boots from the wrong SSD again.

            When I use the F10 boot menue with legacy boot enabled in VisualBIOS the SSD appears in the boot menue an can be booted.

             

             

            Meanwhile I was able to convert the partition table using 'sgdisk -m' from gpt to mbr: Now it works as expected, the boot order is respected.

             

             

            But with one SSD which has gpt partition table with legacy boot enabled flag set in the partition table (see previous post) and one SSD with mbr partition table you can only boot from the first SSD by using F10 or by double clicking on the entry in the VisualBIOS but you can not make it permanent also the gpt formatted disk appears as legacy bootable device.

            Not really a problem anymore but at least a weird behavior.

            • 3. Re: Cannot set boot order
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Thank you for the information renegat, I’m glad that at least you found a way to make the system boot from the drive you want; I have not seen this behavior with this unit before, what I suspect is that because Linux* was not validated by Intel on this unit the system recognizes the drive with Windows® 7 as the primary boot drive.

              If you need anything else related to this matter please let me know and I will be more than glad to help you.


              Best wishes,


              Ivan U.