5 Replies Latest reply on Jul 28, 2017 4:05 PM by Intel Corporation

    570 Fails To Boot

    sthomps3

      I have a 570 with Ubuntu 16.04 installed. I was working on the platform when it hung while I was trying to log back in. I am unable to boot at all now. When I connect the 12v power supply I am only seeing the MAIN PWR LED. I tried to DNX Boot but that fails to get anywhere as well. I tried to power using USB-C and have had the same result. I have previously seen the platform hang occasionally while idling, but typically it is able to boot up successfully afterwards. Unfortunately, that is no longer the case.

       

      Any suggestions would be appreciated.

       

      Thanks

        • 1. Re: 570 Fails To Boot
          Intel Corporation
          This message was posted on behalf of Intel Corporation

          Hi Sthomps3,

          Thanks for contacting us.

          We’re sorry to hear you are getting that issue with you Joule board. We would like to know a little bit more information and also provide some suggestions that may help:

          Note: The current base-know-configuration release is FW 1J2 + OS 1706

          • Are you receiving any error messages from the serial terminal?


          Moreover, we would like to let you know that the official Joule’s image we support is the Ref-OS-IoT, for that reason we suggest you to try installing that one.

          Regards,
          -Yermi A.

          • 2. Re: 570 Fails To Boot
            sthomps3

            Hi Yermi thanks for the reply.

             

            I am currently unable to update the Joule's BIOS because my host platform is unable to see the Joule in the device manager. It seems to be failing to enter DnX mode. I have tried the flashing BIOS instructions with two different host systems with no luck. The flasher also confirms that the device is not found. Also, there is no activity in the serial terminal. It seems that despite the device appearing to be powered (main power LED is illuminated), it is failing to initiate any type of boot activity.

             

            Last BIOS that was flashed:

            Joule_C0-X64-Release-193_DNX.bin

             

            Thanks

            • 3. Re: 570 Fails To Boot
              Intel Corporation
              This message was posted on behalf of Intel Corporation

              Thanks for the information. It is a strange behavior, could you please double check the following information?

              • Verify that the Intel Joule module is correctly seated on the Expansion board
              • Is your Joule board overheating?
              • Remove the micro SD card if it is not being used


              Regards,
              -Yermi A.

              • 4. Re: 570 Fails To Boot
                sthomps3

                Thanks Yermi,

                 

                Do you suggest trying to re-seat the module on the board?  I saw that there is a tool that we can 3D print to remove the module from the expansion board.

                Removing the Intel® Joule™ Compute Module from the Expansion Board

                The module seems to be secure and seated on the board as it sits now.

                The temperature isn’t increasing at all when the board is powered with the adapter. It didn’t seem to be overheating at the time of the hang. It felt to be the typical temperature that it usually is. The heat sink has always gotten pretty warm but didn’t seem out of the ordinary.

                I removed the SD card and attempted to boot but still no luck.

                A bit before the hang I was trying to detect an accelerometer on the different i2c busses. The last bus I tried was the I2C 1 bus before it hung after idling for a bit. Not sure if there is an issue with the I2C bus connection that could have led to this. The occasional hangs that I saw before occurred with nothing connected to the platform other than a mouse and keyboard via usb hub, so I’m not sure if the sensor connection was the issue. It seems like the module isn't getting power to initiate the boot, despite the fact that the expansion board appears to be powered on.

                • 5. Re: 570 Fails To Boot
                  Intel Corporation
                  This message was posted on behalf of Intel Corporation

                  Thanks for checking that. For this issue we’d recommend you to submit a ticket to the following form: https://customercare.intel.com/?lang=en-US, and the Warranty team will receive the ticket and contact you back to provide further assistance with this issue.

                  Regards,
                  -Yermi A.